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About This Guide
Introduction
The MK1200 MicroKiosk for CE .NET 4.2 Product Reference Guide provides information on installing, operating, 
and programming the MK1200. 

Chapter Descriptions
Following are brief descriptions of each chapter in this guide.

• Chapter 1, MK1200 Introduction, provides an overview of the MK1200 that includes parts of the MK1200, 
features, and scanning modes.

• Chapter 2, Installation, describes the hardware setup and installation of the MK1200.

• Chapter 3, Configuration, describes the configuration parameters of the MK1200.

• Chapter 4, Remote Device Manager, provides information about the Remote Device Manager (RDM).

• Chapter 5, Transferring Files to the MK1200, describes how to use Microsoft® ActiveSync for communication 
between the MK1200 and a host computer. 

• Chapter 6, Web Kiosk Software Suite, describes the free browser-based sample application available for 
download. 

• Chapter 7, System Features, describes the wide range of capabilities used to support independent 
application development on the MK1200.

• Chapter 8, Software Development Environments, describes the software development environments.

• Appendix A, Technical Specifications, provides technical information about the MK1200.

• Appendix B, RF Network Configuration, describes how to configure the Spectrum24 wireless connection.

• Appendix C, Rapid Deployment Client, describes the Rapid Deployment Client and how it facilitates software 
downloads to the MK1200 from a Mobility Services Platform (MSP) Console’s FTP server.

NOTE     Unless otherwise noted, the term MK1200 refers to all configurations of the device.
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• Appendix D, Web Kiosk Software Suite Bar Codes, provides sample bar codes used with the Web Kiosk 
Software Suite.

• Appendix E, Terminal Configuration Manager, provides an overview of the Terminal Configuration Manager 
(TCM), used to specify and load files into the MK1200 flash memory using the MK1200 Initial Program 
Loader (IPL).

• Appendix F, OS Upgrade Procedures, provides instructions on using IPL mode to upgrade flash partitions.

• Appendix G, Troubleshooting, provides troubleshooting procedures for correcting problems encountered with 
the MK1200.

• Appendix H, Setting Scanner Parameters, lists the defaults for all scanning parameters.

Notational Conventions
This document uses these conventions:

• “User” refers to anyone using an application on the terminal.

• “Device” refers to the MK1200.

• Bold text is used to highlight the following:
• Dialog box, window, and screen names
• Drop-down list and list box names
• Check box and radio button names
• Icons on a screen
• Button names on a screen.

• Italics are used to highlight specific items in the general text, and to identify chapters and sections in this and 
related documents.

• Bullets (•) indicate:
• lists of alternatives or action items.
• lists of required steps that are not necessarily sequential.

• Numbered lists indicate a set of sequential steps, i.e., those that describe step-by-step procedures.

NOTE This symbol indicates something of special interest or importance to the reader. Failure to read the note 
will not result in physical harm to the reader, equipment or data.

CAUTION This symbol indicates that if this information is ignored, the possiblity of data or material damage may 
occur.

WARNING! This symbol indicates that if this information is ignored the possibility that serious personal 
injury may occur.
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Related Publications
Following is a list of documents that provide additional information about configuring the MK1200:

• MK1200/MK2200 Quick Reference Guide, p/n 72-88687-xx

• MK1100 PSDK (Platform Software Development Kit)

• MK1100 SMDK (Symbol Mobility Developer Kit) for C

• MK1100 SMDK (Symbol Mobility Developer Kit) for .NET

• MK1100 SMDK (Symbol Mobility Developer Kit) for .WEB

• MSR Magnetic Stripe Reader Quick Reference Guide, p/n 72-54435-xx

• AirBeam Package Builder Product Reference Guide, p/n 72-55769-xx.

• Aegis documentation, available at: http://www.mtghouse.com/

Service Information
If you have a problem with your equipment, contact Motorola Enterprise Mobility Support for your region. Contact 
information is available at: http://www.symbol.com/contactsupport. 

When contacting Enterprise Mobility Support, please have the following information available:

• Serial number of the unit

• Model number or product name

• Software type and version number.

Motorola responds to calls by E-mail, telephone or fax within the time limits set forth in support agreements.

If your problem cannot be solved by Motorola Enterprise Mobility Support, you may need to return your equipment 
for servicing and will be given specific directions. Motorola is not responsible for any damages incurred during 
shipment if the approved shipping container is not used. Shipping the units improperly can possibly void the 
warranty.

If you purchased your Enterprise Mobility business product from a Motorola business partner, contact that business 
partner for support.
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Chapter 1 MK1200 Introduction
Introduction
The MK1200 MicroKiosk provides retail consumers access to data critical to making an informed purchasing 
decision. The MK1200 verifies prices on bar coded merchandise and obtains up-to-the-minute information on 
in-store promotions, and its easy-to-read display can be used as an electronic billboard for instant in-store 
merchandising.

MK1200 Configurations
The MK1200 MicroKiosk is available in the following configurations:

Table 1-1    MK1200 Configurations

Configuration Description

MK1200-0N0DAKBNT0R Wired Ethernet, non-touch screen, 32 MB / 32 MB

MK1200-0N0DAKBWT0R Wired Ethernet, touch screen, 32 MB / 32 MB

MK1250-0N0DAKBNTWR 802.11b, non-touch screen, 32 MB / 32 MB, 
no Ethernet support/chip is present

MK1250-0N0DAKBWTWR 802.11b, touch screen, 32 MB / 32 MB,
no Ethernet support/chip is present
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MK1200 Parts
MK1200 parts include:

• Optional touch screen

• Scanner window

• Function buttons

• Access covers

• External ports.

See Figure 1-1 on page 1-3, Figure 1-2 on page 1-4, and Figure 1-3 on page 1-5 for illustrations. 

LCD

The color 5.7 inch (14.5 cm) diagonal 1/4 VGA passive LCD (320 X 240 pixels) is ideal for presenting text and 
graphics. The optional touch screen accommodates greater user interaction and enhances the capabilities of 
custom designed applications.

Scanner Window

The scanner window protects the scan engine.

Function Buttons

The MK1200 has four programmable function buttons (see Figure 1-1 on page 1-3) identified A, B, C, and D (from 
left to right) for reference purposes in this document, and are not labeled on the MK1200. These buttons are 
programmable for various tasks such as navigating through an application and making decisions when prompted. 
See Remapping Buttons on page 7-8 for instructions on setting the buttons’ values.

Access Covers

The access cover on the back of the MK1200 allows access to the PCMCIA card slot. PCMCIA access is intended 
for development or maintenance purposes only. 
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Figure 1-1    MK1200 Front View
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Figure 1-2    MK1200 Rear View 
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CAUTION *When an access cover is removed, follow proper ESD (Electro-Static Discharge) precautions to 
avoid damaging sensitive components. These precautions include, but are not limited to, working on 
an ESD mat and ensuring that the operator is properly grounded. Failure to apply proper ESD 
precautions can damage the MK1200 and void the warranty.
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Figure 1-3    MK1200 Bottom (Connectors) View 

External Ports

The MK1200 has the following external ports:

• Ethernet / Bias-T (Power-Over-Ethernet)*

• Power

• Printer (RS-232).

*Functional on wired Ethernet MK1200 configurations only, not on MK1250 RF units.

Ethernet/Bias-T

Wired Ethernet: Power via AC Outlet

The Ethernet / Bias-T (10-conductor RJ-45) port accommodates Ethernet data connection. The MK1200 receives 
power via the Symbol approved power supply. 

Wired Ethernet: Power via Power-Over-Ethernet

The MK1200 supports Power-Over-Ethernet (POE), Symbol Technologies' proprietary Bias-T functionality. An 
Ethernet (10 Base-T) cable connected to the Ethernet/Bias-T port provides both data communication and power to 
the MK1200.

Power Port

A Symbol power supply connects to the power port (2.0 mm barrel jack connector) on the MK1200. For more 
information, see Connecting the MK1200 on page 2-7 and Technical Specifications on page A-1.

BIAS-TBIAS-T
ETHERNET/ETHERNET/

VDCVDC
12-2412-24

PRINTERPRINTER

Power

Ethernet/Bias-T*
Printer
(RS-232)

(Port enabled on wired 
Ethernet configurations only)

Debug
(ActiveSync Port)
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Printer (RS-232) 

The Printer (RS-232) port (RJ-45 jack, 10 conductor) is used for serial communication with a host or connection of 
an external device such as a receipt/bar code printer. Confirm the cable pin-outs before attaching the cable. For 
cable pin-outs, see Printer (RS-232) Port Connections on page 2-11.

MK1200 Features

Programmable Function Buttons

The MK1200 has four function buttons that can be programmed to perform various tasks such as navigation 
through an application or selecting between various options. See Figure 1-1 on page 1-3.

Bar Code Scanner

The omni-directional scan pattern decodes all traditional 1D bar codes, and Smart Raster mode decodes 2D 
symbologies such as PDF417. See Bar Code Scanning on page 1-8.

Software

Standard well-supported operating system and development tools ease application development for the Microsoft® 
Windows® CE .NET operating system: Embedded Visual C/C++ 4.0, Visual Studio.NET, and Internet Explorer 6.0.

Optional Touch Screen 

The optional touch screen provides user interaction and enhances the capabilities of custom designed 
applications.

Magnetic Stripe Reader (Optional)

An optional three-track Magnetic Stripe Reader (MSR) module attaches to the MK1200 and adds the ability to read 
the raw data required to process loyalty card and credit card transactions.

Memory

The MK1200 standard system configuration contains 32 MB flash/32 MB DRAM. The flash memory is non-volatile 
and stores system firmware, user programs/data, and persistent system parameters.

The Dynamic Random Access Memory (DRAM) is used for run-time storage of system parameters, user programs, 
and data. DRAM is also used by the system during normal program executions. 

Connectivity Options

MK1200 connectivity options include wired 10 Mbps Ethernet and serial (RS-232) as well as wireless 802.11b 11 
Mbps.
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Expansion Card Slot

The MK1200 contains one Type III Personal Computer Memory Card International Association (PCMCIA) 
expansion slot.

Power Options

Power can be supplied via the standard Symbol approved power supply, or by Symbol’s proprietary 
Power-Over-Ethernet (POE). 

Mounting Options

The MK1200 can be mounted on a wall or pole. See MK1200 Mounting on page 2-3. Alternatively, mount the 
MK1200 using a commercially-available bracket or stand that conforms to the 100 mm Video Electronics Standards 
Association (VESA) Flat Panel Monitor Physical Mounting Interface (FPMPMI™) mounting standards. 

Symbol Mobility Developer Kits (SMDKs)

Three developer kits are available for the MK1200:

• SMDK for C (see Symbol Mobility Developer Kit (SMDK) for C on page 8-2) for developing native C/C++ 
applications

• SMDK for the Web (see Symbol Mobility Developer Kit (SMDK) for the Web on page 8-3) for developing 
browser-based applications

• SMDK for .NET (see Symbol Mobility Developer Kit (SMDK) for .NET on page 8-3) for developing managed 
.NET applications in C# or VB.NET.

NOTE Adding a PCMCIA card to the MK1200 adds flash memory.
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Bar Code Scanning
The MK1200 decodes any traditional retail or PDF417 bar code presented in its field of view. A user-developed 
application running on the MK1200 controls the scan engine and its scanning mode.

Scanning Modes

Table 1-2 lists the MK1200 scan modes.

Scanning Guidelines

When scanning a bar code: 

• Hold the bar code below the scan window at an approximately 45o angle.

• Hold the bar code at an angle which does not cause specular reflection (see Specular Reflection on page 
1-11). 

• Hold the bar code close for small bar codes and farther away for large bar codes.

Table 1-2    Common Scan Modes

Scan Mode Description Scan Pattern

Cyclone 
Omnidirectional 
1D Scan Pattern 
(recommended)

A highly efficient scan pattern which 
decodes 1D symbologies, including 
RSS, in any orientation.
Note: In this mode, the MK1200 does 
not decode 2D bar codes (PDF417).

Always Raster 
Scan Pattern

Directly opens the laser to a full sized 
Raster pattern. Decodes 1D, 
composite codes, and PDF417.

Smart Raster Scan 
Pattern

Creates a single scan line which opens 
vertically for PDF417 symbols using 
the Smart Raster feature. This feature 
autodetects the type of bar code 
presented and adjusts its pattern 
accordingly. This provides optimal 
performance on 1D, PDF417, and 
EAN/UCC.
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Figure 1-4    Scanning with the MK1200

Cyclone Omnidirectional 

In Cyclone Omnidirectional mode the scan pattern decodes standard 1-dimensional symbologies in any 
orientation. This mode cannot be used to decode 2D bar codes (PDF417).

Figure 1-5    Cyclone Omnidirectional Pattern
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Smart Raster

In Smart Raster mode, a single scan line pattern appears and decodes a standard bar code. If a 2D bar code is 
presented, the scanning pattern opens up to a full, optimized raster pattern. 

Figure 1-6    Smart Raster Scanning Pattern

The raster pattern must cover the top and bottom of a 2D symbol. If not, pull the bar code further away until the 
pattern completely covers the bar code. Make sure the scan pattern extends at least three quarters of an inch 
beyond the edges of the bar code.

Figure 1-7    Raster Pattern Expanded Over PDF417 Bar Code

If the vertical scan pattern is not high enough to cover a “tall” PDF417 symbol, move the bar code slowly down 
toward the bottom of the scan beam, keeping the beam horizontal to the rows, then slowly back up to the top. 
Alternatively, move the bar code further away from the scanner until the scan pattern covers a larger portion of the 
bar code in the vertical direction. 

Figure 1-8    Moving Scan Pattern Upward and Downward on “Tall” PDF417 Bar Code

The scan beam does not have to be perfectly parallel with the top and bottom of the symbol (up to a 4o tilt is 
permitted).

Single Scan Line Pattern

Open Raster Pattern

Y-
A

xi
s

Horizontal Displacement (X - Axis)

3/4” 3/4”
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Ensure the symbol is in good condition. 

Specular Reflection

When laser beams reflect directly back into the scanner from the bar code, they can “blind” the scanner and make 
decoding difficult. This phenomenon is called specular reflection. 

To avoid this, scan the bar code so that the beam does not bounce directly back. But don’t scan at too oblique an 
angle; the scanner needs to collect scattered reflections from the scan to make a successful decode. Practice 
quickly shows what tolerances to work within.

Figure 1-9    Avoiding Specular Reflection

When scanning a 1D bar code, there is only a small specular dead zone to avoid (+ 2o from the direct laser beam). 
The specular dead zone is larger for scanning PDF417 (+ 9o from the direct laser beam). However, the scanner is 
not effective if its beams hit the bar code’s surface at an angle greater than 30o.

No specular reflection. 
Decode can occur.

Side Views

Tilt Bar Code At Slight Angle (Up to 30°)

Bar Code

Specular reflection.
Reflected beam is

within specular
dead zone and

prevents decode.
30°

Bar C
ode



1 - 12 MK1200 MicroKiosk for CE .NET 4.2 Product Reference Guide



Chapter 2 Installation
Introduction
This chapter describes MK1200 installation, including:

• Unpacking

• Installation 
• Mounting 
• Providing power
• Communication interfaces
• Installing accessories
• Peripherals

• Connector pin-outs

• Optional accessories.

Unpacking the MK1200
Remove the MK1200 from its packing and inspect it for damage. Keep the packing, it is the approved shipping 
container and should be used if the MK1200 needs to be returned for servicing.
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Installation Overview
To install the MK1200:

1. Select the mounting method (see MK1200 Mounting on page 2-3):
• Wall Mount
• Pole Mount
• Desk Mount.

2. Select the method of supplying power (see Connecting the MK1200 on page 2-7):
• Symbol AC power supply
• Power-Over-Ethernet.

3. Select the data communications method (see Connecting the MK1200 on page 2-7):
• Wired Ethernet (10 Base-T cable)
• Wireless Ethernet (11Mb RF)
• Wired Printer (RS-232, serial cable).

4. Select a printer (see Printers on page 2-10).

5. Configure the MK1200 if necessary:
• For configuration, see Chapter 4, Remote Device Manager, System Menu on page 3-5, or 

<Blue><Italic>Control Panel Configuration Parameters on page -20.

• To access the Windows® CE Desktop, see Accessing the Windows® CE Desktop on page 7-7.
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MK1200 Mounting
If desired, mount the MK1200 on a wall, pole, or counter top using the following optional mounting accessories:

• Wall Mounts
• Pole Mount Kit, see page 2-6.

Figure 2-1    Mounting Dimensions

NOTE The MSR increases the width of the MK1200 from 8.92 inches to 11.5 inches. The height and depth do 
not change.
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MK1200 Wall Mounting Options

Wall mounting options include:

• Free wall-mounting template (shipped with the unit)

• Wall Mount Kit (optional)

• Recessing the MK1200 into a wall (see page 2-5) (optional).

Using the Wall Mount Kit 

1. Determine the MK1200 mounting location.

2. Follow the instructions and use the template provided with the MK1200. Secure the Connector/Port Cover to 
the wall using four screws (not provided) appropriate for the wall material.

3. Connect the cables to the MK1200 (see Figure 2-3 on page 2-5) and ensure the cables are routed and secured 
correctly (see Figure 2-4 on page 2-5). Cables incorrectly mounted or secured can become pinched when the 
MK1200 is attached to the Connector/Port Cover. 

4. To install the Connector/Port Cover, place the keyholes on the back housing over the shoulder head bolts 
protruding from the plate and slide the MK1200 to the left and down to secure in place. See Wall Mounting Kit 
on page 2-4 and Mounting Directions on page 2-5. 

5. Screw one 8-32 pan head screw (lock screw) into the Connector/Port Cover tab (located at the top left corner). 
Hand tighten the screw, or for additional security use a nylon locknut (not included) to prevent removal of the 
device. 

6. Proceed to Connecting the MK1200 on page 2-7.

Figure 2-2    Wall Mounting Kit

Shoulder 

Connector/Port 
Cover Tab

Head Bolts (4)

Lock Screw

Connector/Port Cover
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Figure 2-3    Mounting Directions

Figure 2-4    Cable Routing

Recessed Wall Mounting

To recess the MK1200:

1. Cut an opening in the wall, 8.63" minimum height x 8.0" minimum width.

2. Place the back housing into the opening, following the instructions in Using the Wall Mount Kit on page 2-4. 
See Figure 2-2 and Figure 2-3 on page 2-5. Symbol does not provide hardware to support this installation. 

Move to the left first

Move down
second

Vertical Cable Run

NOTE Recessed mounting may degrade wireless network performance.
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Pole Mounting

The Pole Mounting Kit accommodates poles up to 11.5 inches in diameter. To install the MK1200 using the Pole 
Mounting Kit:

1. Wrap the pole mount straps around the pole and tighten.

2. Secure the connector port cover to the pole mount bracket using the four shoulder screws.

3. Connect the cables to the MK1200 (see Figure 2-3 on page 2-5) and ensure the cables are routed and secured 
correctly (see Figure 2-4 on page 2-5). Cables incorrectly mounted or secured can become pinched when the 
MK1200 is attached to the Connector/Port Cover. 

4. Position the MK1200 keyholes located on the back housing (see Figure 2-2 on page 2-4) over the shoulder 
head bolts and slide the MK1200 to the left and down to secure in place. See Wall Mounting Kit on page 2-4 
and Mounting Directions on page 2-5.

5. Screw one 8-32 pan head locking screw into the pole mount bracket bottom left tab. See Figure 2-5 on page 
2-6. Hand tighten the locking screw, or for additional security use a nylon locknut (not included), to prevent 
removal of the device.

6. Proceed to Connecting the MK1200 on page 2-7.

Figure 2-5    Pole Mount Kit

Pole Mount Bracket: 

Locking Screw

Connector/Port Cover

Shoulder Screws (4)
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Connecting the MK1200
The MK1200 communication interfaces include both wired and wireless solutions:

• Wired Ethernet (10 Base-T cable)
• Power via AC outlet (see below)
• Power via Symbol’s BiasT Power-Over-Ethernet (see page 2-8)

• Wireless Ethernet (11Mb RF)

• Wired RS-232 (serial cable) (see page 2-9).

To configure the communications interfaces, see Chapter 4, Remote Device Manager. To access the Windows® 
CE Desktop, see Accessing the Windows® CE Desktop on page 7-7.

AC Power Supply 

The Symbol universal AC power supply has a positive center pin and the outer tab is ground. It is compatible with:

• 120V 60 Hz (North America)

• 230V 50 Hz (International excluding Japan)

• 100V 50/60 Hz (Japan).

Wired Ethernet Connection

With a wired Ethernet connection, Ethernet-enabled MK1200 models are powered either using the MK1200’s 
Symbol AC power supply, or by Power-Over-Ethernet through the Ethernet cable.

Wired Ethernet: Power via AC Outlet

The MK1200 communicates to the host via a 10 Base-T Ethernet cable and receives power via a Symbol AC 
power supply. 

1. Insert the power supply’s barrel connector into the MK1200’s power port. See Figure 1-3 on page 1-5.

2. Route the power cable. 

3. Plug the Symbol AC power supply into a wall outlet.

4. Connect the Ethernet cable to the LAN port on the MK1200. See Figure 1-3 on page 1-5. Ensure the Ethernet 
cable is terminated according to Table 2-2 on page 2-11.

5. Plug the other end of the Ethernet cable into the host system’s LAN port.
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Wired Ethernet: Power via POE

The POE installation option allows the MK1200 to communicate and receive power on the same 10 Base-T 
Ethernet cable. See Figure 1-6 on page 1-10 and Figure 1-7 on page 1-10.

1. Connect the Ethernet cable to the MK1200 Ethernet / Bias-T port. See Figure 1-3 on page 1-5. 

2. Ensure the Ethernet cable is terminated according to Table 2-2 on page 2-11.

3. Plug the other end of the Ethernet cable into the Bias-T (POE) module.

4. Connect a patch cable from the Bias-T module to the host system’s Ethernet port.

5. Connect the DC power supply to the Bias-T module.

Figure 2-6    MK1200 Power-Over-Ethernet, Network Connectivity

CAUTION DO NOT use POE in conjunction with an external power supply connected to the power port on the 
MK1200. Using two power sources can damage the MK1200 and/or the network.
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Figure 2-7    Alternate MK1200 Power-Over-Ethernet, Network Connectivity

Wired RS-232 Connection

The MK1200 can communicate with a host using a serial cable connected to the Printer (RS-232) port.

1. Insert the power supply’s barrel connector into the MK12000’s power port. See Figure 1-3 on page 1-5.

2. Route the power cable. 

3. Plug the Symbol AC power supply into a wall outlet.

4. Connect the RS-232 serial cable to the Printer (RS-232) port on the MK1200. See Figure 1-3 on page 1-5 for 
port locations. Ensure the cable is terminated according to the Printer (RS-232) Port Connections pin-outs 
described in Table 2-3 on page 2-11.

5. Plug the other end of the serial cable into the host.
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Printers
The RS-232 port can also be used to connect to a printer. For port locations, see Figure 1-3 on page 1-5. Confirm 
the connector pin-out before attaching the cable. See Printer (RS-232) Port Connections on page 2-11. 

1. Attach the printer’s cable to the Printer (RS-232) port on the MK1200. See Figure 1-3 on page 1-5 for port 
locations. Ensure the cable is terminated according to Table 2-3 on page 2-11.

2. Connect the other end of the cable to the printer.

COM Port

Connector Pin-Outs
Table 2-2 and Table 2-3 identify the MK1200 connector pin-outs. See Figure 1-3 on page 1-5 for port locations. 

Figure 2-8    10-Pin Connector Port

Table 2-1    COM Port

COM Port Connector

COM4 RS-232 (no power) Printer (serial)

Pin 10 Pin 1

10-Pin
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Ethernet / Bias-T Port Connections

The Ethernet connector provides both Ethernet signals and power supply voltage to the MK1200 through a single 
Ethernet cable. If providing power to the MK1200 via POE, DO NOT use the Symbol AC power supply.

Printer (RS-232) Port Connections

Use this connector pin-out (RJ-45 jack, 10 conductor) for serial communication with the host or connection to a 
printer.

Table 2-2     Power-Over-Ethernet Connections

Pin Description

Pin 1 Reserved/Do not Use

Pin 2 TXD (+)

Pin 3 TXD (-)

Pin 4 RXD (+)

Pin 5* Bias-T VCC

Pin 6* Bias-T VCC

Pin 7 RXD (-)

Pin 8* Bias-T GND

Pin 9* Bias-T GND

Pin 10 Reserved/Do not Use

* Used only with Power-Over-Ethernet

Table 2-3    Printer (RS-232) Connector: 10-Pin

Pin Description

Pin 1 Not used

Pin 2 Not used

Pin 3 RXD (input)

Pin 4 DSR (input)

Pin 5 RTS (output)

Pin 6 GND

Pin 7 CTS (input)

Pin 8 Not used

Pin 9 TXD (output) 

Pin 10 DTR (output)
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Magnetic Stripe Reader (MSR) Mounting

To mount the optional MSR to the MK1200:

1. Gently place the MK1200 face down on a soft cloth laying on a flat surface, using care not to damage the touch 
panel display.

Figure 2-9    Removal Directions

NOTE The MSR increases the width of the MK1200 from 8.92 inches to 11.5 inches. The height and depth do 
not change.

Move to the right second

Move up first
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2. Remove the three screws shown in Figure 2-10 from the back of the MK1200 and remove the protective cover. 
Retain only the screw from the protective cover. Two new (longer) screws are provided with the MSR.

Figure 2-10    Removing the Cover and Screws

3. Connect the MSR cable to the MK1200.

Figure 2-11    Connecting the MSR Cable to the MK1200

Protective
Cover

Remove
Screws

(3)

CAUTION When removing an access cover, follow proper ESD (Electro-Static Discharge) precautions to avoid 
damaging sensitive components. These precautions include, but are not limited to, working on an 
ESD mat and ensuring that the operator is properly grounded. Failure to apply proper ESD 
precautions can damage the MK1200 and void the warranty.

Connect
Cable
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4. Align the mounting holes on the MSR with the MSR mounting holes on the MK1200 as shown in Figure 2-12.

Figure 2-12    Positioning the MSR on the MK1200

5. Secure the MSR to the MK1200 as shown in Figure 2-13. Use the shorter screw from the protective cover, and 
two new (longer) screws provided with the MSR.

Figure 2-13    Securing the MSR to the MK1200

MSR

Three Screws
Install
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Figure 2-14 shows the MSR mounted to the MK1200 for card reading.

Figure 2-14    View of MSR Mounted to the MK1200
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Installing/Removing the RF Card

To remove and re-install the RF card:

1. Disconnect power from the MK1200.

2. Gently place the MK1200 face down on a flat surface, using care not to damage the display.

3. Remove the PCMCIA access cover.

Figure 2-15    MK1200 Rear View

4. Press the ejector button and remove the RF card.

Figure 2-16    Removing the RF Card from the MK1200

5. Insert the RF card.

6. Re-install the PCMCIA access cover.

NOTE This section applies to factory-shipped RF models only.

PCMCIA Access Cover

CAUTION When removing an access cover, follow proper ESD (Electro-Static Discharge) precautions to avoid 
damaging sensitive components. These precautions include, but are not limited to, working on an 
ESD mat and ensuring that the operator is properly grounded. Failure to apply proper ESD 
precautions can damage the MK1200 and void the warranty.

Ejector button



Chapter 3 Configuration
Introduction
This chapter describes how to set up and configure the MK1200 applications, communications, and network 
settings which include parameters such as the device name, internet browser settings, date and time, and several 
other key settings.

Configure these settings remotely using the Symbol Remote Device Manager (RDM), or locally on the MK1200 
using the System Menu. These settings are saved in the configuration registry file (mkconfig.reg) in the MK1200 
Application folder to maintain them across cold boot cycles.

Remote Configuration using Symbol Remote Device Manager

Use the Symbol Remote Device Manager (RDM) to configure parameters remotely. RDM is a Windows®-based 
utility that runs on a host computer and generates/edits an MK1200 configuration file (mkconfig.reg). Load this file 
onto the MK1200 and reboot the MK1200 to configure the device.

See Chapter 4, Remote Device Manager for more details.

Local Configuration

Using the System Menu (Touch Screen Devices Only)

The System Menu function sets configuration parameters locally on the MK1200. The System Menu is similar to 
the MK1200 Configuration Utility window of the RDM, except the virtual keyboard is used to enter information. 
From within the System menu, use the File > Save option to save the changes and update the configuration registry 
file (mkconfig.reg). The new settings are invoked upon the next cold boot. See System Menu on page 3-5.

Table 3-1    Methods of Configuring the MK1200

Configuration Method Remote Local

Remote Device Manager (RDM) X

System Menu X

Control Panel X
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Using the Microsoft Windows Control Panel

The Control Panel on the MK1200 Start menu changes a limited number of parameters. If desired, use the Control 
Panel to change the functions listed in Control Panel Configuration Parameters on page 3-20; however Symbol 
recommends only changing the Stylus Settings/Touch Screen Calibration, Backlight, and Contrast settings using 
the Control Panel. To save changes to the mkconfig.reg configuration file, select Start > Programs > Save 
Configuration to maintain the settings across cold boot cycles.

Updating the Device Configuration File

Use one of the following methods to update the device configuration file (mkconfig.reg) locally on the MK1200.

• Start > Programs > Save Configuration

Figure 3-1    Save Configuration Screens

The Save Configuration option uses the current registry parameter values and writes them to the mkcofig.reg 
file. The windows shown in Figure 3-1 appear while the file is saved and written. Not all registry values are 
saved with this option; only the registry parameter values that can be configured using the RDM or the 
System Menu (and some system parameters) are written and saved to the mkconfig.reg file.

• Start > Programs > System Menu > File > Save.

Figure 3-2    System Menu Main Screen

This option reads the current content of the mkcofig.reg file, allows user changes, then writes them back to 
the mkcofig.reg file. The window shown in Figure 3-2 reads and displays the current contents of the 

NOTE Touch Screen calibration and Backlight contrast persist regardless of whether you use Save 
Configuration. There are also some Control Panel settings which do not persist across cold boot cycles.
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mkconfig.reg file. Tap an item listed in the left window pane to display current mkconfig.reg file information. 
Edits are permitted to the current file information in the text boxes that appear in the right pane. Tap File > 
Save to save changes and write them to the mkconfig.reg file.

Downloading the Configuration File to the MK1200

Before downloading the configuration file (.reg file) to the MK1200 Application folder, rename it mkconfig.reg. In 
MK1200 Configuration Utility window, select File > Open and select the file, then select File > Save As, rename the 
file mkconfig.reg, and click Save. 

Use one of the following methods to download the file to the MK1200:

• Use the RDM to “push” the file to the MK1200(s) (see Downloading the Configuration File to the MK1200 
Using the RDM on page 4-13).

• Copy the mkconfig.reg file to the MK1200 Application folder using a USB ActiveSync connection (see 
Downloading the Configuration File Using ActiveSync on page 3-3).

• Send the file to the MK1200 Application folder using FTP (see the instructions provided with the FTP 
software) or AirBeam.

• Copy the mkconfig.reg file to a PCMCIA card, then transfer the file into the MK1200 Application folder.

Downloading the Configuration File Using ActiveSync

To copy the mkconfig.reg from the host computer to the MK1200 Application folder (My Computer/Application) 
using ActiveSync:

1. Connect the MK1200 to the host computer by connecting the USB cable (Symbol p/n 25-64626-01R) to the 
ActiveSync (RS-485) port on the MK1200, and the other end to a USB port on the host computer.

2. In ActiveSync on the host computer, click Explore. Windows® Explorer opens the Mobile Device window for the 
MK1200.

3. Open a new Windows® Explorer and browse the host computer to locate the file.

4. Right-click on the file and select Copy. 

5. Right-click in the MK1200 Application folder and select Paste. A prompt requests to overwrite the existing file (if 
present).

NOTE If upgrading the MK1200 OS and a configuration (.reg) file was created using an older OS version, you 
must create a new .reg file (see Creating a Configuration File on page 4-11). For more information about 
upgrades, see Appendix F, OS Upgrade Procedures.

NOTE Use the RDM or System Menu to enable ActiveSync support in the MK1200 if support is disabled.
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Rebooting the MK1200

After downloading the mkconfig.reg file, perform a remote or local cold boot to apply the new settings.

Remote Boot

After loading the configuration file onto the MK1200 using the wired or wireless Ethernet connection, use the RDM 
to send a command over the network to initiate a remote cold boot of the MK1200.

1. Select the MK1200 to cold boot from the list box in the Remote Device Manager screen.

2. From the RDM main toolbar, select Actions > Cold Boot. Allow approximately one minute for the MK1200 to 
reboot and reconnect, then select View > Refresh to verify the device rebooted successfully.

Local Boot

To manually cold boot the MK1200, which enables the settings within the mkconfig.reg file to load, press and hold 
buttons B and C on the MK1200 (see Figure 1-3 on page 1-5) until the display goes blank (typically 15 seconds), 
then release the buttons.

Alternatively, to cold boot the MK1200, select the reboot option from the System Menu File menu.
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System Menu

Setting Defaults Using the System Menu

Use the System Menu to set parameter values locally on the MK1200. See Default Parameters on page 3-6 for 
these options. The System Menu is identical to the RDM Configuration Utility Window for MK1200 devices, and 
provides local instead of remote access to the same parameters. The System Menu modifies parameters in the 
configuration file (mkconfig.reg) on the MK1200.

As with the MK1200 Configuration Utility window, the parameters in the System Menu fall into five categories:

• Configuration file Information

• Applications

• Communications

• System configuration

• Update.

Figure 3-3    System Menu Main Screen

NOTE Saving the System Menu configuration overwrites mkconfig.reg. Reboot the MK1200 to apply the values.

To launch the System Menu, even while an application is running, press the physical buttons A, B, and C 
simultaneously. Use the virtual keyboard to enter data. To launch the virtual keyboard, press buttons B 
and C simultaneously.
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Default Parameters
The default settings that follow apply to both the Remote Device Manager on a host computer and System Menu 
on the MK1200.

Configuration File Information

The first branch of the MK1200 Configuration Utility window and System Menu is Configuration File Information. 
Use this to track mkconfig.reg version information. Table 3-2 provides descriptions for these parameters.

Applications

The second branch of the MK1200 Configuration Utility window and System Menu is Applications. Table 3-3 
provides descriptions and defaults for these parameters.

Table 3-2    Configuration File Version Information Parameters

Configuration File 
Information Parameters Description Default

Configuration File Version Configuration File Version Information

Version Use the Version parameter to specify the version 
number of the mkconfig.reg file.

Description Use the Description parameter to write a detailed 
description of the location, use, and the changes 
made on the deployed mkconfig.reg file.

Table 3-3    Application Default Parameters

Application Parameters Description Default

Internet Explorer Internet Explorer Configuration

Anchor Underline Specifies whether an anchor or link is 
underlined or not.

no

Cache Limit Specifies the cache size for Internet Explorer, in 
kilobytes.

512 kB (0x200 hex)

Search Page Specifies the default search page for Internet 
Explorer.

http://search.msn.com

Secure Protocols Specifies the security settings configuration for 
Internet Explorer.

TLS 1.0 disabled, 
SSL 2.0, SSL3.0 enabled

Smooth Scroll Check to enable smooth scrolling in Internet 
Explorer.

Disabled

Start Page The default home page for Internet Explorer. file:///windows/MK1200.htm

Play Background Sounds Check to enable playing of sound files in an 
html page.

Enabled
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Kiosk IE Kiosk IE Configuration

ErrorRecoveryPage Specifies an error recovery page for Internet 
Explorer. When an error is detected, the 
browser is redirected to this page.

\Windows\RetryPage.html

NeedProgressBar Check to display a progress bar on the left top 
corner of the Kiosk IE which indicates the 
progress of downloading a page to the Kiosk 
IE. Enable this feature when deploying MK1200 
devices in a slow network.

Disabled

Scanner Wedge Scanner Wedge Configuration

Append Enter To Barcode? Check to add an ENTER to the end of each bar 
code. 

Disabled 

Append Tab to Barcode? Check to add a TAB character to the end of 
each bar code (and after ENTER, if enabled). 

Disabled 

Trigger Mode Specifies whether to constantly trigger the 
scanner laser or trigger it manually. 

Manual Trigger 

Scanning Mode Specifies scanner raster mode. Omnidirectional - 1D only 

Prefix Specifies text to add to the beginning of a bar 
code. 

None 

Suffix Specifies text to add to the end of bar code, 
before TAB/ENTER (if enabled).

None 

Transmit Code ID Transmit bar code type identifier. None

Slide Show Slide Show Inactivity Application parameters

Background Color Default screen background color if image is 
smaller than screen. Format is 0BGR, where 
the first byte is zero, and the rest are byte 
values for each color.

7340032 (0x700000 hex)

Display Duration The duration, in seconds, to display each 
image before loading the next image. The 
minimum delay allowed is 2s. If this value is 
less than 2s SlideShow takes delay as system 
default of 5s.

5 (0x5 hex) 

Image Directory The directory that contains the images to 
display.

\Application\Slides

Table 3-3    Application Default Parameters (Continued)

Application Parameters Description Default
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Communications

The third branch of the MK1200 Configuration Utility window and System Menu is Communications. Table 3-4 
describes these wired Ethernet parameters. To configure DHCP options, see DHCP Configuration on page 4-24, 
and to specify RF settings for wireless networks see Specifying RF Settings for Wireless Network Connections on 
page 3-8.

Specifying RF Settings for Wireless Network Connections

To enable a wireless MK1200 to work on an RF network, configure RF settings as defined in Appendix B, RF 
Network Configuration.

Two utilities are available for specifying wireless security:

• Aegis Client (page B-2)

• Mobile Companion (page B-3).

RF devices shipped with a wireless card include both the Aegis Client and Mobile Companion pre-installed. The 
default client is Aegis.

Table 3-4    Communication Default Parameters

Communication Parameters Description Default

Onboard Wired Ethernet Onboard Wired Ethernet Configuration

Enable DHCP Check to turn on DHCP Address resolution. 
When checked, do not set IP Address, Subnet 
Mask, Gateway, DNS Server(s), or WINS 
Server(s).

Enabled

IP Address Sets the IP Address for the Onboard Wired 
Ethernet adapter.

None

Subnet Mask Sets the subnet mask for the Onboard Wired 
Ethernet adapter.

None

Default Gateway Sets the Default Gateway for the Onboard 
Wired Ethernet adapter.

None

DHCP Options Opens DHCP Options dialog (see DHCP 
Configuration on page 4-24).

None

DHCP Server Specifies DHCP server. The device contacts 
the specified server for retrieving IP address 
and other network parameters. If the DHCP is 
not specified, device automatically broadcasts 
for the server for retrieving IP address.

None

DNS Domain The domain name for the Onboard Wired 
Ethernet adapter.

None

DNS Server(s) A list of DNS servers, in the order to query. None

WINS Server(s) A list of WINS servers, in the order to query. None

NOTE RF settings are not stored within the mkconfig.reg file or entered via the RDM. For details on configuring 
RF settings, see page B-3.
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System Configuration

The fourth branch of the MK1200 Configuration Utility window and System Menu is System Configuration. Table 
3-5 lists these parameters and their descriptions. Also see:

• Device Activity Management (Sleep/Wake-up Functionality) on page 3-17

• Printing on page 3-17

• Configuring User Application(s) on page 3-18.

Table 3-5    System Configuration Default Parameters

System Configuration 
Parameters Description Default

ActiveSync ActiveSync Configuration

EnableActiveSync When an application is running, 
ActiveSync is enabled at all times.

Enabled

Backlight Backlight Configuration

Brightness Default display backlight brightness. Bright (maximum)

Buttons Configuration of MK1200 four buttons. See Table 7-6 on page 7-9.

Button A Button A default 38 (0x26 hex) Up

Button B Button B default 40 (0x28 hex) Down

Button C Button C default 37 (0x25 hex) Left

Button D Button D default 39 (0x27 hex) Right

Button A and B Button A and B default 13 (0xd hex) Enter

Button A and C Button A and C default 194 (0xc2 hex) Shift-Tab

Button B and C Button B and C default 199 (0xc7 hex) Input Panel

Button A, B, and C Button A, B, and C default 197 (0xc5 hex) System Menu

Button A and D Button A and D default 18 (0x12 hex) Alt

Button B and D Button B and D default 9 (0x9 hex) Tab

Button A, B, and D Button A, B, and D default 195 (0xc3 hex) Alt-Down

Button C and D Button C and D default 27 (0x1b hex) Cancel/ESC

Button A, C, and D Button A, C, and D default 196 (0xc4 hex) Calibration

Button B, C, and D Button B, C, and D default 8 (0x8 hex) Backspace

Button A, B, C, and D Button A, B, C, and D default 198 (0xc6 hex) Signal Strength

Trigger Time Button combination trigger time, in 
milliseconds. Specifies the maximum 
time between button presses for them to 
be considered a button combination.

500 (0x1f4hex)
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Button Security Enables/disables the button security 
functionality on the MK1200 device.
Check to lock the buttons. These can 
only be unlocked by entering the button 
security password.

Enabled

Date and Time Settings Date and Time Configuration

Time Zone Standard time zone. Drop-down list of 
time zone names, such as "Pacific 
Standard Time", or "South Africa 
Standard Time". Select the appropriate 
time zone.

Pacific Standard Time

Daylight Saving Daylight Saving Configuration

AutoDST Check to enable daylight saving time for 
the current time zone. 
Use this setting for non-explorer.exe 
based application. When enabled, the 
Windows Explorer shell uses this setting 
to set the system time for daylight saving. 
Use this setting if the application runs 
with the Windows Explorer shell.

Enabled

HomeDST Check to enable daylight saving time for 
the current time zone. 
Use this setting if application does not 
run with Windows Explorer shell, for 
example when developing a browser 
(Kiosk IE) based application.

Enabled

Device Activity Management There are three slots with identical parameters:
First Activity Configuration
Second Activity Configuration
Third Activity Configuration
See Device Activity Management (Sleep/Wake-up Functionality) on page 
3-17.

Items Devices to apply activity scheme to. All

Days Set of days on which to apply this activity 
scheme (Monday through Sunday).

None

On Time Time when device is activated, using 24 
hour clock representation. Set this value 
for correct functioning of the Device 
Activity Manager.

None

Table 3-5    System Configuration Default Parameters (Continued)

System Configuration 
Parameters Description Default
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Off Time Time when device is deactivated, using 
24 hour clock representation. Set this 
value for correct functioning of the Device 
Activity Manager.

None

Error Reporting Error Reporting Configuration

Low Memory Settings Configuration of Low Memory Settings

Object Store Min Size Minimum size of object store to allow 
RAM to borrow from it.

1048576

RAM Expansion Block Size System adjusts RAM/Object Store 
percentage to provide more RAM in low 
memory conditions. Values range from 
64K to 1MB. Set to 0 to disable RAM 
expansion.

1048576

Show Error Messages Determines whether the system displays 
dialogs when low memory problems 
occur. 

Disabled

Identification General Configuration

Name Specifies device name. None

Description Specifies device description. None

Contact Contact details of the system 
administrator.

System contact here

Location Specifies the location of the device. Device location here

Configuration Group 1 First user-definable string. Intended for 
use when grouping devices to aid 
configuration. Can be used as part of 
device filter in RDM.

None

Configuration Group 2 Second user-definable string. Intended 
for use when grouping devices to aid 
configuration. Can be used as part of 
device filter in RDM.

None

Inactivity Manager Inactivity Manager Configuration 
(see Inactivity Application (Screen Saver) on page 7-12)

Inactivity Application Name Inactivity application. \\Windows\\SimpleSaver.exe

Idle Time Before Launch Idle time before inactivity application 
launches, in seconds.

0 (0x0 hex)

Table 3-5    System Configuration Default Parameters (Continued)

System Configuration 
Parameters Description Default
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Memory Allocation Memory Partition of Storage Memory and System Memory

SystemStorePercent Percentage of memory used for the 
storage memory. The remaining memory 
is allocated to program memory (memory 
used to run programs). Half the unused 
RAM is used, when the value assigned to 
SystemStorePercent does not provide 
enough memory for the device to operate 
normally. This parameter only configures 
unused RAM.

50 (0x32 hex)

Network Time Update Configuration of Simple Network Time Protocol service (see Network 
Time Update: SNTP Client on page 7-10 for details)

Time Server Specifies the domain name of the time 
server to contact for updates. If no time 
server is set in the field, the time service 
is disabled.
Do not set an IP address for this 
parameter.
If the MK1200 is unable to obtain a time 
value from the time server, it uses the 
default setting (June 1, 1999 12:00:00 
PM), and does not re-attempt to acquire 
a time value unless a regular update is 
also configured (the next attempt occurs 
at the configured time).

tock.usno.navy.mil

Refresh Specifies the time period, in milliseconds, 
between synchronizations with the SNTP 
server.

1209600000 (0x48190800 hex)

Recovery Refresh Specifies the time period, in milliseconds, 
until next synchronization, if the previous 
synchronization attempt failed. 

86400000 (0x5265c00 hex)

Threshold Specifies the interval between the time 
on the SNTP server and the current time 
in milliseconds. If the difference between 
the SNTP server time and the local 
system time is larger than the specified 
value in Threshold parameter, the update 
is ignored unless the system clock is 
presumed incorrect.

86400000 (0x5265c00 hex)

Table 3-5    System Configuration Default Parameters (Continued)

System Configuration 
Parameters Description Default
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Printer Configuration Printer Configuration (see Printing on page 3-17)

Active Printer Use this parameter to set the active 
printer. Select the printer from the list.

Zebra (QL320, Cameo, Encore)

Zebra QL Series Specifies the baud rate for the selected 
active printer if the selected active printer 
is a Zebra QL Series printer.

19200

Zebra QL Series Flow Control Specifies the flow control of the active 
printer if the selected active printer is a 
Zebra QL Series printer.

None

Zebra EPL Series Specifies the baud rate of the active 
printer if the selected active printer is a 
Zebra EPL Series printer. For a list of 
supported EPL printers, see Printing on 
page 3-17.

9600

Zebra EPL Series Flow Control Specifies the flow control of the active 
printer if the selected active printer is a 
Zebra EPL Series printer. For a list of 
supported EPL printers, see Printing on 
page 3-17.

None

Zebra ZPL Series Specifies the baud rate of the active 
printer if the selected active printer is a 
Zebra ZPL Series printer. For a list of 
supported ZPL printers, see Printing on 
page 3-17.

9600

Zebra ZPL Series Flow Control Specifies the flow control of the active 
printer if the selected active printer is a 
Zebra ZPL Series printer. For a list of 
supported ZPL printers, see Printing on 
page 3-17.

None

Epson TML90 Specifies the baud rate of the active 
printer if the selected active printer is a 
Epson TML90 printer.

9600

Epson TML90 Flow Control Specifies the flow control of the active 
printer if the selected active printer is a 
Epson TML90 printer.

None

Epson TMT88III Specifies the baud rate of the active 
printer if the selected active printer is a 
Epson TMT88III printer.

9600

Epson TMT88III Flow Control Specifies the flow control of the active 
printer if the selected active printer is a 
Epson TMT88III printer.

None

Table 3-5    System Configuration Default Parameters (Continued)

System Configuration 
Parameters Description Default



3 - 14 MK1200 MicroKiosk for CE .NET 4.2 Product Reference Guide
Protected Mode Gate Keeper Configuration 
(see Password Protection (Gate Keeper) on page 7-7)

Password Required for Protected Mode access. 
Buttons are assigned numeric values 
from left to right (A=1, D=4).

44213 (denoted with *****)

Application Application to run in Protected Mode. \windows\explorer.exe

Regional Settings - General HTML in web pages does not use regional settings without programmatic 
support. To use regional settings, script in web pages must format dates, 
times, currency, and numbers using built-in functions that take the regional 
settings into account. This is the only method of using the regional settings in 
a browser. 
C/C++ apps can use regional settings through the standard Windows CE 
API.

Regional Settings - Date Configuration of Date Regional Settings

Long Date Long date format. dddd, MMMM dd, yyyy

Short Date Short date format. M/d/yyyy

Short Date Separator Character uses as the short date 
separator.

/

Regional Settings - Time Configuration of Time Regional Settings

PM indicator PM indicator. PM

AM indicator AM indicator. AM

Time Separator Time separator (generally 1 character). :

Leading Zero Display leading zero for 
hours/minutes/seconds.

Disabled

Time Format Time format. h:mm:ss tt

Regional Settings - Currency Configuration of Currency Regional Settings

Digits In Group Number of digits allowed in a group. 0

Grouping Symbol Digit grouping symbol (generally zero or 
one character).

,

Digits After Decimal The number of digits allowed after a 
decimal point.

0

Decimal Symbol Decimal symbol (one character). .

Negative Format Format for negative currency values. The 
asterisk (\"*\") denotes the universal 
currency symbol. The period (\".\") 
indicates the chosen decimal separator.

(*1.1)

Table 3-5    System Configuration Default Parameters (Continued)

System Configuration 
Parameters Description Default
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Currency Symbol Position Position of currency symbol. The asterisk 
(\"*\") denotes the universal currency 
symbol. The period (\".\") indicates the 
chosen decimal separator.

*1.1

Currency Symbol Currency symbol. $

Regional Settings - Numbers Configuration of Number Regional Settings

List Separators List separators (character). None

Measurement System Measurement system. Metric

Display Leading Zero Display leading zero. Enabled

Negative Number Format Negative number format. The period 
(\".\") indicates the chosen decimal 
separator.

-1.1

Negative Sign Negative sign (generally one character). -

Digits In Group Number of digits in group. 3

Grouping Symbol Digit grouping symbol (generally zero or 
one character).

,

Digits After Decimal The number of digits allowed after a 
decimal point.

0

Decimal Symbol Decimal symbol (one character). .

Screen Taps Screen Tap Configuration

Double-Click Distance Specifies the maximum number of pixels 
between two screen taps to qualify the 
screen taps as a double-click. Use this 
parameter to differentiate double-clicks 
from screen taps.

6 (0x6 hex)

Double-Click Speed Specifies the maximum number of 
milliseconds between two screen taps to 
qualify the screen taps as a double-click. 
Use this parameter to differentiate 
double-clicks from screen taps.

500 (0x1f4 hex)

Table 3-5    System Configuration Default Parameters (Continued)

System Configuration 
Parameters Description Default
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User Apps There are seven user application slots, with identical parameters. Each slot 
is under a group called “X Application Launched”, where “X” is First, Second, 
etc.
See Configuring User Application(s) on page 3-18 for details.

Application Path Full path to application. First application slot:
\windows\explorer.exe 
Remaining slots: None

Arguments Command line arguments for the 
program (UNICODE string).

None

Delay Before Launch Number of seconds to delay before 
launching program.

0x0

Waiting For Completion Specifies whether to wait for program to 
complete before proceeding.

Disabled

Volume and Sounds Volume and Sound Configuration

Button Press Sounds Configuration of Button Press Sounds

Duration Duration of time to play the sound in 
milliseconds (ms). Value must be 
non-zero before you can hear sound.

8 ms

Frequency Frequency of sound to play in Hertz (Hz). 400 Hz

Volume Volume of sound to play when you press 
a button (single or combination). Set to 0 
to disable button press sounds.

Medium

Scanner Beep Configuration of Scanner Beep

Volume Volume of scanner beep on a good 
decode.

High

Screen Tap Sounds Configuration of Screen Tap Sounds

Duration Duration of time to play the sound in 
milliseconds (ms). Value must be 
non-zero before you can hear sound.

8 ms

Frequency Frequency of sound to play in Hertz (Hz). 400 Hz

Volume Volume of sound to play when you tap 
the screen. Set to 0 to disable screen tap 
sounds.

Medium

Web Server Web Server in MK1200 Configuration

Enable WebServer Enables/disables the Web Server in the 
device.

Enable

Table 3-5    System Configuration Default Parameters (Continued)

System Configuration 
Parameters Description Default
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Device Activity Management (Sleep/Wake-up Functionality)

Use the Device Activity Manager to manage the device usage profile and lifecycle by turning on/off the scan engine 
laser and the display backlight. Set the sleep and wake-up times by day, weekday, weekend, etc. When setting the 
time, use the 24-hour clock in the format hh:mm.

If the Device Activity Manager (DAM) puts the scan engine and/or backlight into sleep mode, these subsystems 
repower (wake up) upon the following events:

• a button press

• a display touch.

The DAM only checks whether to turn devices on or off when the Inactivity Application Timeout expires. If a device 
wakes up due to user input (a “wakeup”), it remains awake regardless of user input until another timeout expires, 
then goes back to sleep.

To use the DAM without the Inactivity Application Manager, configure the Inactivity Application Timeout to the 
default wakeup time and set the Inactivity Application parameter to nothing.

Printing

The MK1200 supports printing text, bar codes, and bitmaps in the following environments:

• Browser applications

• C/C++ applications.

The MK1200 transmits data to a printer using an RS-232 serial connection. RS-232 serial port settings (port, stop 
bits, data bits, parity) are shared with the tethered scanner. Table 3-5 contains the default baud rate settings for the 
following printers:

• Zebra (QL320, Cameo, Encore)

• Zebra (LP2824/TLP2844)*

• Zebra EPL Series (LP/TLP 2824, LP/TLP 2844, TLP 3842)

• Zebra ZPL (LP/TLP 2844-Z, TLP 3844-Z)

• Epson TML90

• Epson TMT88III.

* Zebra LP printers ship in Gap mode. If using a printer in Continuous Paper mode, the autosense does not work 
and you must manually set the gap to zero. To avoid this, send a command to the printer to change the mode. 
Refer to the Zebra printer documentation.

NOTE It is strongly advised to use the Device Activity Management functionality.

NOTE Use the RDM or System Menu to set up the Device Activity Manager. Enter valid values to all DAM 
parameters (see page 3-10). Otherwise the system rejects the input values and the DAM does not invoke 
the Inactivity Application.
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Advanced Printer Monitoring Functionality

For some printers, such as the Zebra QL Series, the MK1200 supports advanced printer monitoring functionality, 
such as:

• Detecting if the printer cable is connected

• Detecting if the printer power is on

• Detecting if the printer is out of paper

• Detecting if the printer door is open.

Configuring User Application(s)

The MK1200 Configuration Utility window configures the launching of user application(s). The seven definable 
application "slots" are processed upon power up. Programs launch in sequence with no delay, unless you set the 
Delay Before Launch or Waiting For Completion parameter.

The Startup program supports four parameters for each slot, detailed in Table 3-6: executable path, command line 
arguments, delay before running, and a special flag.

Reliable Sequencing of Application Programs

Use the Delay Before Launch and Wait for Completion parameters to set the startup process parameters:

• If an application requires a definitive order of execution

• To provide a signal between components to detect failures

• To verify that local or networked resources are available before the main application launches.

Use the Delay Before Launch parameter to achieve a delay in the launch sequence. However, this is not a robust 
way to ensure correct system operation. The recommended method is to write a separate program, with or without 
a user interface, that performs required checks then terminates, possibly setting a registry value or filesystem flag 
to indicate success. Set the Wait For Completion flag and run this program before running the main application(s).

Table 3-6    User Applications, Parameter Descriptions

Parameter Description

Application Path The full “run” path to the executable. Define this in order to process the entry (i.e., do 
not just specify a delay). File type associations are not supported. For example if the 
Argument contains a word document, specify the full path to wordpad.exe in the 
Application Path. 

Arguments Optional. Command line arguments for the program above. Escape double quotation 
marks using a back slash character, as in \". Also escape back slashes, i.e., \\. 

Delay Before Launch Optional. Specifies the number of seconds to delay before launching the User 
Application, if a previous program needs to complete or to ensure system resources are 
available. This is a simple way to handle sequencing; see Reliable Sequencing of 
Application Programs on page 3-18 for more complex situations (requires “wait for 
completion”).

Waiting For Completion Specifies whether the startup sequence waits for this program to complete before 
launching the next one, typically set to FALSE. See Reliable Sequencing of 
Application Programs on page 3-18.
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Update

The fifth branch of the MK1200 Configuration Utility window and System Menu is Update. The default parameters 
are listed in Table 3-7.

Table 3-7    Update Default Parameters

Update Parameters Description Default

FTP Server FTP Configuration

Allow Anonymous Determines whether the server allows anonymous 
access.

Enabled

Allow Anonymous Upload Determines whether authorization is required for 
uploading files to server.

Enabled

FTP Enable Part I Determines whether the FTP server is 
loaded/accessible when the kiosk is powered on. 
Note that disabling this parameter has no impact on 
the ability to load or retrieve mkconfig.reg files via 
the Remote Device Manager's Push Configuration 
File and Retrieve Remote Configuration File 
functionality.

Enabled

FTP Enable Part II Enabling this parameter allows the RDM to 
load/retrieve a mkconfig.reg file even if the kiosk's 
FTP server is disabled (FTP Enable Part I = 
disabled). If this parameter and FTP Enable Part I 
are both disabled, you cannot load an mkconfig.reg 
file remotely via the Configuration Utility or FTP. 
You can still load an mkconfig.reg file locally via an 
ActiveSync connection or a PC card.

Enabled

Root Directory Directory and subdirectories of this key are 
accessible remotely. If this value is not set in the 
registry, the default is \Temp.

\

Use Authentication Determines whether authorization is required to 
connect to the server.

Disabled

User Authentication Domain Domain that holds information on authentic users 
that are allowed to access FTP service from the 
server.

None

User List List of users able to access the FTP server. None
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Control Panel Configuration Parameters
On touch-enabled configurations, when using the Windows® desktop Control Panel to modify certain MK1200 
configuration settings, select Start > Programs > Save Configuration on the MK1200 to save certain parameter 
changes to the mkconfig.reg file and retain them across power cycles. If not saved, the MK1200 defaults to the 
original mkconfig.reg parameter values upon the next power sequence. 

The Control Panel can set the following options:

• Backlight and Contrast Settings on page 3-20

• Button Definitions on page 3-21

• Date and Time on page 3-21

• Inactivity Manager on page 3-22

• Gate Keeper (Password Protection) on page 3-23

• Stylus Settings/Touch Screen Calibration on page 3-23

• Regional Settings on page 3-25

• Memory Allocation on page 3-26.

For best results, use the system menu for all permanent changes (except recalibrating the touch screen).

Backlight and Contrast Settings

To change the backlight intensity on the MK1200:

1. Tap Start > Settings > Control Panel.

2. Double-tap the Backlight & Contrast icon from the Control Panel window.

Figure 3-4    Backlight & Contrast Screen

3. Select the backlight intensity by tapping the radio button.

4. If necessary, change the contrast by tapping the arrows next to the Contrast field.

5. Tap OK or X to close the screen to apply the selection.
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Button Definitions

To change the button mapping on the MK1200:

1. Tap Start > Settings > Control Panel.

2. Double-tap the Button Definitions icon from the Control Panel window.

Figure 3-5    Button Definitions Screen

3. Tap on the button to remap. The button’s current hex code appears in the text box.

4. Using the input panel, enter the new value of the hex code in the text box to remap the button. Also use this 
option to remap button combinations. See Table 7-6 on page 7-9 for correct key codes.

5. To change the buttondown delay, enter the new value using the input panel.

6. Tap OK or X to close the screen and apply the selection.

7. Tap Start > Programs > Save Configuration to save the new settings in the MK1200 configuration (mkconfig.reg) 
file.

Date and Time

To set the date/time on the MK1200:

1. Tap Start > Settings > Control Panel > Date/Time icon.

2. Double-tap the Date/Time icon from the Control Panel window. The Date/Time Properties screen appears.

Figure 3-6    Date/Time Properties Screen

3. To set the month, tap the arrows on either side of the month shown, or select the month label to choose from a 
list of months.
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4. To select a date, tap the date in the calendar.

5. To set the current time, highlight the hours, minutes, seconds, or AM/PM field in the Current Time field. Tap the 
up/down scroll arrows to change the highlighted selection.

6. To change the time zone, use RDM.

7. Tap Apply to apply the new date/time settings.

8. Tap Start > Programs > Save Configuration to save the new settings in the MK1200 configuration (mkconfig.reg) 
file.

Inactivity Manager

To set up the inactivity manager:

1. Tap Start > Settings > Control Panel.

2. Double-tap the Inactivity Manager icon.

Figure 3-7    Inactivity Manager Screen

3. Select the application to run during inactivity by tapping the  button. (The default application is 
SimpleSaver.exe.)

4. Enter the timeout value (in seconds). The default is 0, which allows the system to run continuously without 
entering inactivity mode.

5. Tap OK.

6. Tap Start > Programs > Save Configuration to save the settings in the MK1200 configuration (mkconfig.reg) file.

NOTE The date resets to June 1, 1999, 12:00 PM upon a cold boot. Use the Control Panel or the SNTP Client to 
update this (see Network Time Update: SNTP Client on page 7-10).

To permanently set the time zone and daylight saving settings, use the RDM or System Menu on the 
MK1200.
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Gate Keeper (Password Protection)

To run an application in protected mode:

1. Tap Start > Settings > Control Panel.

2. Double-tap the Gate Keeper icon from the Control Panel window. The Gate Keeper screen appears.

Figure 3-8    Gate Keeper Screen

3. Select the application to run in protected mode by tapping the  button. 
Note: Changing this application is not recommended. Errors in this configuration parameter or the program 
that is run can prevent troubleshooting or interacting with the MK1200 in protected mode.

4. Specify the password to access protected mode, and enter it a second time to confirm it.

5. Tap OK.

6. Tap Start > Programs > Save Configuration to save the new settings in the MK1200 configuration (mkconfig.reg) 
file.

Stylus Settings/Touch Screen Calibration

The double-tap speed and calibration setting are factory-set. To recalibrate the Stylus settings:

1. Tap Start > Settings > Control Panel > Stylus. 

Figure 3-9    Stylus Properties Screen - Double-Tap Tab

2. On the Double-Tap tab, double-tap the checkerboard grid at a comfortable speed.

NOTE When Button Security is enabled, a password is required to access functionality launched by the physical 
buttons.

NOTE This section applies to touch screen units only.
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3. Double-tap the clapboard to test the settings. If the icon does not change, adjust the settings on the 
checkerboard and test the settings again. 

4. If the MK1200 is not responding properly to taps, tap the Calibration tab to calibrate the screen.

Figure 3-10    Stylus Properties Screen - Calibrate Tab

5. Tap the Recalibrate button and follow the directions on the screen.

Figure 3-11    Calibrate Screen

6. The system returns to the Stylus Properties screen when calibration completes. To cancel calibration, press the 
C and D buttons simultaneously.

7. Tap OK on the Stylus Properties screen. 
Note that calibration values are stored separately from other configuration settings in non-volatile storage and 
cannot be accessed by the user.

NOTE Alternatively, to access the Calibrate screen simultaneously press the buttons A, C, and D (see Figure 
1-1 on page 1-3).



Configuration 3 - 25
Regional Settings

To set up or change regional settings:

1. Tap Start > Settings > Control Panel > Regional Settings icon.

Figure 3-12    Regional Settings Properties Screen - Regional Settings Tab

2. On the Regional Settings tab, in Your locale (location), select the region to use for date, time, number, and 
currency formatting from the drop-down list.

3. To change the way numbers appear, tap the Number tab and make the changes.

Figure 3-13    Regional Settings Properties Screen - Number Tab

4. To change the way currency values appear, tap the Currency tab and make the changes.

Figure 3-14    Regional Settings Properties Screen - Currency Tab

5. To change the way the time appears, tap the Time tab and make the changes.

Figure 3-15    Regional Settings Properties Screen - Time Tab
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6. To change the way the date appears, tap the Date tab and make the changes.

Figure 3-16    Regional Settings Properties Screen - Date Tab

7. Tap Start > Programs > Save Configuration to save the new settings in the MK1200 configuration (mkconfig.reg) 
file.

Memory Allocation

To change memory allocation settings:

1. Tap Start > Settings > Control Panel > System > Memory.

Figure 3-17    System Properties Screen - Memory Tab

2. On the Memory tab, adjust the memory allocation as desired using the slider.

3. Tap OK.

NOTE Changing these settings using the Control Panel does not persist them through cold boot cycles. To set 
allocation to persist through cold boot cycles, or for more information on this topic, see Memory 
Management on page 7-10.



Chapter 4 Remote Device Manager
Introduction
The Symbol Remote Device Manager (RDM) 2.5 is a simple, menu-based Windows® utility for streamlining large 
and small site deployments. This utility allows a user to remotely stage (discover and configure) and monitor 
networked MK1200s.

The RDM functionality falls into five categories:

• Generating a device configuration file

• Performing discovery (detection) of devices on a network

• Enabling automated staging/configuring/provisioning of networked devices

• Remote monitoring

• Remotely initiating device functionality.

Generating Configuration Files
Use the Create Local Configuration File feature of RDM to create an MK1200 configuration file (mkconfig.reg). 
When loaded onto the device, this file customizes the MK1200 communication settings, application settings, date 
and time setup, and much more. 

After generating the mkconfig.reg file, load it into the MK1200 Application folder (Desktop > My Computer > 
Application) and reboot the device. The MK1200 reads the mkconfig.reg file upon power-up and configures its 
parameters according to the settings defined in the mkconfig.reg file. If the MK1200 loses power, the parameters 
set within the configuration file persist and are re-established at the next power up.

See Creating a Configuration File on page 4-11 for more information.
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Performing Discovery (Detection) of Devices on a Network
The RDM discovers and displays the IP addresses of MK1200s on different subnets to which the host computer is 
connected, provided that the broadcast IP address is set correctly. See Setting RDM Options on page 4-14 for 
more details.

The RDM utility broadcasts a request for discovery, and each MK1200 responds with its IP address. The RDM 
utility displays all responding MK1200 IP addresses on the main RDM screen.

The RDM can remotely initiate actions, such as playing a sound file, on the discovered device to help locate it in a 
store environment.

Automated Staging/Configuring/Provisioning of Networked Devices
The RDM can load a device configuration file (mkconfig.reg) onto an MK1200 remotely. This process is automated 
and does not require user intervention.

For details, see Creating a Configuration File on page 4-11 and Downloading the Configuration File to the MK1200 
Using the RDM on page 4-13.

Remote Monitoring
Use the RDM to determine device-specific information. After performing discovery, select an MK1200 from the 
discovery list box to retrieve information to view:

• Device general information

• Operating System versions

• Storage information

• Partition information

• Application versions

• RF Signal Strength.

See Monitoring MK1200s on a Network on page 4-15 for more information.

Remotely Initiating Select Device Functionality
Use the RDM to remotely initiate select functionality on MK1200s. After performing discovery, highlight desired 
devices from the discovery list box to initiate remote functionality on these devices, such as launching AirBeam 
Smart or rebooting the device.

NOTE RDM performance and consistency when performing discovery on a network are directly related to 
network reliability.
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Installing the Symbol Remote Device Manager
The RDM is available for download from the Symbol Developer Zone web site (http://devzone.symbol.com/). 

1. Download the Symbol Remote Device Manager install file and save it on the host computer hard drive.

2. Select Start > Run from the Windows® task bar.

3. Using the Browse button, locate the Symbol Remote Device Manager install file and select OK.

4. The Symbol Remote Device Manager First Install Screen provides copyright information. Select Next to 
continue.

Figure 4-1    Symbol Remote Device Manager First Install Screen

5. The Symbol Remote Device Manager Select Installation Folder screen provides the directory information for 
the installation. Enter a new install path or accept the default path, and select users. Click Next to continue.

Figure 4-2    Symbol Remote Device Manager Select Installation Folder
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6. The Symbol Remote Device Manager Confirm Installation screen requests to confirm installation. Click Next to 
continue.

Figure 4-3    Symbol Remote Device Manager Confirm Installation

7. The Symbol Remote Device Manager Installation Complete screen confirms the installation was completed 
successfully. Click Close to exit.

Figure 4-4    Symbol Remote Device Manager Installation Complete
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Symbol Remote Device Manager Main Screen
To open the Symbol Remote Device Manager on the host computer, select Start > Programs >Symbol Remote 
Device Manager > Symbol Remote Device Manager. 

Figure 4-5    MK1200 Symbol Remote Device Manager

Symbol Remote Device Manager Menus

Use the menus on the Symbol Remote Device Manager (RDM) main screen to perform the functions in Table 4-1.

Table 4-1    Symbol Remote Device Manager Menu Items

Menu Item Function

File Menu

Exit Exits the Symbol Remote Device Manager.

Edit Menu

Select All Selects all MK1200s in the list.

Select None Deselects all MK1200s in the list.

View Menu

Refresh (Discover Remote Devices) Locates all MK1200s on the network and displays them in the list box.

Device Information Displays information on the selected MK1200. See Monitoring MK1200s on 
a Network on page 4-15.
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RF Signal Strength Launches the RF Signal Analyzer which displays RF signal strength.
Only RF MK1200s running Mobile Companion support this feature. 
RF MK1200s running Aegis Client do not support this.

View Filter Parameters Toggles on/off the Filter Parameters panel of the RDM.

Set Default Column Width Sets the default column width for fields displayed in main RDM screen.

Actions Menu

Locate Device Initiates the device locating mechanism. Select an option for locating the 
device from the sub menu:
Select Display Color Screen to display a color screen on the target device.
Select Emit Sound to play a high-pitched sound clip from the target device.
Select Display Color and Emit Sound to invoke both the previous two 
mechanisms in the target device.
Select Terminate Locator mode to terminate the locating mechanism. This 
terminates the current locator mode before initiating another locator mode.

Ping Device Ping the selected device. If the device cannot be reached, an error message 
displays.

Delete Device Removes the selected device from the list of discovered devices. This only 
deletes the devices highlighted in gray.

Cold Boot Cold boots the selected/highlighted MK1200(s). Allow approximately one 
minute for the device(s) to reboot and reconnect, then select View > Refresh 
to verify the devices rebooted successfully.

Warm Boot Warm boots the selected/highlighted MK1200(s). Allow approximately one 
minute for the device(s) to reboot and reconnect, then select View > Refresh 
to verify the devices rebooted successfully.

Launch AirBeam Launches the AirBeam version 2.16 application on the selected/highlighted 
MK1200(s). See Setting RDM Options on page 4-14.

Tools Menu

Create Local Configuration File Creates a new configuration file and allows saving it to the PC hard drive. 
See Creating a Configuration File on page 4-11.

Open Local Configuration File Opens an existing configuration file that resides on the host computer.

Retrieve Remote Configuration File Opens a configuration file that resides on the selected/highlighted MK1200. 

Push Configuration File Downloads a selected configuration file to the selected/highlighted 
MK1200(s). See Downloading the Configuration File to the MK1200 Using 
the RDM on page 4-13.

Table 4-1    Symbol Remote Device Manager Menu Items (Continued)

Menu Item Function
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Symbol Remote Device Manager Toolbar

Use the toolbar on the RDM main screen to perform the functions listed under the menu items in Table 4-2.

Manage Static IP Address Opens the Manage Static IP Address window. 
See Managing Static IP Addresses on page 4-20.

Custom DHCP Options Displays the Customer DHCP Options window. Use this window to 
add/edit/remove DHCP options available within the Symbol RDM.

Options Customizes Remote Device Manager options such as FTP security and 
broadcast IP address. See Setting RDM Options on page 4-14.

Table 4-1    Symbol Remote Device Manager Menu Items (Continued)

Menu Item Function

Table 4-2    Symbol RDM Toolbar Components

Component Description

Tool Bar Contains buttons that invoke most common functions of RDM. 

Discover all devices on the network 
and display the Discovered Devices 
list. To stop discovery, click the 
Cancel Discovery button.

Select all devices listed in the 
Discovered Devices list.

Deselect all devices. Retrieve the configuration file from 
the selected device.

Push the configuration file to the 
selected device(s).

Abort pushing the configuration file 
to device(s).

Create an MK1200 device 
configuration file using the RDM.

Retrieve device specific 
information.

Cold boot the selected device. Turns on and off the Filter 
Parameters panel.
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Row Colors

The Symbol RDM uses a color scheme to indicate the state of the MK1200 devices. 

State Icons

The Symbol RDM uses a color scheme on the State Icons (the left most column) to indicate the state of the 
MK1200 devices. 

Table 4-3    Row Colors

Color Status

Green Successfully retrieved/pushed configuration file. 

Yellow Selected for downloading a configuration file.

Gray Device is inactive. The device may be booting up or is no longer in the same subnet.

Red The retrieval/pushing of the configuration file is unsuccessful.

Table 4-4    State Icons

Color of Icon Status

Successfully discovered device.

Successfully retrieved/pushed configuration file. 

Device is selected for downloading a configuration file.

Device is inactive. The device may be booting up or is no longer in the same subnet.

The retrieval/pushing of the configuration file is unsuccessful.
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Filtering Parameters 

Use the Filter Parameters fields on the RDM main screen to display only certain devices on the network. Table 4-5 
describes these fields.

Set the filtering parameters and click Apply Filter to apply the filters in RDM. 

Click Clear Filter to remove the filtering parameters.

Table 4-5    Filter Parameters Fields

Menu Item Function

Product Group Select a product group to display. 

Product Select product model to display. See Identification on page 3-11.

Config Group 1 Select an assigned configuration group to display. To set configuration groups, use the 
System Configuration feature of RDM or System Menu. See Identification on page 
3-11.

Config Group 2 Select a second assigned configuration group to display. To set configuration groups, 
use the System Configuration feature of RDM or System Menu. See Identification on 
page 3-11.

Location Select a device location to display. To set locations, use the System Configuration 
feature of RDM or System Menu. See Identification on page 3-11.

Address Types Select Static to display devices found in Manage Static IP Address list (see Managing 
Static IP Addresses on page 4-20), or Discovered to display all devices not in the 
Manage Static IP Address list (see Enabling DHCP on page 4-24).

IP Address Enter IP address range to filter devices within the range.
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Filtering Example

In Figure 4-6, the filter parameter is set to a configuration group called Technical to isolate a device used in the 
Technical department. When you click Apply Filter, the RDM scans the discovered devices list and filters out only 
the devices that fall into that configuration group. Use filters to quickly locate the devices. 

Figure 4-6    Symbol Remote Device Manager Filtering

Electronic Serial Number 

An MK1200 shipped from the factory with CE .NET 4.2 has an electronic serial number accessible via network 
query. This information appears in RDM’s Serial Number column. 
A sample serial number is M1J37B90R.
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Creating a Configuration File

To create a new configuration file:

1. From the Remote Device Manager, select Tools > Create Local Configuration File from the menu bar. 

2. In the Domains window, select the applicable domain/product (MK1200) and click OK. This opens the MK1200 
Configuration Utility window.

3. Make the necessary changes to the default values in the configuration file. See Default Parameters on page 
3-6 for all configuration options, which fall into the following configuration categories:

• Configuration File Information - includes parameters related to version tracking of the mkconfig.reg file.

• Applications - includes parameters related to Internet Explorer.

• Communications - includes parameters for wired MK1200s related to Onboard Wired Ethernet. 

• System Configuration - includes parameters related to MK1200 system settings such as backlight intensity, 
volume and sounds, date/time, button configurations, regional settings, and user applications.

• Update - includes parameters related to the onboard FTP Client.

• See Figure 4-7 for a sample screen, and Data Entry Formats on page 4-27 for MK1200 Configuration Utility 
window data entry field types used when changing configuration options.

Figure 4-7    Changing Configuration Parameters Example: Internet Explorer Start Page

4. Select File > Save As.

5. In the Save window, specify the file name and location, then click OK.

NOTE The default folder is C:\Program Files\Symbol\Configuration Utility\MK1200 Configuration Files. The 
default file name is mkconfig.reg. Assign the file any name, but rename the file mkconfig.reg before 
transferring it to the MK1200.
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Modifying an Existing Configuration File

To edit an existing configuration file: 

1. From the RDM on the host computer, choose Tools > Open Local Configuration File to open the MK1200 
Configuration Utility window.

2. Select a configuration file (with a .reg extension) to edit and click OK.

3. Make the necessary changes to the default values in the configuration file. See Default Parameters on page 
3-6 for these options. Also see Figure 4-7 for a sample screen, and Data Entry Formats on page 4-27 for 
MK1200 Configuration Utility window data entry field types used when changing configuration options.

4. To save the changes, choose File > Save to overwrite the old file, or select Save As to specify a new name for 
the file. Note that you cannot change the Domain (product) of an existing configuration file.

Retrieving and Modifying a Configuration File from an MK1200

1. From the RDM screen, select the device from which to retrieve the configuration file.

2. Select Tools > Retrieve Remote Configuration File to retrieve the MK1200 configuration file from the MK1200 to 
the host computer. This launches the MK1200 Configuration Utility window of the RDM. If a configuration file is 
unavailable in the device, RDM opens the MK1200 Configuration Utility window with the default factory settings.

3. Make the necessary changes to the default values in the configuration file. See Default Parameters on page 
3-6 for these options. Also see Figure 4-7 for a sample screen, and Data Entry Formats on page 4-27 for 
MK1200 Configuration Utility window data entry field types used when changing configuration options.

4. In the MK1200 Configuration Utility window, select File > Save to Remote Device to save the changes and 
transfer the updated configuration file back to the original MK1200. 

5. Alternatively, configure the RDM to automatically cold boot the MK1200 device after a download completes. 
Select Tools >Options to open the RDM Options screen, and check Auto reboot after download.

NOTE If you upgraded the MK1200 OS to CE .NET 4.2 and a configuration (.reg) file was created using an older 
version, you must create a new .reg file using RDM Version 2.5 (see Creating a Configuration File on 
page 4-11). For more information about upgrades, see Appendix F, OS Upgrade Procedures..

NOTE Only open files created by the RDM, System Menu, or Save Configuration. Loading other registry files 
can cause file corruption.

NOTE To reboot manually instead, in the RDM, select the MK1200 device, then select Actions > Cold Boot. 
Allow approximately one minute for the MK1200 to reboot and reconnect, then select View > Refresh to 
verify the device rebooted successfully.
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Cloning an MK1200 Configuration File to Multiple MK1200s
To use one MK1200 configuration file to configure other MK1200s:

1. In the RDM, select the MK1200 with the configuration file to use.

2. Select Tools > Retrieve Remote Configuration File to transfer the configuration file to the host computer and 
open the MK1200 Configuration Utility window. 

3. In the MK1200 Configuration Utility window, select File > Save As.

4. Specify the location for the configuration file to be saved on the host PC, and click OK.

5. Select the MK1200 devices to be updated from the Discovered Devices list.

6. Select Tools > Push Configuration File option to upload the configuration file to the selected MK1200s (see 
Downloading the Configuration File to the MK1200 Using the RDM).

Downloading the Configuration File to the MK1200 Using the RDM

To “push” the file to the MK1200(s):

1. In the Symbol Remote Device Manager (RDM) window, select/highlight the MK1200(s) to receive the 
configuration file.

2. Select Tools > Push Configuration File.

3. Select the configuration file to send, then click Open.

The row color of the selected device changes to yellow to indicate that the MK1200 device is ready to receive 
a configuration file through the RDM. When the download completes, the row color changes to green. See 
Row Colors on page 4-8 and State Icons on page 4-8.

4. If the Auto reboot after download option is disabled, manually cold boot the MK1200(s). In the RDM main 
screen, select the MK1200(s) to reboot, then select Actions > Cold Boot. Allow approximately one minute for 
the MK1200 to reboot and reconnect, then select View > Refresh to verify the device rebooted successfully.

NOTE Setting the device FTP options to Enable Anonymous Login and Disable User Authentication allows 
anonymous login and retrieval of files through FTP connection. However, modifying/adding files is not 
allowed for non-anonymous users. Therefore, do not enter a user name and password in RDM’s options 
panel to download a file to the device through RDM if these FTP settings are in place.
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Setting RDM Options
If desired, set the following Symbol Remote Device Manager (RDM) options from the Options window. These 
settings apply for the RDM:

• AirBeam parameters

• FTP security

• Timeouts

• Auto-refresh

• 3rd party application data

• Other options (e.g., auto-reboot, device discovery).

To set options:

1. In the RDM main screen, select Tools > Options to open the Options window.

Figure 4-8    Symbol Remote Device Manager Options Window

2. Set desired options:

• Set AirBeam Parameters for launching AirBeam. For more information on AirBeam command line parameters, 
refer to the AirBeam Package Builder Product Reference Guide.

• Set the FTP user ID in the User ID field and password in the Password field for accessing an FTP server. 
Leave this blank to enable anonymous FTP login. See Downloading the Configuration File to the MK1200 
Using the RDM on page 4-13 and FTP Server on page 3-19.

• Enter a value for Device discovery (the duration for sending network queries for detecting MK1200 devices) 
and Query timeout (the timeout period before the next query). 
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• Check the Enable auto-refresh every option to enable automatic refresh/discovery of devices and specify the 
time period in its text box. This automatically refreshes the Discovered Devices list after a cold/warm boot or 
after a configuration file push.

• In the Application 1 and Application 2 fields, enter the names of applications loaded on the device that the 
RDM must monitor. For example, to track the Web Kiosk Software Suite version, enter Web_Kiosk 
SoftwareSuite into Application 1. 

• Check Auto reboot after download to reboot the device after a successful configuration file push.

• Check Device discovery on open to perform device discovery automatically when the RDM launches.

• Check Enable RDM Password to prompt for a User Name and Password for using the RDM. Enter the user 
name and password in the RDM Login screen. RDM prompts for the user name and password when 
launched.

• Specify the Broadcast IP Address, used in discovering devices on the network. The default value is 
255.255.255.255. This causes discovery of all device in all network interfaces attached to a single computer 
(multi-homed computer).

3. Click OK to save the changes and close the Options window.

4. Click Defaults to load the default settings for the RDM.

5. Click Cancel to exit the RDM Options screen without saving the settings.

Monitoring MK1200s on a Network
Use the RDM to remotely monitor MK1200s connected through a network connection. After performing discovery, 
double-click on an MK1200 from the discovery list, or click on the MK1200 in the list and select View > Device 
Information from the RDM menu:

• View device general information. See Device Information - Info Tab: Detected Device Information on page 
4-16.

• View software version information, such as applications, drivers, OS, and platform. See Device Information - 
Software Tab: Version Information on page 4-17.

• View RAM and flash memory usage for the selected device. See Device Information - Storage Tab: Memory 
Availability and Usage on page 4-18.

• View partition information for the selected MK1200. See Device Information - Partitions Tab on page 4-19.

Use the up and down arrow keys to navigate through the discovered devices to view information.

Click Refresh to refresh the device properties list.

Click Generate Report to place the information displayed in the tabs into a printable file.
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Device Information - Info Tab: Detected Device Information

The Info tab displays identification information about the selected MK1200. Also see Performing Discovery 
(Detection) of Devices on a Network on page 4-2

Figure 4-9    MK1200 Remote Device Monitor - Info Tab
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Device Information - Software Tab: Version Information

The Software tab displays the applications, operating system, monitor driver, and platform, and their version 
information for the selected MK1200.

Figure 4-10    MK1200 Remote Device Monitor - Software Tab
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Device Information - Storage Tab: Memory Availability and Usage

The Storage tab displays storage areas on the selected MK1200, their physical size, and available free memory.

Figure 4-11    MK1200 Remote Device Monitor - Storage Tab
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Device Information - Partitions Tab

The Partitions tab displays the number and size of the storage areas on the selected MK1200. 

Figure 4-12    MK1200 Remote Device Monitor - Partitions Tab
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Setting a Static IP Address
To set a static IP address for a wired device: 

1. In the MK1200 Configuration Utility window, select IP Address under the appropriate adapter: Onboard Wired 
Ethernet.

Figure 4-13    Setting a Static IP Address

2. In the text box, enter the IP address.

3. Also select and define the adapter's Default Gateway and Subnet Mask.

4. Optionally, select and define the DNS Server(s) and DNS Domain.

5. Ensure that Enable DHCP is disabled (de-select its check box).

6. Save the changes.

Managing Static IP Addresses
Specify the static IP address of an MK1200, which is on a different subnet than the Symbol Remote Device 
Manager PC, to establish a connection and still be managed by the RDM. This causes the RDM to list the devices 
and their IP addresses, without performing discovery, in the RDM main screen. 

For this to occur, the MK1200 that is on a different subnet than the RDM must have a static (unchanging) IP 
address during the remote management session.

This is useful when MK1200s are on more than one subnet, when bandwidth is a consideration, or when MK1200s 
are connected over a WAN. For example, if the MK1200 RF and wired Ethernet devices are on different subnets, 
the Remote Device Manager can still manage all devices.
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Adding Static IP Addresses

1. In the Symbol Remote Device Manager, select Tools > Manage Static Addresses.

Figure 4-14    Manage Static Addresses Window

2. Enter the IP address and the name, and click Add. Repeat this to enter other static IP addresses.

3. Click OK to save the changes.
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Modifying Static IP Addresses

1. In the Symbol Remote Device Manager, select Tools > Manage Static IP Addresses.

Figure 4-15    Modifying Static Addresses

2. Select the IP address and click Modify. 

3. Change the appropriate settings and click Update to update the static IP addresses list. 
Click Discard to discard the modifications.

4. Click OK to save the changes.
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Deleting Static IP Addresses

1. In the Symbol Remote Device Manager, select Tools > Manage Static IP Addresses.

Figure 4-16    Deleting Static Addresses

2. Select the IP address to delete, and click Delete. Repeat this to delete other static IP addresses.

3. Click OK to save the changes.
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DHCP Configuration
Familiarity with Dynamic Host Configuration Protocol (DHCP) options is required to edit options and save them to 
the configuration file.

Enabling DHCP

Enabling DHCP configures a specific network adapter to acquire its IP address and other network parameters 
through DHCP. DHCP options determine what additional data is sent to and received from the DHCP server.

To enable DHCP:

1. In the MK1200 Configuration Utility window, select Enable DHCP under the appropriate adapter: Onboard Wired 
Ethernet.

Figure 4-17    Enable DHCP Window

2. Check Enable DHCP.

If enabling DHCP to resolve addresses for a network adapter, optionally specify which data fields are sent from or 
received by the MK1200 (DHCP options) during DHCP transactions using that network adapter. 

Some of the 256 available DHCP options are defined by the IETF in RFC-2132, and appear in the MK1200 
Configuration Utility window when specifying DHCP options. If desired, add custom DHCP options to this list. 
These custom option definitions are stored in the file <install_dir>\dhcpoptions.reg, which the RDM reads upon 
launch. If using another computer to edit a configuration file that contains custom DHCP options, transfer the file 
<install_dir>\dhcpoptions.reg to this computer to view these custom options.

NOTE Do not use the System Menu or RDM to enable DHCP receive options 1, 3, 6, 15, 44, 46, 47, 66 and 67. 
They are already enabled in dhcpoptions.reg as a part of the AirBeam package. Refer to AirBeam 
documentation for this configuration.

NOTE If enabling DHCP, you can set DHCP Server; however, this is usually not required. Do not set any other 
parameters under Communications.
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To change Send DHCP options:

1. In the MK1200 Configuration Utility window, select DHCP Options under the appropriate adapter: Onboard 
Wired Ethernet.

2. Click Edit Send Options to view the Send window.

Figure 4-18    DHCP Send Options Window

3. To add options to the configuration, select an option for the network adapter to receive from the Available 
Options list. 

4. In the data field(s) in the Static area of the window, enter the data to send for this option. Click to add these 
options to the Options to Receive list.

5. To add other Send DHCP options, repeat steps 3 and 4.

6. To remove options from the configuration, select an option to remove from the Options to Send list. Click to 
move the option back to the Available Options list. Repeat this for each option to remove.

7. Click OK to save the changes and close the Send window.
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Custom DHCP Options

Use the RDM to add/edit/remove custom DHCP options available within the RDM. Select Tools > Custom DHCP 
Options.

Figure 4-19    Custom DHCP Options Screen

Adding Custom DHCP Options

Use the Custom DHCP Options window to add a new DHCP option.

1. Select a code that is not currently used from the Code drop-down list.

2. Enter the Name and Description for the custom DHCP option.

3. Set the Input Rules.

4. Click OK to submit the entered settings in the RDM.

Editing Custom DHCP Options

1. From the Code drop-down list, select the custom DHCP option to edit. 

2. Make the appropriate changes.

3. Click OK to submit the entered settings in the RDM.

Removing Custom DHCP Options

1. From the Code drop-down list, select the custom DHCP option to remove.

2. Delete the Name and Description.

3. Click OK to save in the RDM.
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Updating the RDM on the Host Computer
To update the RDM:

1. Use the Windows® Add/Remove a Program utility to remove the RDM from the host computer.

2. Install an updated RDM. See Installing the Symbol Remote Device Manager on page 4-3.

Restoring Configuration Parameter Defaults
Some fields have a default value. To restore default values, choose one of the following items from the MK1200 
Configuration Utility window: 

• Select a parameter, then select Edit >Restore Default to restore the current field to its default.

• Select Edit > Restore All Defaults to restore all parameter default settings.

Save the changes.

Data Entry Formats
The RDM uses standard data entry formats, depending on the data type:

• Check Box: Used for true or false values. An "X" in the check box selects the function. Tap the box to check 
or uncheck. 

• Text Data Entry Box: Requires text entry. Examples are IP address, domain name, or server name.

• Numeric Data Entry Box: Requires numeric entries, in hexadecimal (base 16) or decimal (base 10) notation. 
Hex values must be preceded by "0x".

• Drop-down List: Select a single option. The stored parameter value may be different than the text displayed.

• Bit Fields: Multiple items with check boxes. If desired, select multiple items (from none to all). Each selected 
item affects the value stored, which is a single number, so the selections will not match the mkconfig.reg file. 

• Multiple Text: Enter multiple free-form strings. Click Enter on the keyboard to create a new string. Multiple 
text values are not represented in the mkconfig.reg file as text, so the value entered is not recognizable in the 
mkconfig.reg file.

• External-type: For each different external type, an associated DLL manipulates what is stored in the Registry 
(mkconfig.reg) and how it is displayed in the Configuration Utility/System Menu.
The Configuration Utility/System Menu loads the relevant DLL when an External-type is found in the 
metadata file for the particular Registry type. The DLL should have two standard methods: input and output. 
When a registry entry of External- type is stored, the text in the text box is passed to the output method of the 
DLL which translates the data accordingly and writes it to the Registry file. When retrieving a Registry entry, 
the DLL invokes the input method and translates the data back to a valid form. It is displayed in the 
Configuration Utility /System Menu. 
All validation for the value entered is done through the DLL. No validation is done through the Configuration 
Utility/System Menu. This method is used in encrypting and decrypting WEP keys.
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Chapter 5 Transferring Files to the MK1200
Introduction
Use the following tools to copy files to the MK1200:

• ActiveSync

• FTP Server (see FTP Server on page 7-11)

• PCMCIA Card (see PCMCIA Storage Card on page 5-3)

• AirBEAM version 2.16 (see AirBeam Package Builder Product Reference Guide).

ActiveSync
The MK1200 communicates with a host computer via Microsoft® ActiveSync (version 3.7.1 or higher). Use USB 
ActiveSync to transfer data between a host computer and the MK1200.

When installed on the MK1200, ActiveSync allows copying and pasting (rather than synchronizing) files between 
the MK1200 and host computer.

Installing ActiveSync

To install ActiveSync on the host computer, download the latest version of the software from 
http://www.microsoft.com. Refer to the installation instructions included with the ActiveSync software.

NOTE While an application is running, access to ActiveSync can be enabled or disabled using either RDM or the 
System Menu under System Configuration - ActiveSync - EnableActiveSync.

NOTE The MK1200’s implementation of ActiveSync 3.7 does not support ActiveSync Backup and Restore 
functionality and automatic information synchronization.
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Connecting the MK1200 to the Host Computer

See the following instructions to configure ActiveSync for Guest access, suitable for copying files between the host 
computer and the MK1200.

1. Connect the RJ-45 connector end of the ActiveSync Developer’s Cable, p/n 25-64626-01R, to the Debug port 
on the MK1200 (see Figure 1-3 on page 1-5). Connect the other end of the cable to a USB port on the host 
computer.

2. If the Get Connected window does not appear on the host computer, select Start > Programs > Microsoft 
ActiveSync.

Figure 5-1    Get Connected Window

3. Select Next. The host computer and the MK1200 attempt to synchronize. The New Partnership window 
appears.

Figure 5-2    New Partnership Window

4. As Partnership is not supported, click No, then Next. The New Partnership/Name Your Device window appears.
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5. Click Next. The Microsoft ActiveSync Guest Connected window appears.

Figure 5-3    Microsoft ActiveSync Guest Connected Window

To download files (such as the mkconfig.reg file) from the host computer to the MK1200, use Windows Explorer to 
copy the files. Then, select File > Explore on the ActiveSync window, locate the folder to download the files to, and 
paste the file.

For more information about ActiveSync, start ActiveSync on the host computer, then refer to ActiveSync Help.

PCMCIA Storage Card
A PCMCIA card adds flash memory to the MK1200. Use the PCMCIA card to copy files to or from the MK1200. 
The PCMCIA card appears as the folder \Storage Card in Explorer.
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Chapter 6 Web Kiosk Software Suite
Introduction
The Symbol Web Kiosk Software Suite is a set of sample software applications available for the MK1200 and 
MK2200. The Web Kiosk Software Suite is a comprehensive browser solution that demonstrates the many 
capabilities of the MK1200 Micro Kiosk. For software developers, production quality HTML source code is included 
as a reference implementation for creating custom solutions.

Web Kiosk Software Suite Features
The Web Kiosk Software Suite provides a sample retail application that demonstrates the functionality of the 
MK1200 in a retail environment, and includes Customer and Store Operations applications.

The Customer Application screens provide:

• Advertising (Attract Mode)

• Price verification

• Alternate language information

• Printing capability

• Magstripe reading (MSR)

• Loyalty program

• Guided selling tool.

The Store Operations screens provide:

• Employee bulletin (text messaging)

• Weekly employee work schedule

• Time and attendance (clocking in).
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Free Source Code

• Dynamic button re-labeling

• Prevent website redirection

• Scan engine control

• Enable/disable symbologies

• Automatic device setup

• Serial printing

• Alternate language support.

Customer Facing Employee Facing

Price 
Verification

Loyalty 
Program

Guided 
Selling Tool Advertising

Payment 
via MSR

Time and 
Attendance

Work 
Schedule

Messaging 
System

Alternate 
Language 
Support
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Web Kiosk Software Suite
The Web Kiosk Software Suite MK1100WEBKSS_X.XX.ZIP and source code are available at 
http://devzone.symbol.com. The Web Kiosk Software Suite does not require any external connectivity to run.

Web Kiosk Software Suite Bar Codes

The Web Kiosk Software Suite uses the Web Kiosk Software Suite Bar Codes on page D-1 to demonstrate the 
MK1200’s capabilities.

Installing the Web Kiosk Software Suite 

To install the Web Kiosk Software Suite when the MK1200 is set to launch another application on power-up, see 
Accessing the Windows® CE Desktop. 

Accessing the Windows® CE Desktop

To prevent launching an application on power-up:

1. Perform a cold boot: press and hold buttons B and C on the MK1200 (see Figure 1-1 on page 1-3) until the 
display goes blank (typically 15 seconds), then release the buttons. 

2. To prevent the MK1200 from entering an application, simultaneously press and hold buttons A and D just after 
the blue Performing System Initialization (Phase 1) screen appears, and before the message changes to Phase 
2. Release the buttons.

3. When the Enter Password prompt appears, press buttons DDBAC and touch OK, or simultaneously press the 
A and B buttons for Enter. The MK1200 enters Protected Mode and the Windows® CE desktop appears.

Deleting the Current Web Kiosk Software Suite Version

To delete an existing copy of the Web Kiosk Software Suite:

1. Double-tap the My Computer icon on the CE desktop.

2. Double-tap the Application folder.

3. Select and delete the MK1100WebKioskSoftwareSuite folder.

4. Select and delete the mkconfig.reg file.

5. Select and delete the Web_KioskSoftwareSuite.reg file.

NOTE Use Delete in the Files menu to remove the files.
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Installing a New Web Kiosk Software Suite Version

1. Create a folder on the host computer called SoftwareSuite.

2. Download the Web Kiosk Software Suite MK1100WEBKSS_X.XX.ZIP from http://devzone.symbol.com, saving 
it to the desktop. The downloaded files are compressed in a .zip file.

3. Extract all files to the SoftwareSuite folder to create the following files and folders:
• MK1100WebKioskSoftwareSuite folder
• MK1100_WebKSS_Install+SourceCode_Updated.doc
• mkconfig.reg
• Web_KioskSoftwareSuite.reg
• RetryPage.html.

4. To load the Web Kiosk Software Suite onto a PCMCIA card, copy the following items onto the PCMCIA card:
• The folder labeled MK1100WebKioskSoftwareSuite 
• The file labeled mkconfig.reg

• The file labeled Web_KioskSoftwareSuite.reg

• The file labeled RetryPage.html.

5. Insert the PCMCIA card into the PCMCIA card slot in the MK1200. See Figure 1-2 on page 1-4. To access 
PCMCIA card contents, use the Storage Card folder located in My Computer.

6. Double tap the My Computer icon.

7. Double tap the Application folder.

8. Use the copy function to copy the folder and files from the My Computer\Storage Card folder into the My 
Computer\Application folder.

9. Reboot the MK1200 to launch the new version of the Web Kiosk Software Suite.

Disabling/Restoring the Web Kiosk Software Suite 

1. To prevent the MK1200 from entering an application, simultaneously hold down buttons A and D just after the 
blue Performing System Initialization (Phase 1) screen appears, and before the message changes to Phase 2. 
Release the buttons.

2. When the Enter Password prompt appears, press buttons DDBAC and touch OK on the MK1200 screen, or 
simultaneously press the A and B buttons for Enter.

The MK1200 enters Protected Mode and the Windows® CE desktop appears.

3. Double tap the My Computer icon.

4. Double tap the Application folder.

5. Use the cut function to cut the mkconfig.reg file from the My Computer\Application folder.

6. Double-tap the MK1100WebKioskSoftwareSuite folder and paste the mkconfig.reg file into this folder.

7. Reboot the MK1200. The Windows® CE desktop appears.

NOTE Alternatively, use an ActiveSync connection to transfer files from the host computer to the MK1200.
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8. To restore the Web Kiosk Software Suite, move the mkconfig.reg file back to the My Computer\Application 
folder.

Starting and Exiting the Web Kiosk Software Suite

Before launching the Web Kiosk Software Suite, print out the bar codes in Web Kiosk Software Suite Bar Codes on 
page D-1, used to demonstrate MK1200 features. For sample source code that demonstrates automatic MK1200 
startup from a browser application, refer to the MK1100_WebKSS_Install+SourceCode_Updated.doc file, which is 
part of the MK1100WEBKSS_X.XX.ZIP file.

To launch the Web Kiosk Software Suite automatically, apply power to the MK1200 and allow the boot sequence to 
proceed uninterrupted. To exit the Web Kiosk Software Suite and access the Windows® CE Desktop, see 
Accessing the Windows® CE Desktop on page 6-3.
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Web Kiosk Software Suite Structure
The Web Kiosk Software Suite’s Customer Application Screens are for customer use, and the Store Operations 
Screens are for store employee access only. For access to the Store Operations Screens, use the Employee Badge 
on page D-6. These screens use the four programmable buttons and/or virtual touch screen buttons (on 
touch-enabled units). 

The Customer Application Screens demonstrate customer support features:

• Main Menu Bar

• Scanning Bar Codes on page 6-6

• Attract Mode on page 6-7

• Price Verification on page 6-7
Price Verification Menu Bar on page 6-8

• Printing from the Web Kiosk Software Suite on page 6-8

• Loyalty Program on page 6-10

• Guided Selling Tool (Select Ink Cartridge) on page 6-11.

The Store Operations Screen on page 6-13 demonstrates sample store operations that the MK1200 can support:

• Text Messaging Screen on page 6-13

• Work Schedule Screen on page 6-14.

Customer Application Screens

Main Menu Bar 

In Attract Mode (Idle Mode) the MK1200 displays the Main Menu bar titles above the programmable buttons.

Figure 6-1    Main Menu Bar

Scanning Bar Codes

A bar code (item's SKU, employee badge or loyalty card) can be scanned from any point within the application 
where the scanner is active. For example, after a store employee scans an item's SKU for price lookup, they can 
scan their employee badge on the price verification screen to directly access the store operations menu.

For sample source code that demonstrates how to control the scan engine from a browser application, refer to the 
MK1100_WebKSS_Install+SourceCode_Updated.doc file, which is part of the Web Kiosk Software Suite.
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Attract Mode

The Web Kiosk Software Suite automatically enters Attract Mode after a period of inactivity on any screen, and 
displays a slide show. The Main Menu bar is visible during the slide show.

Figure 6-2    Slide Show Screens

Price Verification

The Web Kiosk Software Suite has two price verification screen formats: 

• Price Verification screen (Loyalty Program enabled) - requires the Loyalty Program bar code to access 
special Loyalty Program product information.

• Price Verification screen (non-Loyalty Program) - displays standard non-Loyalty Program product information.

Scan the bar code White Correction Fluid on page D-2.

Figure 6-3    Loyalty Program Enabled, Price Verification Screen
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Scan the bar code Wide Screen TV on page D-1.

Figure 6-4    Non-Loyalty Program, Price Verification Screen

Price Verification Menu Bar

The Price Verification Menu bar appears directly over the function buttons and identifies the button functions (while 
in the Price Verification screen).

Figure 6-5    Price Verification Menu Bar

The menu bar enables the following functionality:

• Español (alternate language) - The title above the first button labels the alternate language (Spanish is the 
default). Once selected, screen text appears in the alternate language, including all screen titles, buttons 
titles, and price verification field titles. This language remains in effect until the screen is exited or until 
another button is pressed. 
For sample source code that demonstrates alternative language support from a browser application, refer to 
the MK1100_WebKSS_Install+SourceCode_Updated.doc file, which is part of the Web Kiosk Software Suite.

• Print - print information shown on the screen. See Printing from the Web Kiosk Software Suite on page 6-8.

• Loyalty Program - see Loyalty Program on page 6-10.

• Home - returns the MK1200 to Attract Mode on page 6-7.

Printing from the Web Kiosk Software Suite

Select the Print button to view the Printing Options screen, which offers the following options:

• Print - print bar codes, bitmaps, and/or text on the selected printer.

• Down arrow - scroll down the printer list

• Troubleshoot - accesses a screen for setting the printer in a mode to print on receipt paper. The default 
setting is for label stock if this is not done.

• Home - returns the MK1200 to Attract Mode on page 6-7.
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Figure 6-6    Printing Options Screen

The Web Kiosk Software Suite supports printing via the Zebra QL220/320/420 or Zebra LP2834/2844 series 
printers, and demonstrates how to print on receipt stock (continuous printing) or label stock. The QL series printers 
support advanced printer monitoring functionality (see Advanced Printer Monitoring Functionality on page 3-18).

For sample source code that demonstrates printing from a browser application, refer to the 
MK1100_WebKSS_Install+SourceCode_Updated.doc file, which is part of the Web Kiosk Software Suite.

Printer Errors

If an error occurs during printing to a Zebra QL printer, the error is highlighted in red as shown in Figure 6-7. 

Figure 6-7    Printer Errors
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Loyalty Program

Select the Loyalty Program button from the Main Menu bar (see page 6-6) or from the Price Verification screen 
(see page 6-7) to view the Loyalty Program screen.

Figure 6-8    Loyalty Program Screen

Scan the Loyalty Card on page D-6 for details about the customer’s Loyalty Program account status.

Figure 6-9    Loyalty Program Account Status
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Guided Selling Tool (Select Ink Cartridge)

Select the Select Ink Cartridge button from the Main Menu bar (see page 6-6) to view the Print Cartridge screen.

Figure 6-10    Print Cartridge Screen

Highlight one of the printers and tap or press the Select button. The Cartridge Type Selection screen appears for the 
selected printer.

Figure 6-11    Cartridge Type Selection Screen
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Select either Black Cartridges or Color Cartridges to view information for that cartridge.

Figure 6-12    Cartridge Information Screen

For an MSR demonstration on MK1200s with an attached MSR, tap Buy.

Figure 6-13    MSR Payment Screen

Slide a credit card through the MK1200’s MSR for sample payment authorization. No payment information from the 
credit card is sent or retained.

For sample source code that demonstrates MSR operation from a browser application, refer to the 
MK1100_WebKSS_Install+SourceCode_Updated.doc file, which is part of the Web Kiosk Software Suite.

NOTE If the MK1200 does not have an attached MSR, tap Back or Cancel to exit this screen, as no credit cards 
can be swiped.
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Store Operations Screen

Scan the Employee Badge on page D-6 (5-digit Code 128) to enter the Store Operations mode. 

The Store Operations menu bar offers the following buttons:

• Employee Bulletin (see page 6-13)

• Work Schedule (see page 6-14)

• Home - returns the MK1200 to Attract Mode on page 6-7.

Figure 6-14    Store Operations Screen

Text Messaging Screen

Select Employee Bulletin from the Store Operations screen to view the Text Messaging screen (see Figure 6-15).

Options include:

• Delete - Returns to the Store Operations Screen on page 6-13.

• Back - Returns to the Store Operations Screen on page 6-13.

Figure 6-15    Text Messaging Screen
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Work Schedule Screen

Select Work Schedule from the Store Operations screen to view the Work Schedule screen, which displays an 
employee’s schedule.

Select Back to return to the Store Operations Screen on page 6-13.

Figure 6-16    Text Messaging Screen

WebKSS Source Code Index

Refer to the MK1100_WebKSS_Install+SourceCode_Updated.doc file for sample source code for the following 
functionality.

Screen Layout

• Alternate language support:
• Displaying screen text in Spanish versus English

• Hiding the Browser and Windows® CE toolbars

• Setting up a Price Verification Screen:
• Routing UPC data
• Laying out item pricing information on a screen.

Printing

• Bitmap

• Bar code

• Text

• QL printer error handling.
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Scan Engine

• Turning the engine on

• Turning the engine off

• Setting the scan pattern (omnidirectional or straight line)

• Embedding the scanner object in a frame

• Routing bar code data via symbology type to different locations.

Advertising

• Attract loop
• How the loop works
• Changing the amount of time to display each image
• Locating images

• Running a slide show.

Magstripe Reader

• MSR control

• Reading a credit card.

Device Startup

• Enabling automatic device setup (see the Software Suite's mkconfig.reg file)

• How to enable device self-configuration/setup at power up.

Application Version Tracking

• Tracking the Web Kiosk Software Suite’s version information (see Web_KioskSoftwareSuite.reg file)

• How to track application versions via a .reg file.

Custom Internet Explorer Error Page

• Verifying the behavior of a custom Kiosk IE error page

• Setting a custom Kiosk IE error page.
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Chapter 7 System Features
Introduction
This chapter discusses the following operating system features:

• Network Security on page 7-2

• SNMP-Based Remote Monitoring on page 7-3

• RegMerge and CopyFiles on page 7-6

• Accessing the Windows® CE Desktop on page 7-7

• Password Protection (Gate Keeper) on page 7-7

• Remapping Buttons on page 7-8

• Network Time Update: SNTP Client on page 7-10

• Memory Management on page 7-10

• FTP Server on page 7-11

• AirBEAM on page 7-12

• Inactivity Application (Screen Saver) on page 7-12

• Browser Applications - Hiding Toolbars on page 7-13

• Browser Applications - Handling Network Disconnects on page 7-14

• Loading Additional Fonts on the MK1200 on page 7-15

• Input Panel (Virtual Keyboard) on page 7-17

• Microsoft WordPad on page 7-18

• Internet Explorer on page 7-19

• Printer Object Test on page 7-21

• MSR Object Test on page 7-22

• Scanner Object Test on page 7-23

• MicroKiosk Object Test on page 7-24.
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Also see Electronic Serial Number on page 4-10.

Security Overview
The following items and features help secure the device from external intrusion:

• ActiveSync - deactivation when an application is running: pages 3-9 and 5-1.

• FTP Server - partial or complete deactivation: pages 3-19 and 7-11.

• Web Server deactivation: page 3-16.

• Password protecting access to CE Desktop: pages 7-7, 3-14 and 6-3.

• RS-232 Port - page 2-11.

• Browser error page redirection: page 7-14.

• RF Security: pages B-1, B-2, B-6 and B-10.

• Open TCP ports: page 7-2.

Network Security
The MK1200 has the following open TCP ports:

• Port 23: FTP server

• Port 80: Default HTTPD listen port

• Port 443: Default SSL listen port.

By default the FTP server runs on the MK1200 allowing anonymous login, which makes the entire folder structure 
accessible to any user. 

Using the System Menu or RDM, disable the feature that allows anonymous login to secure the system. Use the 
Windows Domain control to authenticate the allowed users to login to the FTP server running on the device. Then, 
using the RDM, enter user information (User Name and Password) required to access the device FTP server. 

The web server in the MK1200 is enabled by default. Use the System Menu or RDM to disable and enable the web 
server.
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SNMP-Based Remote Monitoring
The MK1200 supports Simple Network Management Protocol (SNMP) Version 2c. The MK1200 includes an SNMP 
agent. The MK1200 supports two Host Resource Management Information Bases (HR MIBs):

• The MK1200 extends Microsoft implementation of the MIB-II defined Host Resource MIB to report software 
versions, file system values, partition table values, and a few miscellaneous items.

• A custom HR MIB performs actions such as rebooting the MK1200. The previous MIBs support Microsoft 
default implementation.

This guide does not provide details of supported MIB-II and Host Resource MIB (HRMIB) functionality, except for 
specific changes to the HR MIB made for MicroKiosk products.

The software versions are published using tables within the hrSWInstalledTable table, which is part of the Host 
Resource MIB. hrStorageTable presents the filesystem information. See List of Reported Software Component 
Versions on page 7-3 for more information on what is reported using the Host Resource MIB.

The MicroKiosk line of products use the SysOID (System Object Identifier) listed in Table 7-1. This OID is the prefix 
for all OIDs in the MicroKiosk Custom MIB.

These SysOIDs come from the tree officially assigned to Symbol Technologies (.1.3.6.1.4.1.388) and are 
registered with the body within Symbol that manages our SNMP OIDs.

List of Reported Software Component Versions

The Host Resource MIB reports the items in Table 7-2, which indicates where to find this information in the Host 
Resource MIB. Use the RDM to view this information. See Monitoring MK1200s on a Network on page 4-15.

NOTE Download a detailed specification of the MK1200 MicroKiosk SNMP agent/MIB at 
http://devzone.symbol.com.

Table 7-1    SysOID

Product SysOID

MK1200 .1.3.6.1.4.1.388.10.3

Table 7-2    Reported Software Component Versions

Item Host Resource MIB Location

Symbol OS hrInstalledSoftware

Windows CE OS hrInstalledSoftware

Monitor/IPL hrInstalledSoftware

Scanner C API hrInstalledSoftware

Scanner Driver MDD hrInstalledSoftware

Scanner Driver PDD hrInstalledSoftware

Scanner Decoder Firmware hrInstalledSoftware

Scanner Hardware hrInstalledSoftware
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User Application Version Reporting

SNMP reports user application names and version information as follows:

Upon boot up, the MK1200 reads a .reg file (e.g., application_name.reg) created and loaded into the Application 
partition (folder), and loads its contents into the system registry.

Values under the registry key HKEY_LOCAL_MACHINE\Software\AppVersions represent software components. 
Each value/data pair specifies the name of the component and its version, respectively. These values must be 
string values.

The Symbol RDM and a number of off-the-shelf SNMP-based network management packages can read 
application version information (see Software Version Information under Monitoring MK1200s on a Network on 
page 4-15).

For a sample .reg file see the Web Kiosk Software Suite Web_KioskSoftwareSuite.reg file which contains the 
following text on two lines:

[HKEY_LOCAL_MACHINE\Software\AppVersions]
"Web_KioskSoftwareSuite"="x.x"

When an MK1200 that contains the Web_KioskSoftwareSuite.reg file in its Application folder (file is present at 
bootup) is queried by the RDM for application version information, it returns the application name and version: 
web_kiosksoftwaresuite and x.x. 

Radio Driver hrInstalledSoftware

Radio Firmware hrInstalledSoftware

Radio Hardware hrInstalledSoftware

N User Application names/versions hrInstalledSoftware

Processor Name/Type hrDeviceTable

RAM Size hrDeviceTable

Flash Size hrDeviceTable

Other devices hrDeviceTable

Partitions - name/size
(Platform, Application, Data, Object Store)

hrPartitionTable

Filesystem Information hrStorageTable

Table 7-2    Reported Software Component Versions (Continued)

Item Host Resource MIB Location

NOTE For tracking purpose, it is recommended that the name of the registry setting is the same as the registry 
file name.
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Actions - Custom MIB

When running OS version 1.1.1 and platform MK11XXPlat_2.00.17.hex or later, the MicroKiosk Custom HR MIB 
supports the actions and commands in Table 7-3.

Table 7-3    Custom MIB Actions/Commands

Action/Value Var Name OID Access Data Type

Cold Boot Cold boots the MK1200.

stiColdBoot SysOID.10.1 WO

Warm Boot Warm boots the MK1200.

stiWarmBoot SysOID.10.2 WO

Launch AirBeam Launches AirBeam with no command-line parameters, causing it to perform the 
function stored in its registry settings. There is no mechanism to provide command-line 
arguments to AirBeam using SNMP.

stiLaunchAirBeam SysOID.10.3 WO

GUID Returns the globally unique system identifier (GUID/UUID). Use this for reliable 
product tracking as this number does not change if the operating system or other 
portion of system software changes.

stiSystemGUID SysOID.10.4 RO String (DisplayString)

Product Group Alpha prefix for product (e.g., MK, MC, PDT, PPT, VRC). Allows filtering a class of 
devices in the Remote Terminal Manager.

stiProductGroup SysOID.10.7 RO String (DisplayString)

Product Numeric portion of product (e.g., 2000, 1200, 9000, 8100, 2800, 6900). Allows filtering 
a specific device in the Remote Terminal Manager.

stiProduct SysOID.10.8 RO String (DisplayString)

Generation Generation of device. For products with multiple hardware implementations 
(e.g., PDT 8100, PPT 2800). Allows filtering specific generations in the Remote 
Terminal Manager and refines product model reporting.

stiGeneration SysOID.10.9 RO String (DisplayString)

Domain A unique string used by the RDM to identify the product.

stiDomain SysOID.10.10 RO String (DisplayString)

Configuration Group 1 A user-defined string that can be filtered in the Remote Terminal Manager 
(e.g., hardware, housewares, East Coast).

stiConfGroup1 SysOID.10.11 RO String (DisplayString)

Configuration Group 2 A user-defined string that can be filtered in the Remote Terminal Manager 
(e.g., hardware, housewares, East Coast).

stiConfGroup2 SysOID.10.12 RO String

MIB Version The version of the terminal MIB.

stiCustomMibVersion SysOID.10.13 RO String (DisplayString)
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RegMerge and CopyFiles
RegMerge and CopyFiles are two device drivers included in the Windows CE OS to assist developers in 
configuring the MK1200 following a cold boot.

RegMerge.dll

RegMerge.dll is a built-in driver that allows making registry edits to the Windows CE Registry. Regmerge.dll runs 
very early in the boot process and looks for registry files (.reg files) in certain Flash File System folders during a 
cold boot. It then merges the registry changes into the system registry located in RAM.

Since the registry is re-created on every cold boot from the default ROM image, the RegMerge driver is necessary 
to make registry modifications persist between cold boots.

RegMerge looks in the root of two specific folders for .reg files in the following order:

1. \Platform

2. \Application

Regmerge continues to look for .reg files in these folders until all folders are checked. This allows folders 
later in the list to override folders earlier in the list. This way, it is possible to override Registry changes 
made by the Platform partition folders. Take care when using Regmerge to make Registry changes. The Device 
Configuration Package (DCP) for the MK1200 contains real examples of .reg files.

Modifying registry values for drivers loaded before RegMerge is not recommended. However, these values may 
require modification during software development. Since these early loading drivers read these keys before 
RegMerge can change them, you must warm boot the MK1200. The warm boot does not re-initialize the registry 
and the early loading driver reads the new registry values.

Do not use RegMerge to merge the same registry value to two files in the same folder, as the results are not 
predictable.

CopyFiles

Windows CE expects certain files to be in the Windows folder, residing in volatile storage. Windows CE maintains 
the System Registry in volatile storage. CopyFiles copies files from one folder to another on a cold boot. Files can 
be copied from a non-volatile partition (Application or Platform) to the Windows or other volatile partition during a 
cold boot. During a cold boot CopyFiles looks for files with a .CPY extension in the root of the Platform, then 
Application FFS partition. These files are text files containing the source and destination for the desired files to be 
copied separated by ">". Following is the content of a sample .cpy file that copies ScanSamp2.exe from the 
Applications\Samples folder to the \Windows folder.

Example:
Content of ScanSamp2.cpy
\Application\ Samples\ScanSamp2.exe > \Windows\ScanSamp2.exe

Files are copied to the Windows folder from the flash file system using copy files (*.cpy) in the following order:

\Platform
\Application

NOTE RegMerge only merges the .reg files during a cold boot. A warm boot skips the merge process.
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Accessing the Windows® CE Desktop
If an MK1200 is configured to launch an application on power-up, you can bypass the application at boot-up to 
access to the Windows® CE desktop. See Accessing the Windows® CE Desktop on page 6-3.

Password Protection (Gate Keeper)
The Gate Keeper application provides password protection preventing unauthorized access to the Windows® CE 
desktop. 

• At bootup: After Windows® CE boots (just after the blue Performing System Initialization (Phase 1) screen 
displays), but before an application launches, the Gate Keeper application checks (for two seconds) to see if 
the user selected the appropriate combination of buttons (currently A and D) to request password entry. See 
Accessing the Windows® CE Desktop on page 6-3 for the procedure. 

• While an application is running: Gate Keeper also password protects access to button functionality such 
as viewing the System menu while an application is running. See Setting Defaults Using the System Menu on 
page 3-5 and Table 7-5 on page 7-8 for a list of button functionality.

The buttons are mapped to produce the characters 1, 2, 3, 4, Enter, and Escape, as listed in Table 7-4. On the 
password screen, enter the desired character sequence and press Enter to submit the password and gain access 
to the Windows® desktop. If the password is incorrect, the MK1200 runs the specified user applications.

Use the RDM Protected Mode feature (System Configuration/Protected Mode) to set up password protection. See 
Protected Mode on page 3-14.

NOTE When specifying the protected mode password in the RDM or System Menu, enter the password in terms 
of the characters mapped by Gate Keeper (1-4), not the alphabetic labels (A-D) used in this document. 
The default password is 4,4,2,1,3.

Table 7-4    Button Mappings for Protected Mode

Button Combo Character / Action Note

A and D Request Protected Mode Only for 2 seconds after boot

A ‘1’ During password entry

B ‘2’ During password entry

C ‘3’ During password entry

D ‘4’ During password entry

A and B ‘Enter’ (Return) During password entry

C and D ‘Escape’ (Cancel) During password entry
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Remapping Buttons
Use the four buttons on the front of the MK1200 individually or in combinations. All 15 combinations can remap to 
a virtual keycode that represents a given character or key sequence, as defined in Table 7-5. Holding any 
combination that includes buttons B and C for more than 15 seconds causes a cold boot. Use the Control Panel - 
Button Definitions, the System Menu, or RDM to remap the buttons (see Table 7-6 on page 7-9).

Table 7-5    Default Button Mapping

Button Combo Mapping Hex Code

A Up 0x26

B Down 0x28

C Left 0x25

D Right 0x27

AB Enter/Return 0x0D 

AC Shift-Tab 0xC2

AD Alt 0x12

BC Show/Hide Virtual Keyboard 0xc7

ABC System Menu 0xC5

ABD Alt-Down 0xC3

ACD Touchscreen Calibration 0xC4

BCD Backspace 0x08

BD Tab 0x09

CD Cancel/Escape 0x1B

ABCD Signal Strength (Mobile Companion Information tab) 0xC6

NOTE To disable a button combination, set its mapping to 0. 

To perform a cold boot press and hold buttons B and C until the display goes blank (typically 15 seconds) 
then release the buttons.
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Button Remapping - Keycode Values

Use the keycode values in Table 7-6 to remap buttons.

Table 7-6    Keycode Values

Button Values

Function Value Function Value

BACK 0x08 COMMA 0xBC

TAB 0x09 HYPHEN 0xBD

CLEAR 0x0C PERIOD 0xBE

RETURN 0x0D SLASH 0xBF

SHIFT 0x10 BACKQUOTE 0xC0

CONTROL 0x11 F1 0x70

ALT 0x12 F2 0x71

CAPITAL 0x14 F3 0x72

ESCAPE 0x1B F4 0x73

SPACE 0x20 F5 0x74

PRIOR 0x21 F6 0x75

NEXT 0x22 F7 0x76

END 0x23 F8 0x77

HOME 0x24 F9 0x78

LEFT 0x25 F10 0x79

UP 0x26 F11 0x7A

RIGHT 0x27 F12 0x7B

DOWN 0x28 0 thru 9 are the same as ASCII '0' thru '9' 0x30 – 0x39

MULTIPLY 0x6A A thru Z are the same as ASCII 'A' thru 'Z' 0x41 - 0x5A

ADD 0x6B SHIFT-TAB 0xC2

SEPARATOR 0x6C ALT-DOWN 0xC3

SUBTRACT 0x6D CALIBRATION 0xC4

DECIMAL 0x6E SYSTEM MENU 0xC5

DIVIDE 0x6F SIGNAL STRENGTH 0xC6

SEMICOLON 0xBA TOGGLE SOFTWARE INPUT PANEL (SIP) 0xC7

EQUAL 0xBB
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Network Time Update: SNTP Client
The MK1200 Simple Network Time Protocol (SNTP) client can automatically set and update the MK1200 time and 
date through the network. Use this feature to set the system time and date after reboots or power outages. This 
feature also ensures consistent time and date stamping across a fleet of MK1200s. The SNTP Client program 
queries the specified SNTP server over the network to set the time and date.

The SNTP client shipped with MK1200 WinCE 4.20 is the Microsoft default SNTP Client program. (This is a 
change from the WinCE 4.1 operating system, which had a custom SNTP client).

MK1200 allows changing four parameters of the SNTP Client. See Network Time Update on page 3-12.

Memory Management

Flash: Nonvolatile (Persistent) Memory

The MK1200 has 32 MB of available nonvolatile flash memory. 3.25 MB is committed for platform partition use to 
install external driver packs such as RF drivers. 7.75 MB is available for developer’s applications within the 
application partition (folder). The data stored in flash memory persists through cold boot cycles.

To increase usable persistent (flash) memory, use TCM to adjust the allocation of memory between the application 
and platform partitions.

Add a PC card to the MK1200 to increase the non-volatile memory available for file storage.

RAM: Volatile (Non-Persistent) Memory

The MK1200 has 32 MB of DRAM volatile memory. Developers can automate control of the device’s RAM (volatile) 
memory allocation (storage vs. memory used to run programs) to persist memory allocation settings through cold 
boot cycles.

Use the Symbol RDM or the System Menu to permanently configure RAM memory allocations (memory used to 
run programs). (System Configuration > Memory Allocation > SystemStorePercent).

NOTE The RDM/System Menu can only configure unused RAM.
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FTP Server
The MK1200 supports the minimum implementation of the FTP server defined in RFC 959, which includes 
configuration values, transfer parameters, and supports only ASCII and image data types.

The FTP server is enabled by default. Use the RDM utility FTP Server feature (Update/FTP Server) to set up the 
FTP server. See page 3-19.

FTP Server Registry Parameters

• Allow Anonymous - This parameter determines whether to provide anonymous access to users for copying 
data from MK1200. When enabled, users do not need an account on the local machine.

• Allow Anonymous Upload - Use this parameter to enable/disable anonymous users to copy data to the 
MK1200.

• FTP Enable Part I - This parameter determines whether the FTP server is loaded/accessible when the 
MicroKiosk is powered on. Disabling this does not affect the RDM’s ability to load or retrieve mkconfig.reg 
files using the Push Configuration File and Retrieve Remote Configuration File options respectively.

• FTP Enable Part II - Enabling this parameter allows the RDM to load/retrieve a mkconfig.reg file even if the 
MicroKiosk FTP server is disabled (FTP Enable Part I = disabled). If both FTP Enable Part I and FTP Enable 
Part II parameters are disabled, you cannot load the mkconfig.reg file remotely using the RDM or FTP. 
However, you can load the mkconfig.reg file locally using an ActiveSync connection or a PC card.

• Root Directory - Use this parameter to set the root directory, which could be accessed remotely. If you do 
not specify the root directory, the default \Temp is set.

• Use Authentication - Use this parameter to enable/disable authorization to connect to the server. If enabled, 
a valid user account on the local machine is required and the correct ID and password for the account must 
be specified to the server.

• User Authentication Domain - Valid Windows domain to look for users that are allowed to access FTP 
service. The FTP server authenticates user password from this Domain Controller.

• User List - Use this parameter when the Use Authentication parameter is enabled to set the list of users that 
are able to access the FTP server.

NOTE You cannot use FTP to update partitions.

CAUTION Never enable the server in anonymous mode if the MK1200 is accessible from the internet.
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AirBEAM
The following AirBEAM parameters are not viewable on the MK1200’s AirBEAM screens:

• Configure/Misc(1): WNMS (Default = WNMS disabled)

• Configure/Misc(2): Close Apps (default = Close Apps enabled)

Use registry settings to configure these parameters.

Inactivity Application (Screen Saver)
The Inactivity Application Manager (IAM) is the screen saver engine for the MK1200. It launches and terminates 
the screen saver at appropriate times but does not provide the screen saver images.

Use one of the provided applications, or create an application. Use the RDM utility Inactivity Manager feature to 
configure the IAM (System Configuration > Inactivity Manager). See Inactivity Manager on page 3-22.

The screen saver exits if any of the following events occur:

• bar code scan

• pen tap

• button press

• MSR swipe.

Note that using a bar code scan or an MSR swipe to exit the screen saver also passes this data to the application 
using an ActiveX object, while using a pen tap or button press to wake the device does not pass any additional 
information to other applications.

SimpleSaver

The SimpleSaver program is the default IAM application, and clears the screen to white and repeatedly displays 
the following message at different locations on the screen:

Perform some action to wake me up!

This provides a simple example of how to implement a custom application, and is not intended as a final 
presentation tool. The SMDKs provide source code.

SlideShow

The SlideShow screen saver program endlessly displays a group of graphics files (slides) one at a time. The 
program supports the following file extensions:

• JPG

• GIF

• BMP

• 2BP.
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The program uses the following registry entries under the [HKEY_LOCAL_MACHINE\Software\Symbol\SlideShow] 
key:

• Directory - A string value specifying the directory containing the graphic files. Only one directory is 
supported.

• Delay - A DWORD value indicating the number of seconds to display each graphic. If not specified, the 
default is 5 seconds. The minimum duration is 2 seconds.

• Background - A DWORD value specifying the background color to use around graphics that are smaller 
than the screen size. If not specified, the default background is black.

Set these values using the RDM. The program does not accept command line parameters.

Once the program has read the registry entries, it reads a file named SlideShow.txt from the graphics directory. This 
file should contain one file name per line. These file names should not include a path and must exist within the 
graphics directory. The files appear in the order specified.

If the SlideShow.txt file is not present, the program scans the graphics directory for all files with the appropriate file 
name extensions and displays these files in a sequence determined by the file system.

If a slide is smaller than the screen size, it is centered on the screen and the background color appears around the 
slide. If a slide is larger than the screen size, it is scaled to fit on the screen. This can result in an undesirable effect 
if the slide is not proportional to the screen size. For best results, use slides that are the same size as the screen. 
Source code is provided in the SMDKs.

Browser Applications - Hiding Toolbars
The MK1200 ships running the standard browser (iesample.exe), which leaves the Windows® CE start bar and the 
Internet Explorer toolbar accessible. To run a browser application with no toolbars (Windows CE® start bar and 
Internet Explorer toobar), use KioskIE.exe. To start the browser application using KioskIE.exe without toolbars, use 
the RDM. 

First, within the RDM, configure the “first application launched” for KioskIE.exe, using the path: 

system configuration/user app(s)/First application launched/application path
Enter \windows\KioskIE.exe in the application path field.

Second, set the start page for the browser. The path to the start page is:

applications/Internet Explorer/[start page]

Then enter the start page URL.

For sample source code that demonstrates hiding browser toolbars and the Windows® CE start bar from a browser 
application, refer to the MK1100_WebKSS_Install+SourceCode.doc file, which is part of the Web Kiosk Software 
Suite (see page 6-3).

NOTE If using wireless connectivity and the start page is stored within the network, set a delay of about 10 
seconds before KioskIE.exe launches to allow time for the MK1200 to establish the wireless connection. 
See Configuring User Application(s) on page 3-18.
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Browser Applications - Handling Network Disconnects
The KioskIE.exe browser can redirect to a custom Error Recovery Page if it detects an Internet Explorer error page 
(like a error 404). Since the errors are likely to occur during network outages, Symbol recommends using locally 
stored files to drive the custom error recovery page. Once directed to a local URL, a customer friendly message 
appears while script code retries to connect. 

• Specify the on-board error recovery page to appear in Applications > Kiosk IE > ErrorRecoveryPage. See 
ErrorRecoveryPage on page 3-7.

• The device includes a sample page in \Windows\RetryPage.html.

Configuring Error Page Redirection
KioskIE includes an Error Page Redirection feature that defines specific HTML code as errors and allows the 
KioskIE to navigate to an on-board error recovery page. For this purpose the .reg file KioskIE_ErrorPageList.reg is 
added to either the Platform or Application folder. The .reg file includes the following entries:

[HKEY_CURRENT_USER\Software\Symbol\IEBrowser]
"PageErrorList"=hex(7):\ 54,68,65,20,70,61,67,65,20,63,61,6e,6e,6f,74,20,62,65,20,66,6f,75,6e,64,00,\
43,61,6e,6e,6f,74,20,66,69,6e,64,20,73,65,72,76,65,72,00,\
46,6f,72,63,65,20,45,72,72,6f,72,00,00,00,00

These entries correspond to the following common errors reported by most Web servers:

• Line 1: The page cannot be found.

• Line 2: Cannot find server.

• Line 3: Force error.

To add a new error page, append the title of the error page to the registry entry above. The entry is stated in the 
hex value of the corresponding ASCII characters in the title of the error page.

For example, to add an error page titled "AAA BBBB CCCCC" to the error pages shown above, append the registry 
entry for the new error page as ‘line 4’, shown below.

[HKEY_CURRENT_USER\Software\Symbol\IEBrowser]
"PageErrorList"=hex(7):\
54,68,65,20,70,61,67,65,20,63,61,6e,6e,6f,74,20,62,65,20,66,6f,75,6e,64,00,\
43,61,6e,6e,6f,74,20,66,69,6e,64,20,73,65,72,76,65,72,00,\
46,6f,72,63,65,20,45,72,72,6f,72,00,\
41,41,41,20,42,42,42,42,20,43,43,43,43,43,00,00,00,00
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Loading Additional Fonts on the MK1200
You can program the MK1200 to support additional fonts such as Unicode and double-byte character font. 

The MK1200 supports the following system fonts as shipped from the factory. The font files corresponding to these 
formats are located in the \windows folder with .ttf extension.

• Arial

• Courier New

• Symbol 

• Tahoma

• Times New Roman

• Verdana

• Wingding.

The default system font path for these fonts is \windows.

Use one of the following options to load fonts not supplied with the MK1200:

• Change the system font path where the system looks for fonts. For example, to change default system font 
path from \windows to \application\fonts add the following registry to the system along with new fonts in 
\application\fonts:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\FontPath]
"FontPath"="\application\fonts"
Adding this registry changes the entire system fonts directory, so fonts supplied with the OS are no longer 
available. To use both the provided system fonts and new fonts, copy the system default fonts to the new font 
directory. 

• Copy new/alternate fonts to the default \windows directory. 

• Copy alternate fonts to the \windows\fonts directory. 

Copying new fonts to the \windows or \windows\fonts preserves existing fonts. However the new fonts consume 
system RAM as they are part of the ObjectStore.

Using the third option, i.e., copying fonts to the \windows\fonts directory, makes it easier to manage the system. 
Note that fonts copied to \windows or \windows\fonts do not persist over power cycles or cold boots. Use the copy 
file feature to persist them over power cycles or cold boots.

Using Additional Fonts in Native Applications

Any application written in EVC can use the additional fonts using either MFC or Win32 APIs. If a specified font is 
missing, the system uses an available font for display.

Using Additional Fonts in Managed Applications

All fonts installed in the system are available to the .Net Compact Framework during runtime.
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Using Additional Fonts in Browser Applications

Regardless of how you installed the font in the system, to reference it using a browser page, specify the font as a 
STYLE, or use FONT tags. Use intuitive names for the fonts (use FontViewer on a Windows desktop and locate the 
Typeface Name line), and use quotes to enclose names with spaces. If the specified font is missing, Internet 
Explorer uses its default font to display the text.

Things to Consider when Using Additional Fonts

• Different font styles (e.g., bold and italic) often require separate TTF files; be sure to provide all required 
styles. Do not reference styles by name (e.g., Arial Bold); set the style separately from the font (e.g., using a 
“b” or “strong” tag, or a style).

• For best results, do not direct the system font path to a storage card (PCMCIA or Compact Flash), as this can 
negatively impact system performance. If this method is necessary, test the use of a storage card thoroughly 
for fonts to ensure proper operation.

• Most Web pages contain information that tells the browser what language encoding (the language and 
character set) to use. If the page does not include that information, and the Language Encoding Auto-Select 
feature is on, Internet Explorer can usually determine the appropriate language encoding. If not, manually 
select it using View > Encoding > More, then select the appropriate language.

NOTE If the Auto-Select feature or a specific language pack is not installed, Internet Explorer prompts you to 
download the files. Adding languages does not guarantee Web pages display in the preferred language.
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Input Panel (Virtual Keyboard)
Use the input panel (virtual keyboard) on the touchscreen of the MK1200 to enter information.

To access the Input Panel, tap the  icon in the icon tray. To enter information, use a stylus to select the keys on 
the input panel. To close the Input Panel, double-tap the icon.

Figure 7-1    Input Panel (Virtual Keyboard)

NOTE To access the virtual keyboard, press the physical buttons B and C simultaneously.

NOTE Use Ctrl-C to copy text, and Ctrl-V to paste text.
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Microsoft WordPad
Microsoft WordPad is an application that allows creating, editing, and viewing documents on the MK1200. 
Password-protect a document if desired.

Figure 7-2    Using WordPad

To open a file on the MK1200, tap File > Open. The file must be in a format that WordPad can read (or convert). 
WordPad can explore the MK1200 to find files stored on the device. Select a file in the list and tap OK to open it. 

Figure 7-3    Open File Dialog Box

Enter information in WordPad as with any text editing program. Select font type, style, color, and size. Use the input 
panel to enter typed text into a document. See Input Panel (Virtual Keyboard) on page 7-17.

To format or edit text, select the text by dragging the stylus across the text. To search a document for specific text, 
tap Edit > Find. 

To change the zoom magnification, tap View > Zoom. Select the percentage. Select a higher percentage to enter 
text and a lower one to see more of the document.

If opening a document created on a host computer, tap View > Wrap to Window to see the entire document.
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Internet Explorer
Use Microsoft Internet Explorer (6.0 compliant) to view Web pages on the MK1200. Use the MK1200 SMDKs to 
customize the appearance of Internet Explorer.

Use the RDM to configure some parameters of Internet Explorer. See Internet Explorer on page 3-6.

To access Internet Explorer, tap Start > Programs > Internet Explorer or double-tap the Internet Explorer icon on the 
MK1200 desktop. The internet browser window opens (see Figure 7-4).

The MK1200 OS also includes kioskie.exe, which hides the toolbar and the Windows Start bar, menus, title bar, 
and status bar. Symbol recommends using kioskie.exe as the default browser when running web applications. See 
Browser Applications - Hiding Toolbars on page 7-13.

For information on loading alternate fonts, see Loading Additional Fonts on the MK1200 on page 7-15. 

For information on handling network disconnects and their associated error recovery pages such as error 404, see 
Browser Applications - Handling Network Disconnects on page 7-14.
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Browsing the Web

Go to a specific Web page in one of the following ways:

• Tap Favorites, then tap the favorite to view. Note that new favorites added are not persisted as part of 
Internet Explorer settings.

• In the address bar at the top of the screen, enter the Web address using the input panel and tap the Enter 
button, or tap the arrow to choose from previously entered addresses.

Figure 7-4    Internet Explorer

Favorites Menu
Home Button

Refresh ButtonBack Button Search Button
Stop Button
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Printer Object Test
Use the Printer Object Test Page to debug serial printer connections and to print test bar codes, bitmaps, and text. 
Within Internet Explorer, select Favorites > Printer Object Test Page. The Printer Language drop-down menu lists 
supported printers, and includes the following information for each printer:

• Programming language acronym (for example, CPL)

• Printer company (for example, Zebra)

• Supported printers (for example, Epson, Zebra. See Printing on page 3-17 for models).

Figure 7-5    Printer Object Test Page
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MSR Object Test
Use the MSR Object Test Page to test the MSR from the browser application. Select Favorites > MSR Object Test 
Page to load the MSR Object Test Page.

Figure 7-6    MSR Object Test Page
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Scanner Object Test
Use the Scanner Object Test Page for debugging scanner setup from the browser application. Select Favorites > 
Scanner Object Test Page to load the Scanner Object Test Page.

Figure 7-7    Scanner Object Test Page
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MicroKiosk Object Test
Use the MK Object Test Page for debugging MicroKiosk Object setup from the browser application. Select Favorites 
> MK Object Test Page to load the MicroKiosk Object Test Page.

Figure 7-8    MicroKiosk Object Test Page



Chapter 8 Software Development 
Environments
Introduction
The MK1200 operating system is Windows CE .NET 4.2, which supports the major technologies and functions 
needed to develop applications in any of the following environments:

• Native Windows® CE applications in C and C++

• Managed .NET applications in C# or VB.NET *

• Browser-based applications in VBScript or JScript

* C# and VB.NET require a separate installation of the .NET Compact Framework (.NETCF).

Symbol Mobility Developer Kits (SMDKs)
The following software developer kits are available for the MK1200:

• SMDK for C - for developing native C/C++ applications

• SMDK for the Web - for developing browser-based applications

• SMDK for .NET - for developing managed .NET applications in C# or VB.NET.

All Symbol Mobility Developer Kits are available as free downloads from the Symbol DevZone: 
http://devzone.symbol.com/.
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Symbol Mobility Developer Kit (SMDK) for C

The Symbol Mobility Developer Kit for C is based on industry-standard Microsoft® Windows® CE development 
tools and enables development of native C and C++ applications. Use this developer kit in conjunction with 
Microsoft® Embedded Visual C++ 4.0 Service Pack 3 and Symbol’s Platform SDK (PSDK) for MK1200c42. 

SMDK for C includes the following components:

• Standard Symbol C API Libraries

• MK1200-specific C API Libraries

• Help file containing a C API Reference Guide

• Sample applications with full source code.

Sample Applications

The sample applications are included as a learning tool, to show developers how to interface with the Symbol C 
API functions. Some of the sample applications contained in the kit include:

Hello: A simple Hello World application.

DisplayTest: Displays various colors on the LCD screen.

KeyCheck: A keyboard checking utility that displays the keys pressed on the device and their associated 
WM_MESSAGE.

ScanSamp2: Demonstrates the bar code scan engine (and external scanner).

MSRSamp2: Displays the MSR track data when a card is swiped.

KioskWedge: Provides non-scanning aware applications the ability to receive scanned bar code data. 
KioskWedge interfaces with the scanner driver, captures selected types of bar code data, and sends the bar code 
data as keystrokes to the window with the keyboard focus (if any).

MemTest: Displays the amount of available memory. Allocate and free blocks of memory to see how available 
memory changes.

Win32PrintSamp: Prints a sample page to a connected printer.
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Symbol Mobility Developer Kit (SMDK) for the Web

The Symbol Mobility Developer Kit for the Web enables development of browser-based applications written in 
VBScript or Jscript. Use this developer kit in conjunction with any web page editor such as Microsoft Front Page or 
Notepad. It contains the following components:

• Documentation for the Symbol ActiveX Object library *

• Sample HTML/Jscript applications

• Outside the SMDK for the Web, see Chapter 6, Web Kiosk Software Suite and WebKSS Source Code Index 
on page 6-14.

* The ActiveX objects are built into the MK1200 operating system and do not need to be loaded.

The MK1200 ships with Internet Explorer CE version 6.0 browser, which supports VBScript and Jscript. See 
http:\\www.microsoft.com for information on Internet Explorer CE version 6.0 features and limitations.

The MK1200 operating system also includes the KioskIE.exe browser, which runs in full screen mode without the 
browser toolbar. See Browser Applications - Hiding Toolbars on page 7-13.

ActiveX objects provide control over the scan engine (and external scanner), four programmable buttons, 
microphone, MSR, and printers. For information on loading alternate fonts onto the MK1200, see Loading 
Additional Fonts on the MK1200 on page 7-15.

Symbol Mobility Developer Kit (SMDK) for .NET

The Symbol Mobility Developer Kit for .NET allows Microsoft® .NET Compact Framework developers to create 
managed (C# and VisualBasic.NET) applications that harness Symbol value-add features on the MK1200. Use this 
developer kit in conjunction with Microsoft® Visual Studio.NET 2003.

The SMDK for .NET includes the following components:

• Class libraries

• Sample applications

• Documentation describing how to use the methods for each class library

• Outside the SMDK for .NET, refer to the C# Kiosk Software Suite and C# KSS Source Code Index sections in 
the MK2000 Product Reference Guide.

NOTE MK1200 supports only the following Active X Objects/Controls: Printer, BarcodeReader, MKUtility, and 
MSR.
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Appendix A  Technical Specifications
For the latest technical specification information for the MK1200, visit: http://www.symbol.com/MK1200
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Appendix B  RF Network Configuration
Introduction
There are two alternative platform partitions available for the MK1250 (WinCE 4.2 OS v3.0.0 Platform 
1150c42Plat32M301.hex) that enable different RF clients to configure the 11 Mbps wireless connection. 

• To implement WPA enterprise-level wireless security in the wireless connection, use the Aegis Client version 
2.1.4 to configure the wireless connection. 

• Alternatively, use Symbol Mobile Companion version 3.9.3.76.

Automated Launch of Aegis Client
By default, the Aegis Client launches at startup and runs in the background on MK1250s using platform 
partition 1150c42Plat32Mxxx.hex. 

The AegisEnable.reg file included in this partition enables this. Deleting this file or renaming its .reg extension 
causes Mobile Companion to launch upon boot up. In this case, to access Aegis Client double-tap its desktop 
icon or press all four of the MK1250’s buttons simultaneously. The Aegis Client icon then appears in the task bar; 
select this to display its configuration window. 

To close the Aegis Client window but continue to run the application in the background, select Client tab > Close. To 
exit the application completely, select Client tab > Exit.

NOTE Mobile Companion supports WPA Home, but not WPA Enterprise.

NOTE To use Mobile Companion on an RF unit, you must first disable Aegis Client or conflicts can occur.
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Aegis Client
Install the Aegis Client included in the platform partition 1150c42Plat32Mxxx.hex onto the MK1250 to 
implement WPA enterprise wireless security. Wireless MK1250s ship from the factory with this client installed. 

Use the Aegis Client to configure the MK1250’s Spectrum24 wireless network settings. See Aegis Client 
documentation for more information.

Persisting Aegis Settings

To permanently save the settings configured by the Aegis Client, run Start > Programs > Tools >Save Aegis 
Configuration. This creates the \Applications\Aegis.reg file containing the configured parameters.

To save certificates installed on the MK1250 for use by Aegis Client, run Start > Programs > Tools > Save 
Certificates. This preserves the certificate across cold boot cycles.

Using Certificates with Aegis Client

When the MK1250 is operating with the default system time after a cold boot (1st of June 1999 12:00:00 AM) 
and cannot update its time over SNTP because it is not connected to the network, perform the following to use 
certificates with Aegis:

1. Manually set the date and time. 

2. Install the certificate.

3. Create a bat file, e.g., SetDate.bat, as follows:
date mm-dd-yyyy
time hh:mm:ss

4. Create a folder named StartUp in the Application folder, and copy this bat file to it.

5. Use Aegis to connect to the required network with the installed certificate.

6. Select Start > Programs > Tools > Save Certificates and Start > Programs > Tools > Save Aegis Configuration 
to save them over power cycles.

IP Configuration of Aegis Client

The Aegis Client does not provide an interface to configure IP settings applicable for NETWLAN adapter. To 
configure IP settings, on the MK1250, select Start > Settings > Network & Dial-up Connections > NETWLAN and 
set the configurations. Then select Start > Programs > Tools > Save Aegis Configuration to preserve the settings 
over cold boot cycles.

NOTE To deploy the same Aegis settings on multiple MK1250 devices, copy the Aegis.reg file to other MK1250 
devices.
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Mobile Companion (11 Mbps Radio)
The MK1250 supports wireless communication using Spectrum24 wireless LAN connection. This requires properly 
configured Access Points (APs) within the facility. Refer to the AP documentation to set up the wireless LAN 
hardware.

Use the Mobile Companion utility to configure the MK1250 wireless network settings. The Mobile Companion icon 
appears in the task tray (see Figure B-1 on page B-3), and indicates MK1250 signal strength as follows:

The Mobile Companion utility starts automatically if the MK1250 is equipped with a Spectrum24 11 Mbps card. The 
status icon appears in the task tray and changes in real-time to reflect the signal strength and availability of the 
adapter and the wireless network. Tap the icon to open the Mobile Companion menu.

Figure B-1    Mobile Companion Menu

Icon Status

Excellent signal strength

Very good signal strength

Good signal strength

Fair signal strength

Poor signal strength

Out-of-network range (not associated)

Mobile Companion icon

Mobile Companion Menu

Task tray
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When the menu opens, select Status, WLAN Profiles, Find WLANs, or Options.

Menu Item Description

Status Displays the current status and information for the wireless connection.
Signal tab - displays radio signal transmission strength from the adapter (using its current 
profile) to the associated AP.
Info tab - displays software, driver, firmware, hardware, and country information for the 
current profile.
IP Status tab view - displays network address information.
Ping tab - displays signal strength data and data rate, and performs data transmission 
tests between the MK1250 and associated AP or client.
APs tab - displays APs with the same ESSID as the current MK1250 profile. Set the 
MK1250 roaming capabilities.

WLAN Profiles Lists the current profiles and allows adding, editing, and deleting profiles. 
Only the Default profile is maintained in mkconfig.reg. Perform all configuration with the 
Default profile only. Do not create additional profiles. These are not saved through a cold 
boot cycle. Under Edit, the Mode, Encryption, IP Config, and Power tabs show the 
ESSID, security settings, network address information, and power consumption level for 
that profile. See page B-6.

Find WLANs Displays a list of Spectrum24 networks (APs and networked peers) available to the 
MK1250 for association. The networks are listed by ESSID. Tap a network and tap 
Connect to interoperate with the AP representing that network. See Find WLANs on 
page B-13 for more information.

Options Displays settings for configuring system sounds, AP and MK1250 association 
capabilities, profile roaming options, and the password protecting the Mobile Companion 
utility.
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Configuring Mobile Companion
Mobile Companion is launched at power-up if an 11 Mbps Spectrum24 radio and driver are installed in the MK1250. 
The Mobile Companion icon appears in the task tray. If it does not launch, manually launch Mobile Companion on 
the MK1250 by double clicking \Windows\EVMON.EXE. 

Select WLAN Profiles from the Mobile Companion menu to view, connect to, create, and edit a profile. A completed 
profile contains adapter configuration settings for use in different locations to connect to a wireless network. 
Symbol recommends using only the Default profile.

Options available in the WLAN Profile window are:

• Select the default profile from the list and tap Connect to set that profile as the active profile. The active 
profile displays the transmit and receive icon to the left. Once selected, the MK1250 uses the ESSID, 
encryption, and power consumption settings configured for that profile.

• Select a profile from the list and tap Edit to make changes to the profile. See Editing Profiles on page B-6.

• Tap New to set the profile name and ESSID on the Mode tab. Use the Encryption, IP Config, and Power tabs 
to set security, network address information, and power consumption level for the new profile.

• Select a profile to delete from the list and tap Delete to remove that profile.

• Select a profile from the list and tap Move Up or Move Down to order the profile. If the current profile 
association is lost, Mobile Companion attempts to associate with the first profile in the list, then the next, until 
a new association is achieved.

Configuring the Default Profile

1. Tap on the task tray icon and select WLAN Profiles from the Mobile Companion menu. The WLAN Profiles 
window displays existing profiles.

Figure B-2    WLAN Profiles

2. If no changes are required for the profile, select Default and tap Connect to set this as the active profile. The 
Default profile displays the transmit and receive icon to the left.
To edit the ESSID, operating mode, profile power consumption, and security parameters first, see Editing 
Profiles on page B-6.
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Editing Profiles

Mode Tab

1. To change the ESSID and operating mode for a profile, select the profile and tap Edit to display the Mode 
tab. 

Figure B-3    Mode Tab

2. Set the operating mode from the Operating Mode drop-down list. Choose Infrastructure (the default mode) 
to enable the MK1250 to transmit and receive data with an AP. 
Select the country of operation for the MK1250 from the Country: drop-down list. This should match the 
APs country setting, and be appropriate for the country of operation. Select International if using the 
MK1250 with a non-Symbol AP or a pre-AP 4131 model.

3. To save the Mobile Companion settings and retain them across cold boot cycles, tap Start > Programs > 
Save Configuration.

Authentication Tab

Select the Authentication tab to configure server-based authentication. Select one of the following 
Authentication options from the Authentication drop-down list.

• None - Default setting when authentication is not required on the network. The client adapter does not 
use any authentication scheme when Open System is selected on the Encryption tab.

• Kerberos 

• LEAP 

• EAP-TLS 

• PEAP.

Infrastructure Mode
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Figure B-4    Mobile Companion - Authentication Tab (Kerberos)

Authentication Description

Kerberos 
(see Figure B-4)

Kerberos is a different form of 128-bit data security. An adapter is required to have its request 
for access point resources authenticated with a Kerberos server before the server permits the 
access point to transmit and receive data with the associated adapter. When Kerberos is 
selected, the KDC and Realm entry fields appear. The KDC field should remain with the default 
KDC name (krbtgt) unless it is changed in the server. Enter the name of the server that hosts 
the Kerberos KDC in the Realm field. The KDC is located on a server and maintains 
information about the access points and users it supports. The KDC also permits the 
transmission and receipt of data once the credentials of the user are verified.
Tap Kerberos Options to configure different caching modes for Kerberos credentials. When 
connecting to a Kerberos supported profile, the system can prompt for the associated user 
name and password at specified instances during the authentication process. Caching of 
credentials is optional.
Kerberos Options:
Select any combination of the following Kerberos Credential Caching settings:
Reset: When selected, the system prompts the user for the username and password upon a 
warm boot.
Connect: When selected, the system prompts the user for login information when the system 
initiates a connection to the ESSID.
Time: When selected, the system requests a user name and password after the specified time 
parameter. Available time parameters are specified as an Interval (in minutes) or At (hh:mm) a 
specified time (chosen with the pull-down menu). If a time option is not selected, authentication 
continues without a user name and password verification.
Resume: When enabled, the system prompts the user for username and password after the 
system is suspended and subsequently resumed. If disabled, the system prompts for a 
username and password only if the user's credentials are not in the registry.

Kerberos Authentication Credential Caching Settings
(Kerberos Options)
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Figure B-5    Mobile Companion - Authentication Tab (LEAP)

Figure B-6    Mobile Companion - Authentication Tab (EAP-TLS)

Authentication Description

LEAP
(see Figure B-5)

Select this option to enable LEAP authentication. LEAP is founded on mutual 
authentication. The AP and the mobile computer attempting to connect to it require 
authentication before access to the network is permitted.

Authentication Description

EAP/TLS
(see Figure B-6)

EAP/TLS is an authentication scheme through IEEE 802.1x. It authenticates users and 
ensures only valid users can connect to the network. It also restricts unauthorized users 
from accessing transmitted information. EAP/TLS achieves this through secure 
authentication certificates.

EAP-TLS Authentication Install / View Certificates
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Figure B-7    Mobile Companion - Authentication Tab (PEAP)

NOTE Run Start > Programs > Tools > Save Certificates to persist the certificate on the MK1250 across cold 
boot cycles.

Authentication Description

PEAP
(see Figure B-7)

Select this option to enable PEAP authentication. This method uses a digital certificate to 
verify and authenticate an user identity.

PEAP Authentication Install / View Certificates

NOTE Run Start > Programs > Tools > Save Certificates to persist the certificate on the MK1250 across cold 
boot cycles.
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Encryption Tab

Select the Encryption tab to set the adapter profile security level by configuring the encryption scheme and 
corresponding keys. Select an option (Open System, WEP, Keyguard-MCM, TKIP (WPA)) from the Encryption 
drop-down list.

Figure B-8    Encryption Tab

The absence of a physical connection makes wireless links vulnerable to information theft. Encryption is an 
efficient method for preventing data theft and improving data security.

If an Access Point (AP) is set to 40-bit and an adapter is set to 128-bit, the adapter can associate to the AP. 
However, no data transmission and reception can take place when these settings are in place.
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Select one of the following Encryption options from the drop-down list:

IP Config Tab

Tap the IP Config tab to configure the following MK1250 profile network address parameters: IP address, subnet, 
gateway, DNS, and WINS. Changes made within the IP Config tab only impact the profile selected in the Mode tab 
and do not impact the network address parameters configured for other profiles.

Figure B-9    Mobile Companion - IP Config Tab (DHCP)

• Select Dynamic Host Configuration Protocol (DHCP) from the IP Type drop-down list to obtain a leased IP 
address and network configuration information from a DHCP server. DHCP is the default setting for the 
MK1250 profile. When DHCP is selected, the IP address fields are read-only.

Open System
(no encryption)

Select this option when no data packet encryption is needed over the network. This option 
provides no security for data transmitted over the network. The window displays only the OK 
and Cancel buttons.

WEP Select this option to use WEP keys for encryption. The window displays several radio buttons 
and edit buttons to configure the WEP keys.
Specify the keylength by selecting the 40-bit or the 128-bit radio button (128-bit is the default). 
Enter WEP keys in the edit boxes. The number of edit boxes is determined by the selected key 
length (10 Hex digit value for 40 bit keys, 26 Hex digit values for 128-bit keys). 
Use the Key radio buttons to configure the four WEP keys. The adapter uses the selected key. 
Select the ResetKeys button to set the encryption key to the default values.

The default Hex digit keys are visible any time they are used. As a security precaution the WEP 
keys appear in asterisks ("*") within the Encryption key fields.
If the associated access point uses an optional Passkey, the "active" adapter WLAN profile 
must use a Passkey as well. The Passkey is a plain text representation of the WEP keys 
displayed in the Encryption property window. Use the Passkey to enter WEP key data without 
having to remember the entire 40-bit (10 character) or 128-bit (26 character) Hex digit string.
Tap Passkey. On the Passkey screen, enter an easy-to-remember character string in the range 
4 to 32 to use as the WEP algorithm, then select OK. The access point transforms the Passkey 
string into a set of four WEP keys using MD5 algorithms and displays them in the WEP fields. 
The selected adapter profile uses these new WEP keys, and behaves as if the keys were 
entered manually.

TKIP (WPA) Select this option for the client adapter to use Wireless Protected Access (WPA) through TKIP. Enter the 
pre-shared keys in the edit boxes. Tap ClearKey to clear all keys and enter new key values. Tap 
Passkey to display the Passkey screen. Enter an easy-to-remember 8 to 63 character string.
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• Select Static to manually assign the IP, subnet mask, default gateway, DNS, and WINS addresses used 
by the MK1250 profile.

Figure B-10    Mobile Companion - IP Config Tab (Static)

Power Tab

The MK1250 always uses the Automatic Power Saving Mode setting, which provides the best network 
performance.

Persisting Mobile Companion Settings

To permanently save the Mobile Companion settings run Start > Programs > Tools > Save Spectrum24 
Configuration. This creates \Applications\Spectrum24.reg file containing the configured parameters.

IP Address The Internet is a collection of networks with users that communicate with each other. Each 
communication carries the address of the source and destination networks and the 
particular machine within the network associated with the user or host computer at each 
end. This address is called the IP Address (Internet Protocol address). Each node on the IP 
network must be assigned a unique IP address made up of a network identifier and a host 
identifier. Enter the IP address as a dotted-decimal notation with the decimal value of each 
octet separated by a period, for example, 192.168.7.27. 

Subnet Mask Most TCP/IP networks use subnets to manage routed IP addresses. Dividing an 
organization's network into subnets allows it to connect to the Internet with a single shared 
network address, for example, 255.255.255.0. 

Gateway The default gateway is a device used to forward IP packets to and from a remote 
destination.

DNS The Domain Name System (DNS) is a distributed Internet directory service. DNS translates 
domain names and IP addresses, and controls Internet email delivery. Most Internet service 
requires DNS. For example, if DNS is not configured, Web sites cannot be located and/or 
email delivery fails.

WINS WINS is a Microsoft® Net BIOS name server. WINS eliminates the broadcasts needed to 
resolve computer names to IP addresses by providing a cache or database of translations. 

NOTE To deploy the same Mobile Companion settings on multiple MK1250 devices, copy the spectrum24.reg 
file to other devices.
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Find WLANs
Select Find WLANs from the Mobile Companion menu to list the ESSIDs of active wireless LANs operating in the 
vicinity of the MK1250. 

Figure B-11    Available WLAN Networks

Select a WLAN ESSID and tap Connect to view the Mode tab. The Profile Name: and 802.11 ESSID: fields reflect 
the ESSID selected. 
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Status
To view the status of the wireless network connection, select Status from the Mobile Companion menu.

1. Tap the Signal tab to view a real-time graph of the signal quality of the MK1250 to the associated AP 
(Infrastructure Mode only), including the number of times the MK1250 roams to and from APs, the current 
data rate, and the network status. Signal quality indicates how clearly the adapter can hear the associated 
AP.

Figure B-12    Mobile Companion - Signal Tab

Missed Beacons The amount of beacons (uniform system packets broadcast by the AP to keep the 
network synchronized) missed by the MK1250. The fewer the missed beacons the better 
the signal. If the LED to the right of the graph is green the AP association is not 
jeopardized by an excess of missed AP beacons. If the LED is red, consider associating 
with a different AP to reduce the amount of missed beacons and improve the signal.

Transmit Retries The number of data packets retransmitted by the MK1250. The fewer transmit retries the 
stronger the signal. If the LED to the right of the graph is green the AP association is not 
jeopardized. If the LED is red, consider associating with a different AP to reduce the 
amount of transmit retries and improve the signal.

Signal The Relative Signal Strength Indicator (RSSI) of the signal transmitted between the AP 
and MK1250. If the LED to the right of the graph is green the AP association is not 
jeopardized. If the LED is red, an association with a different AP could be warranted to 
improve the signal.

NOTE The button combination ABCD is mapped to the Signal Strength function (0xC6) and launches the Signal 
tab. See Table 7-5 on page 7-8.
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2. Tap the Info tab to view the MK1250 current software and driver revision data and the operating parameters of 
the current profile.

Figure B-13    Mobile Companion - Info Tab

3. Tap the IP Status tab to view the MK1250 network address information. Unlike the IP Config tab in Finding 
WLANs, the IP Status tab is view-only with no user-configurable data fields.

Figure B-14    Mobile Companion - IP Status Tab

Version Information The MK1250's software, driver, firmware and hardware versions, and country 
information. This data is consistent for the MK1250 regardless of the current profile.

Current Status The MK1250 current Profile Name, ESSID, and Encryption mode. MK1250 
performance is displayed using a verbal indicator of signal strength. MK1250 
operating information differs depending on the current profile.
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Tap Renew to refresh the information displayed on the IP Status tab.

4. Tap the Ping tab to send and receive ICMP ping packets across the network to the specified IP address.

Figure B-15    Mobile Companion - Ping Tab

• Select or enter a target device IP address from the IP drop-down list.

• Select the size of the packet transmission from the Size drop-down list.

• Tap Start Test to begin the ping test.

• Tap Stop Test to terminate the ping test.

• The average mega-bits per second, signal strength, data rate currently in use, test statistics, and 
round trip (RT) times appear for each test. The associated AP MAC address also appears. The signal 
strength level and the data transmission rate appear in real-time bar graphs.

IP Type If DHCP was selected from the IP Config tab, leased IP address and network address 
data appears. If Static was selected, the values entered in the IP Config tab on page B-12 
appear.

IP Address Each node on the IP network must be assigned a unique IP address. Enter the IP Address 
in dotted-decimal notation, for example, 192.168.7.27.

Subnet Mask All network adapters on a TCP/IP network require a Subnet Mask. See the network 
administrator for the appropriate mask for the network. 

Gateway The Gateway forwards IP packets to and from a remote destination.

DNS The Domain Name System (DNS) is a distributed Internet directory service. DNS 
translates domain names and IP addresses, and controls Internet e-mail delivery. Most 
Internet service requires DNS. For example, if DNS is not configured, Web sites cannot be 
located or e-mail delivery fails. 

WINS WINS is a Microsoft Net BIOS name server. WINS eliminates the broadcasts needed to 
resolve computer names to IP addresses by providing a cache or database of 
translations. 

MAC Address An IEEE 48-bit address factory-assigned to the MK1250 to uniquely identify the adapter at 
the physical layer. 

Host Name The name of the MK1250.
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5. Select the APs tab (Infrastructure operating mode only) to view APs with the same ESSID as the MK1250 
profile.

Figure B-16    Mobile Companion - APs Tab

The associated AP displays a radio wave radiating from its antenna to indicate its associated status. Tapping 
on the icon displays a menu with Set Mandatory and Set Roaming options.

• Select the Set Mandatory item to prohibit the MK1250 from associating with a different AP. The letter M 
displays on top of the icon.

• Select Set Roaming to allow the MK1250 to roam to any AP with a better signal. These settings are 
temporary and never saved to the registry.

Tap Refresh to update the list of APs with the same ESSID. 

Options
Changes made to Options are not persisted across cold boot cycles. 
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Appendix C  Rapid Deployment Client
Introduction
The Rapid Deployment (RD) Client facilitates software downloads to a device from a Mobility Services Platform 
(MSP) Console’s FTP server.

The MK1200 ships from the factory with RD Client version 1.6. You can upgrade this client over a network.

When software packages are transferred to the FTP server, the MK1200 on the wireless network can download 
them to the device. The location of software packages are encoded in RD bar codes. When the MK1200 scans an 
RD programming bar code(s), the software package(s) is downloaded from the FTP server to the MK1200. Multiple 
MK1200s can scan a single RD bar code.

NOTE For information about the MSP Console, MSP Lite/MSP Enterprise servers, and creating RD bar codes, 
refer to the MSP User Guide.
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Rapid Deployment Window
The Rapid Deployment window displays bar code scan status and provides features for resetting and exiting 
the application. To launch the RD application on the MK1200, tap Start > Programs > Rapid Deployment Client.

Figure C-1    Rapid Deployment Window

Table C-1    Rapid Deployment Window

Text Box/Button Description

Please scan all of the bar codes... This text box displays the status of a scanned bar code.
Waiting - indicates the MK1200 is ready to scan a bar code.
OK - indicates the MK1200 successfully scanned a bar code.
If there are no bar codes left to scan, the Rapid Deployment 
Configuring window displays (see Figure C-3).

Bar codes left to scan... This text box displays a list of any remaining bar codes to scan (1D bar 
codes only). When all required bar codes are scanned successfully, the 
Rapid Deployment Configuring window displays (see Figure C-3).

About Tap About to display the Rapid Deployment Client Info window.

Reset Tap Reset to remove any previously scanned data. 

Exit Tap Exit to close the application. A confirmation window displays:

Note: Closing the application prior to scanning all required bar codes 
discards any scanned data collected up to that point.
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Scanning RD Bar Codes
When the MK1200 scans and successfully decodes a single or multiple RD bar codes, the data encoded in the bar 
code can:

• Reset the MK1200’s connection profile. A connection profile is a set of Mobile Companion parameters that 
the MK1200 uses to access the wireless network.

• Initiate downloads of one or more software packages from an FTP server to the MK1200.

To scan an RD bar code:

1. Obtain the appropriate RD bar code(s) from the MSP administrator.

2. Launch the MK1200’s scan engine by tapping Start > Programs > System menu.

3. With the System menu open, from the toolbar, click on Configuration > Turn Scanner On. Leave the System 
menu open while using RD Client or the scan engine turns off.

4. Launch the RD application on the MK1200 by tapping Start > Programs > Rapid Deployment Client. The Rapid 
Deployment window displays.

Figure C-2    Rapid Deployment Window

5. Scan the appropriate bar code(s) to complete the configuration and/or download. For information about 
scanning with the MK1200, see Bar Code Scanning on page 1-8.

a. A PDF417 bar code (2D bar code) can contain all download data in a single bar code. In this case, only 
one bar code may be required to scan.

b. Multi-part linear bar codes (1D bar codes) can require scanning several bar codes. Scan bar codes in any 
order. The text box under Bar codes left to scan... shows the remaining bar codes to scan (see Figure C-2).

NOTE Currently, RD only recognizes AirBeam version 2.16 software packages.

Ready to Scan
No Bar Codes Left to Scan

Ready to Scan
Bar Codes 1, 10, 11, 12 Left to Scan
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6. After scanning all appropriate bar codes, the MK1200 connects to the server and the Rapid Deployment 
Configuring window displays while network settings are configured.

Figure C-3    Rapid Deployment Window - Configuring

7. When configuration is complete:

a. A new Mobile Companion profile is created on the MK1200 from the data encoded in the bar code(s) 
scanned. See Appendix B, RF Network Configuration for more information about wireless profiles.

b. The designated package(s) are downloaded from the FTP server.

NOTE If the MK1200 cannot connect to the server, it retries until you cancel (exit) the application. If failure to 
connect to the server persists, see the MSP administrator.



Appendix D  Web Kiosk Software Suite Bar 
Codes
Introduction
Use these sample bar codes with the Web Kiosk Software Suite.

Wide Screen TV

0 11048 83112 9
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DVD Player

White Correction Fluid

0 11096 38390 8

0 70330 50367 0
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Glue Stick

Transparent Tape

0 71709 00166 7

0 51131 77138 3
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Standard Staples

Tylenol

0 74711 35440 0

3 00450 44909 2
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Rolaids

Color Printer - Ink Cartridge

3 12546 65021 3

7 34646 89800 3
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Employee Badge
John Ryan

(Code 128)

Loyalty Card
Clark Kent

(Code 39)

56842

Employee Badge

John Ryan

4125279101

Loyalty Card

Clark Kent



Appendix E  Terminal Configuration Manager
Introduction
Use the Terminal Configuration Manager (TCM) to specify a group of files to use when creating a partition and to 
load partitions from a host computer into the MK1200 flash memory over a serial connection using the device’s 
Initial Program Loader (IPL). 

TCM creates a script that contains information (commands to copy files) for building the image. TCM works with 
Explorer-type windows to view both the contents of the partitions and the source files directory structure, and 
performs functions including opening multiple scripts, dragging/dropping items from a drive/directory to the script, 
and renaming and deleting files in the script. When building the image, TCM adds all the files and directories 
referenced in the script to the image.

The Symbol MK1200 DCP (Device Configuration Package) includes TCM, standard script, and flash partition 
source files to use as a base for creating new scripts. These scripts are located in:

C:\Program Files\Symbol Device Configuration Packages\MK1100cXX\vX.X\ TCMScripts

Download the installation files for TCM from http://devzone.symbol.com.

To build a hex image using TCM:

• Start TCM.

• Create or modify a script.

• Build the hex image.

• Send the hex image.

NOTE Before creating a script to build a hex image, identify the files required (system files, drivers, applications, 
etc.) and their source directories to simplify the script building process.
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Starting Terminal Configuration Manager
To start TCM, select Start > Programs > Symbol Device Configuration Packages > MK1100cXX vX.X. The 
following screen displays two directory windows: Script1 and File Explorer. 

Figure E-1    Terminal Configuration Manager
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Table E-1 lists the components of the TCM start-up screen.

Table E-1    TCM Start-Up Screen Components

Component Description

Script Window Associated with a script file containing the information to create a Flash Disk image. This 
window is the target window, or the primary TCM window to create a script or change a 
script file contents by copying, deleting, and renaming files and directories. More than one 
script window can open at a time. 
The Script Window consists of the Directory Tree Pane on the left and the Directory 
Contents Pane on the right. The Directory Contents Pane lists subordinate directories and 
files of each partition. 

File Explorer A read-only source window for files and/or directories to include in the script.

Tool Bar Contains the tools below for taking action on a script. 

Create a new script file. Check script for existing files.

Open a script file. Select the hex image to load.

Save a script file. Tile windows.

View script properties. Build and send the hex image to 
the device.

Build a script. Preferences.

View large icons. About TCM.

View small icons. View list.
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Defining Script Properties
Before a script is created, define script properties, including the type of device, flash type, number of disks 
being created, and the memory configuration of each disk partition.

To define script properties:

1. With TCM open, click on the Script Window to make it the active window.

2. From the Script menu, select the Properties option
OR 

Click on from the tool bar. The Script Properties window displays.

3. From the Terminal drop-down menu, select MK1200.

4. From the Disks drop-down menu, select the number of disk partitions to create. 

5. If selecting two or more partitions under the Disk drop-down menu, change the memory configuration of 
the two partitions if desired. Click on the up or down arrow for either partition to set the memory 
configuration to the desired value. As the one partition size is changed, the other partition changes 
accordingly.

6. For each disk partition, set the Read/Write access option.

7. The Script File Path displays the path of the selected script file.

8. Select a Cushion percentage from the Cushion drop-down menu to specify the percent of flash reserved 
for cushion. Choosing a higher number reduces disk storage space, but also increases write performance 
on fragmented disks or disks becoming full. To speed the writing process, select as high a number as 
storage needs permit (up to 25%).

9. Click OK to complete the settings.

NOTE The options available under the disks drop-down menu changes depending on the flash type. Some flash 
types only have one option for the number of disk partitions, others have two options.
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Creating the Script for the Hex Image
On start-up, TCM displays the screen shown in Figure E-1 on page E-2, with the Script1 window and File Explorer 
window pointing to the following directory: 

C:\Program Files\Symbol Device Configuration Packages\MK1100cXX\vX.X\TCMScripts 

The Script1 window directory pane displays three partitions: Platform, Application, and Data. Files can be added to 
each of the partitions. TCM functionality includes:

• Creating a new script file or open an existing script

• Dragging and dropping existing files and directories to that script

• Setting the script parameters

• Saving the script

• Reviewing and modifying the script.

Open a New or Existing Script

Scripts are created in the Script Window. To open a new script: 

• Choose New from the File menu, OR 

• Click on from the tool bar.

To open an existing script (e.g., a standard script provided in the DCP):

• Choose Open from the File menu and select the script file name, OR 

• Click on  from the toolbar and select the script file name, OR

• Double-click on an existing script in the Script Browser window.

Copying Components to the Script

To copy files or directories to the script being generated:

1. Click on the File Explorer Window to make it the active window.

2. Click on the source directory in the Directory Tree Pane. TCM displays the directory contents in the Contents 
Pane.

3. Click on the file(s) and/or directory in File Explorer.

NOTE Saving changes made to an existing script overwrites the original script. To use an original or 
Symbol-supplied standard script as a base and save the changes in a new script, use Save As instead of 
Save after making the changes and save to a different file name.

NOTE Optionally, use the standard Windows® Shift+Left-tap and Control+Left-tap features to select multiple 
files and directories.
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4. Drag and drop the selected file(s) and/or directory from File Explorer to the target directory in the Script 
Window,
OR 
Click on the target directory and select the File Explorer Copy icon from the toolbar.

Saving the Script

To save changes to a new script:

1. From the File menu, choose Save As,
OR 

On the toolbar, click .

2. Enter the path and filename. TCM appends a .TCM extension to the script.

3. Click OK. 

To save changes to an existing script:

• From the File menu, choose Save, OR

• On the toolbar, click .

To use an original or Symbol-supplied standard script as a base and save the changes in a new script, use 
Save As instead of Save after making the changes and save to a different file name. 

NOTE TCM by default saves untitled scripts to the directory that the Script Browser is pointing to.

NOTE Saving changes to an existing script overwrites the original script.
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Building the Image
Before building the image, TCM checks the script to verify that all files referenced in the script exist.

To check a script:

1. In the Script Window, select the script.

2. Save the script, if not already saved.

3. From the Script menu, choose Check,
OR 

On the toolbar, choose .

4. TCM verifies that files referenced in the script exist on available drives and lists an error message in the Errors 
found box for any missing files.

5. Click OK to exit.

To build a script:

1. In the Script Window, select the script to be built.

2. From the Script menu, select Build,
OR 

On the toolbar, choose . The Configure Build window displays.

3. Select the item to build. If an application is selected to build, specify the application.

4. Select Compression for the hex image, which reduces the size of most hex images to speed downloading. 
Click OK.

5. TCM performs a check. If the script has no errors, TCM builds the partition which can be transferred using IPL 
to the MK1200 as a hex file. 

If the build fails, TCM displays a message indicating which file(s) are missing. 

If the amount of flash required by the script exceeds the image size, a TCM error results. To correct this, reduce the 
number of files in the partition. See Defining Script Properties on page E-4 for more information on setting the 
image size.

NOTE Performing a check is more important for existing scripts to ensure that files referenced in the script are 
still in the designated locations.
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Sending the Hex Image
After building the hex file, download it to the device using IPL. See IPL Menu Navigation on page F-3 for 
detailed procedures.

Saving the Script

Save the script if changes were made since last saving it.

TCM Error Messages

Select the Execute button to validate the cells in the partition table. Cells highlighted in red contain an error. 
Partition loading is disabled until all errors are corrected. Following are errors that TCM can encounter and 
possible solutions.

Table E-2    TCM Error Messages 

Error Description/Solution

Failed to build images: flash file 
system DLL not loaded!

TCM could not load the DLL required to build images for the target flash 
file system. Reinstall TCM or recover the DLL.

Failure finding directory xxx Build process failed because directory xxx was not found. 

Failure creating volume Build process failed because a certain disk volume could not be 
created. 

Failure adding system file to image Build process failed because TCM failed to add a certain system file to 
the disk image. 

INVALID PATH The path for the image file to build is not valid.

Nothing Selected To Build In the Config Build window, no item is selected to build.

Disk Full TCM failed to create Hex image file at the selected path. Check 
available disk space.

Target Disk Full Build process failed because TCM failed to add file to the image of a 
disk volume. Remove some files or increase the disk size.

Hex file is READ ONLY The Hex image file to be created exists and is read-only. Delete the 
existing file or change its attribute.

Error opening the file xxx with write 
access

TCM could not open file xxx with write access. Check if file is in use.

Failure creating binary file TCM failed to open/create an intermediate binary file.

Hex File To load is missing or 
invalid

In Load Terminal window, the file selected to load has invalid status.

Could not locate device name in 
TCM.ini file

While loading the Script Properties window, TCM could not find the 
TCM.ini section corresponding to the device type specified by the 
current opening script. Either TCM.ini or the script file is invalid.
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Creating a Splash Screen
The Splash screen appears briefly when the device cold boots. To generate a custom Splash screen, use a bitmap 
editor, such as Paintbrush. 

Creating a Splash Screen on Color Terminals

1. Create an 8 or 16-bit color bitmap with dimensions of BX x BY where:

• BX is less than or equal to 640 pixels

• BY is less than or equal to 480 pixels

2. Choose Build, then check at least the Splash screen item. Build other partition images if desired. Click OK.

3. Select the source file for the splash screen (the bitmap created above) on the File Open window.

4. Specify the output filename for the splash screen on the Save As file window. 
TCM creates the splash screen HEX file and any other HEX files requested.

Incorrect disk sizes in TCM.ini file The total disk size specified in the script does not match the total disk 
size defined in the corresponding TCM.ini section. Check if the script is 
corrupt or the TCM.ini changed after the script was created. 

INVALID DIRECTORY In Script Properties window, the selected System File Path is not a valid 
directory.

One of the disk sizes is one sector 
in size

In Script Properties window, one of the disks is too small (one sector in 
size). This can cause problems when building images, especially when 
cushion is enabled. Increase the disk size.

INVALID VOLUME NAME In Script Properties window, one of the volume labels is not valid. 

Corrupt TCM.INI file! (Invalid value 
of VolumeDivisor)

The VolumeDivisor entry is missing or invalid in the TCM.ini. Reinstall 
TCM or recover TCM.ini.

Invalid version of TCM script file The TCM script was not created by this version of TCM.

Corrupt or missing TCM.ini file TCM could not find TCM.ini file.

FAILED CONNECTION TO COM 
PORT (Could not get status)

While downloading images to device, TCM failed to connect to the 
selected COM port. Ensure the COM port is free and properly 
configured.

FAILED CONNECTION TO 
TERMINAL (Terminal Not 
Connected Properly/Terminal Not 
Ready to Receive)

While downloading images, TCM failed to connect to the device. Ensure 
the correct flow control protocol is set, and the device is properly 
connected and in a listening state.

Table E-2    TCM Error Messages  (Continued)

Error Description/Solution

NOTE The MK1200 ignores images larger than 640 x 480, in either dimension, or that are not 8 or 16-bit color. 
Images smaller than 640 x 480 are centered in the display.
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Appendix F  OS Upgrade Procedures
Introduction
MK1200 operating system upgrade procedures enable software updates and/or feature enhancements. This 
appendix provides upgrading instructions using a CF/PC card and the Initial Program Loader (IPL).

To upgrade the MK1200 operating system:

1. Review Upgrade Requirements on page F-2.

2. Perform Monitor Upgrade on page F-4.

3. Perform Partition Table Upgrade on page F-6.

4. Perfrom Command File Upgrade on page F-7.



F - 2 MK1200 MicroKiosk for CE .NET 4.2 Product Reference Guide
Upgrade Requirements

Hardware Requirements

• CF or PC storage card with the appropriate upgrade files.

• ESD mat and equipment required to properly ground the operator. 

Software Requirements

The files required to upgrade the MK12xx include:

• Command file for the MK1200:

• PC_MK1200_XXX.mcf

• Command file for the MK1250:

• PC_MK1250_XXX.mcf

• The following partition files:

• Monitor file: 11xxc42Monxxxx.bgz

• OS file: 12xxc42OSxxxxxx.bgz

• Platform file: 11xxc42Plat32Mxxx.hex

• Partition Table file: 11xxc42Pt32Mxxx.hex

• Application Partition file: 11xxc42App32Mxxx.hex

• Splash Screen file: 12xxc42cSplxxx.hex

Procedural Requirements

• Monitor Upgrade on page F-4

• Partition Table Upgrade on page F-6

• Command File Upgrade on page F-7

• Calibrating the Screen on page F-10 (optional).

NOTE Symbol recommends using a freshly formatted CF/PC card for storing the upgrade files. Format the 
CF/PC card using the FAT file system in the host computer, then copy the upgrade files to the CF/PC 
card. The upgrade may fail if the CF/PC card contains a corrupt file system.
The MK1200 is equipped with a PCMCIA slot only. This slot is used to connect the Spectrum24 radio card 
in MK1200 devices with a wireless facility. You must remove this card before upgrading. 
Use a CF card with a CF/PC card adapter.

CAUTION When removing an access cover, follow proper ESD precautions to avoid damaging sensitive 
components. These include, but are not limited to, working on an ESD mat and ensuring that the 
operator is properly grounded. Failure to apply proper ESD precautions can damage the MK1200 and 
void the warranty.

NOTE The MK Series includes two different platforms and operating files based on operating systems for the 
MK1200 (wired) versus the MK1250 (RF).
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IPL Menu Navigation
IPL is a menu-based method of downloading partitions to non-volatile storage (flash) on the MK1200. You can 
download the following partitions:

• OS Partition

• Platform Partition

• Application Partition

• Partition Table

• Splash Screen

• Monitor.

Use the MK1200 buttons to navigate IPL menus and make selections. The buttons and their functions are shown in 
Figure F-1.

Figure F-1    Button Functions

OS Upgrade
To upgrade the MK1200 operating system using a CF/PC card, see the following sections to perform monitor, 
partition table, and command file upgrades.

To begin the operating system upgrade:

1. Power off the MK1200.

2. Remove the PCMCIA access cover (see Figure 1-1 on page 1-3).

3. Insert the PC card into the PCMCIA card slot.

A Button
Scroll Down

C Button
Select Menu Option

B Button
Scroll Up
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Monitor Upgrade

To perform a monitor upgrade:

1. Enter IPL mode by powering on the MK1200 while holding the A button. The Initial Program Loader main 
menu displays.

Figure F-2    IPL Main Menu

2. From the Initial Program Loader main menu, press the A or B button to highlight Monitor.

3. Press the C button to select Monitor. The Select Transport menu displays.

Figure F-3    Select Transport Menu

4. Press the A or B button to select the file media source and highlight PC Card.

NOTE A failure during the monitor upgrade can cause the MK1200 to become inoperable.

Initial Program Loader
Timer off

Platform
Application
Windows CE
Monitor
Splash Screen
Partition Table
Command File
System Reset
Auto Select

Select Transport
Timer off

PC Card 
Scanner/Printer - Serial
Previous 
Top
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5. Press the C button to select PC Card. The Select File Name menu displays.

Figure F-4    Select File Name Menu

6. Press the A or B button to highlight the monitor upgrade file, 11xxc42Monxxxx.bgz.

7. Press the C button to select 11xxc42Monxxxx.bgz. The Download File? menu displays.

Figure F-5    Download File? Menu

8. Press the A or B button to highlight Download.

9. Press the C button to initiate the monitor file download.

When the monitor upgrade begins, the following message displays.

Figure F-6    Monitor Upgrade, Downloading Message

10. When the new monitor is successfully loaded, the MK1200 prompts to press a button, then reboots.

11. Continue the OS upgrade by holding the A button during the reboot to display the IPL main menu.

Select File Name
Timer off

11xxc42Monxxxx.bgz
12xxc42OSxxxxxx.bgz
11xxc42Plat32Mxxx.hex
11xxc42Pt32Mxxx.hex
11xxc42App32Mxxx.hex
12xxc42cSplxxx.hex
Previous
Top

Download File?
Timer off

Download
Cancel
Show Parms
Previous
Top

Downloading:
Monitor

Via PC Card 11xxc42Monxxxx.bgz

############# 100%Your terminal needs to be rebooted.

Please press button A to reboot.

NOTE If an error occurs, remove power from the MK1200 and restore power to reboot the MK1200. Hold the A 
button during the reboot. The IPL main menu displays. Repeat the Monitor upgrade procedure.



F - 6 MK1200 MicroKiosk for CE .NET 4.2 Product Reference Guide
12. Proceed to Partition Table Upgrade.

Partition Table Upgrade

To perform a partition table upgrade:

1. From the IPL main menu, press the A or B button to highlight Partition Table.

2. Press the C button to select Partition Table. The Select Transport menu displays.

Figure F-7    Select Transport Menu

3. Select the file media source by pressing the A or B button to highlight PC Card.

4. Press the C button to select PC Card. The Select File Name menu displays.

Figure F-8    Select File Name Menu

5. Press the A or B button to highlight the partition table upgrade file, 11xxc42Pt32Mxxx.hex.

6. Press the C button to select 11xxc42Pt32Mxxx.hex. The Download File? menu displays.

Figure F-9    Download File? Menu

7. Press the A or B button to highlight Download.

Select Transport
Timer off

PC Card 
Scanner/Printer - Serial
Previous 
Top

Select File Name
Timer off

11xxc42Monxxxx.bgz
12xxc42OSxxxxxx.bgz
11xxc42Plat32Mxxx.hex
11xxc42Pt32Mxxx.hex
11xxc42App32Mxxx.hex
12xxc42cSplxxx.hex
Previous
Top

Download File?
Timer off

Download
Cancel
Show Parms
Previous
Top
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8. Press the C button to select Download and initiate the partition table upgrade. When the partition table 
upgrade begins, the following Downloading message displays.

Figure F-10    Partition Table Upgrade, Downloading Message

9. When the message Please press Enter to continue displays, press the C button to continue the OS upgrade and 
proceed to Command File Upgrade.

Command File Upgrade

To perform a command file upgrade:

1. From the IPL main menu, press the A or B button to highlight Command File.

2. Press the C button to select Command File. The Select Transport menu displays.

Figure F-11    Select Transport Menu

3. Select the file media source by pressing the A or B button to highlight PC Card.

4. Press the C button to select PC Card. The Select File Name menu displays.

Figure F-12    Select File Name Menu

Downloading: 
Partition Table

Via PC Card 11xxc42Pt32Mxxx.hex

Result was Success!

Please press Enter to continue

NOTE If an error screen displays, remove power from the MK1200 and restore power to reboot the device. Hold 
the A button during the reboot. The IPL main menu displays. Repeat the Partition Table upgrade 
procedure.

Select Transport
Timer off

PC Card 
Scanner/Printer - Serial
Previous 
Top

Select File Name
Timer off

PC_MK1200_XXX.mcf
PC_MK1250_XXX.mcf
Previous
Top
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5. Select the command file by pressing the A or B button to highlight the appropriate file to download.

6. Press the C button to select the file. The Download File? menu displays.

Figure F-13    Download File? Menu

7. Press the A or B button to highlight Download.

8. Press the C button to select Download and initiate the command file upgrade.

NOTE If the mon> error message displays, remove power from the MK1200 and restore power to reboot the 
device. Hold the A button during the reboot. The IPL main menu displays. Repeat the Command File 
upgrade procedure.

Download File?
Timer off

Download
Cancel
Show Parms
Previous
Top
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9. When the command file upgrade begins, the following message displays.

Figure F-14    Command File Upgrade, Downloading Message 

10. Press and release button A to perform a warm boot. When the desktop displays, remove power from the 
MK1200. Remove PC card and replace the PCMCIA access covers (see Figure 1-2 on page 1-4).

Downloading: 
Command File

Via PC Card PC_MK1200_XXX.mcf
Obtaining script file from given transport . . . 
################### 100%
Begin script execution
-----------------------------------------------------------
Partition Table
################### 100%
Download complete
in 0.656 seconds
(12487 bytes/second)
----------------------------------------------------------------
Splash Screen
################### 100%
Download complete
in 3.257 seconds
(94131 bytes/second)
----------------------------------------------------------------
Platform
################### 100%
Download complete
in 14.337 seconds
(365000 bytes/second)
----------------------------------------------------------------
Application
################### 100%
Download complete
in 39.38 seconds
(718000 bytes/second)
----------------------------------------------------------------
################### 100%Your terminal needs to be rebooted.
Please press button A to reboot.

NOTE If an error screen displays, remove power from the MK1200 and restore power to reboot the device. Hold 
the A button during the reboot. The IPL main menu displays. Repeat the Command File upgrade 
procedure.
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Calibrating the Screen 

Use the Calibration screen to align the touch screen:

1. Remove and restore power to the MK1200 to reboot.

2. From the Windows CE Desktop window, press buttons A, C, and D simultaneously to display the Calibration 
screen. 

Figure F-15    Calibration Screen

3. Carefully press and briefly hold the stylus tip on the center of the Calibration screen target. Repeat the 
procedure as the target moves and stops at different locations on the screen.

4. The Confirm Calibration Resave screen displays. Press the left two buttons (A and B) to accept the new 
settings or press the right two buttons (C and D) to retain the existing calibration settings. 

Figure F-16    Save Settings, Calibration Screen

NOTE To access the Calibration screen from the Windows CE Control Panel, tap Start > Settings > Control 
Panel. Double-tap the Stylus icon, tap the Calibration tab, and tap the Recalibrate button. The 
Calibration screen displays.
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Update Corona Scanner Engine Firmware

Unzip ScanflashVX.X_CE4.x.zip file and copy its contents to the root "\" directory on the MK1200 device. The zip 
file contains:

• Corona scanner firmware binary image file (*.FDL)

• ScanFlash.exe

• ScanFlash.bat.

• Execute the ScanFlash.bat file to update the Corona Scanner Engine firmware. 

NOTE Do not disrupt power to the MK1200 while updating scanner engine firmware. Doing so can damage the 
scanner engine.
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Appendix G  Troubleshooting
Introduction
The MK1200 troubleshooting is provided in three sections:

• Troubleshooting on page G-3 offers troubleshooting scenarios for the MK1200.

• OS Upgrade Troubleshooting on page G-6 provides OS upgrade troubleshooting scenarios for the MK1200.

• MK1200 Version Information on page G-7 describes how to identify the MK1200 version. 

Troubleshooting Notes

When configuring the MK1200 System Menu screens, save and reboot the MK1200 to apply the changes. To save 
some Control Panel changes across cold boot cycles, on the MK1200, select Start > Programs > Save Configuration 
(see Control Panel Configuration Parameters on page 3-20).
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Troubleshooting

• MK1200 does not turn on on page G-3

• MK1200 appears to lock up upon bootup on page G-3

• MK1200 does not respond to polls from the host computer on page G-3

• MK1200 does not send data to host computer on page G-3

• Web Kiosk Software Suite does not work after making changes to the MK1200 on page G-3

• Scanner does not recognize configuration bar codes on page G-4

• Parameter changes made using System Menu were not retained after the MK1200 was re-booted on 
page G-4

• Reg file values are not copied into the Registry at boot time on page G-4

• The screen does not respond to pen input on page G-4

• AirBeam fails to start; abstart.exe crashed at boot up on page G-4

• Need to determine a device MAC address on page G-4

• The wireless MK1200 does not retain its WEP Key encryption after a reboot on page G-4

• After configuring the wireless MK1200 using the mkconfig.reg file, Mobile Companion does not 
automatically launch on page G-4

• The Mobile Companion icon does not appear in the task tray on page G-5

• When downloading files to the MK1200 from a .zip file using ActiveSync, a message displays indicating 
there is not enough free disk space to copy the application on page G-5

• When downloading a large file over ethernet, IE issues an insufficient memory message on page G-5

• When upgrading using a CF/PC card, the MK1200 cannot find files on the card on page G-5

• Flash file system is corrupt on page G-5.

• Copying large amount of files from CF or PC card to the application folder fails with error "Access is 
denied" on page G-5

• After rebooting the MK1200, you can't navigate using the buttons on page G-5
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Table G-1    Troubleshooting

Problem Possible Causes Possible Solutions

MK1200 does not turn on No power to the 
MK1200.

- Power through AC outlet
- Connect the Symbol approved power 

supply to an AC power source and to 
the MK1200 power connector. See 
Figure 1-3 on page 1-5.

- Power through power-over-Ethernet
- Connect 8-wire Ethernet cable to 

MK1200 LAN port.
- Connect other end of Ethernet cable to 

Bias-T Power-Over-Ethernet (POE).
- Connect Bias-T POE power supply to 

an AC outlet.
- Perform continuity check on the 

Ethernet cable.

MK1200 appears to lock up upon 
bootup

A utility with no user 
interface was specified 
as the first user 
application, or user 
application failed to run. 

Either specify no user application, or a 
UI-based application as the first user 
application. If no user application is specified, 
Explorer.exe is used. 
Note: this is a substitution of Explorer.exe as 
the user application, not protected mode.

MK1200 does not respond to polls 
from the host computer

No communication 
between the host and 
MK1200.

Check cables to the MK1200. Ensure the 
MK1200 address is the address the host is 
polling.

Check communication parameters.

Open a command window using 
Start > Programs > Command and type 
ipconfig to list the status of all radio and 
ethernet interfaces.

MK1200 does not send data to host 
computer

MK1200 is not 
programmed to work with 
the host. 

Check setup communication parameters.

MK1200 is not connected 
to the host.

Check cables to host computer.

Web Kiosk Software Suite does not 
work after making changes to the 
MK1200

Web Kiosk Software 
Suite parameter settings 
inconsistent with latest 
program changes and/or 
corrupt files. 

Locate and delete the files associated with 
the Web Kiosk Software Suite (in the My 
Computer/Application folder). Then reload the 
files associated with the Web Kiosk Software 
Suite. See Installing the Web Kiosk Software 
Suite on page 6-3. 
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Scanner does not recognize 
configuration bar codes

The scan driver does not 
support parameter bar 
code scanning.

Configure the scanner using scanning 
C API or Active X scanner object.

Parameter changes made using 
System Menu were not retained after 
the MK1200 was re-booted

Parameter changes were 
not saved.

See Setting Defaults Using the System 
Menu on page 3-5.

Reg file values are not copied into the 
Registry at boot time

More than one .reg file 
and duplicate registry 
entries are present. 

Review all .reg files in /Application and 
/Platform and ensure they have no conflicts. 

The screen does not respond to pen 
input

The screen is not 
properly calibrated, or is 
off center.

See Stylus Settings/Touch Screen 
Calibration on page 3-23

AirBeam fails to start;
abstart.exe crashed at boot up

System Menu or RDM is 
used to enable DHCP 
receive options.

Do not use the System Menu or RDM to 
enable DHCP receive options 1, 3, 6, 15, 44, 
46, 47, 66, and 67. They are already enabled 
in dhcpoptions.reg as a part of the AirBeam 
package. Refer to AirBeam documentation for 
this configuration.

Need to determine a device MAC 
address

N/A Open Start > Programs > CommandPrompt. 
Type ipconfig /all
to display the MAC address next to ‘address’.

The wireless MK1200 does not retain 
its WEP Key encryption after a reboot

Encryption keys not 
saved in spectrum24.reg 
or Aegis.reg file in the 
Application partition.

Set encryption keys using Mobile Companion, 
then use the Save Spectrum24 Settings or 
Save Aegis Settings tool to save them. 
Check communication parameter settings.
Open a command window using Start > 
Programs > Command and type ipconfig to 
list the status of all radio and ethernet 
interfaces.

After configuring the wireless MK1200 
using the mkconfig.reg file, Mobile 
Companion does not automatically 
launch

Incorrect Profile Name in 
the Mobile Companion 
Mode tab.

Assign the profile name “Default” in the Mode 
tab. This field is case-sensitive - enter this as 
a capital “D” and lower case “efault”. 
Apply all settings desired, including 
encryption keys, to this profile. 
Save the configuration.

Table G-1    Troubleshooting (Continued)

Problem Possible Causes Possible Solutions
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If problems still occur, see MK1200 Version Information on page G-7 for system information before calling for 
service help.

The Mobile Companion icon does not 
appear in the task tray

Poor RF card connection 
or bad RF card.

Remove the PCMCIA card cover (see 
Installing/Removing the RF Card on page 
2-16). Press the card ejector button to 
release the card, then press the card back 
into its connector to secure it in place.
Reboot the MK1200. If the Mobile Companion 
icon still does not appear in the task tray, 
replace the RF card.

The radio software is not 
present in the \platform 
folder.

Verify presence of radio software or re-install 
\Platform partition software.

When downloading files to the 
MK1200 from a .zip file using 
ActiveSync, a message displays 
indicating there is not enough free 
disk space to copy the application

Files cannot download 
directly from a .zip file. 

Extract/unzip the files to the host computer, 
then transfer the unzipped files to the 
MK1200 using ActiveSync.

When downloading a large file over 
ethernet, IE issues an insufficient 
memory message

For some file types, IE 
requires free RAM 
equivalent to twice the 
file's size.

This is an IE limitation.

When upgrading using a CF/PC card, 
the MK1200 cannot find files on the 
card

The CF/PC card is not 
formatted properly for the 
MK1200.

Format the CF/PC card as FAT16.

Flash file system is corrupt Reset or power loss 
during write to file 
system.

Format file system partition using Start > 
Settings > Control Panel > Storage Manager, 
and re-install partition data.

Copying large amount of files from CF 
or PC card to the application folder 
fails with error "Access is denied"

Archive bit of the folder 
properties set.

Clear the archive bit of folder properties.

After rebooting the MK1200, you can't 
navigate using the buttons

In the MK1200, by 
default, the focus is not 
set to desktop after a 
reboot.

Tap the touch pad once.

Table G-1    Troubleshooting (Continued)

Problem Possible Causes Possible Solutions
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OS Upgrade Troubleshooting

• Monitor Upgrade Troubleshooting on page G-6.

• Partition Table Upgrade Troubleshooting on page G-6

• Command File Upgrade Troubleshooting on page G-6 

NOTE If OS upgrading repeatedly fails when using a CF card, use the Fat-16 system to format the CF card 
before saving the upgrade files.

Table G-2    OS Upgrade Troubleshooting

Problem Possible Causes Possible Solutions

Monitor Upgrade Troubleshooting

Downloading Message, error 
screen

Monitor upgrade error. Remove power from the MK1200, and restore 
power to reboot the MK1200. Hold the A button 
during the reboot. The IPL main menu displays. 
Repeat the monitor upgrade procedure.

MK1200 does not boot after 
performing a monitor update

Monitor upgrade failure. Failures during the monitor upgrade often render 
the MK1200 inoperable. If the MK1200 does not 
boot after performing a monitor update, contact the 
Symbol Global Customer Interaction Center.

Partition Table Upgrade Troubleshooting

Downloading Message, error 
screen

Partition table upgrade 
error.

Remove power from the MK1200, and restore 
power to reboot the MK1200. Hold the A button 
during the reboot. The IPL main menu displays. 
Repeat the partition table upgrade procedure.

Data Abort Exception Error Partition table upgrade 
error.

Remove power from the MK1200, and restore 
power to reboot the MK1200. Hold the A button 
during the reboot. The IPL main menu displays. 
Repeat the partition table upgrade procedure.

Command File Upgrade Troubleshooting

The mon> error message 
displays

Command file upgrade 
error.

Remove power from the MK1200, and restore 
power to reboot the MK1200. Hold the A button 
during the reboot. The IPL main menu displays. 
Repeat the partition table upgrade procedure.



Troubleshooting G - 7
MK1200 Version Information

If an MK1200 is configured to launch an application on power-up, bypass this upon booting to access the 
Windows® CE Desktop. See Accessing the Windows® CE Desktop on page 7-7.

1. From the Windows® task bar, select Start > Settings > Control Panel.

2. Select MK1200 identification from the Control Panel window to view the following information:

• Device name

• Description

• OS version

• Monitor version

• Display type

• Memory sizes.

The Remote Device Manager (RDM) provides more detailed version information. See Monitoring MK1200s on a 
Network on page 4-15.
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Appendix H  Setting Scanner Parameters
Introduction
This chapter describes the scanning default parameters for the MK1200, useful when developing applications that 
control the MK1200 scan engine.

Enabling and Disabling Symbologies
See the following for information on where to find programming examples for enabling and disabling symbologies.

C API

Refer to the file scan.c in Samples\ EVC\Standard\Common in the SMDK for C. See the functions 
ScanEnableDecoder and ScanDisableDecoder, which enable and disable a single symbology using the scanner 
C API functions.

ActiveX API (Browser Applications)

Refer to the file scanframe.html in the Web Kiosk Software Suite. See the subroutine SetLaserMode which 
enables and disables symbologies based on whether 2D scanning is enabled.

Default Table
Table H-1 lists the default values for the MK1200 SE 3223 Scan Engine. If desired, change these values within an 
application, and in the case of HTML (browser) applications, set them independently for each web page.

To change the settings in an application, refer to the MK1200 SMDK for C. See the scanparams sample application 
in the SMDK.

For a sample HTML application that includes source code and demonstrates scan engine control, see Chapter 6, 
Web Kiosk Software Suite.
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Table H-1    Scanning Default Table

Parameter Parameter Number Default

Scanning Options

Beeper Tone 91h High Frequency

Laser On Time 88h 5.0 sec

Power Mode 80h Continuous

Trigger Mode 8Ah Host

Scanning Mode 8Dh Smart Raster

Aiming Mode F0h 7Eh Disabled

Raster Height E4h 100

Raster Expansion Rate E5h 11

Time Delay to Low Power 92h 30 sec

Time-out Between Same Symbol 89h 0.9 sec

Time-out Between Different Symbols 90h 0.0 sec

Beep After Good Decode 38h Enable

Transmit “No Decode” Message 5Eh Disable

Parameter Scanning ECh Disable

Linear Code Type Security Levels 4Eh 2

Bi-directional Redundancy 43h Disable

UPC/EAN

UPC-A 01h Enable

UPC-E 02h Enable

UPC-E1 0Ch Disable

EAN-8 04h Enable

EAN-13 03h Enable

Bookland EAN 53h Disable

Decode UPC/EAN Supplementals 10h Ignore

Decode UPC/EAN Supplemental Redundancy 50h 5

Transmit UPC-A Check Digit 28h Enable

Transmit UPC-E Check Digit 29h Disable

Transmit UPC-E1 Check Digit 2Ah Disable



Setting Scanner Parameters H - 3
UPC-A Preamble 22h System Character

UPC-E Preamble 23h No Preamble

UPC-E1 Preamble 24h No Preamble

Convert UPC-E to A 25h Disable

Convert UPC-E1 to A 26h Disable

EAN-8 Zero Extend 27h Disable

UPC/EAN Security Level 4Dh 0

Linear UPC/EAN Decode 44h Enable

UPC Half Block Stitching 4Ah Disable

UPC Composite Mode F0h 58h Never Linked

Code 128

Code 128 08h Enable

UCC/EAN-128 0Eh Enable

ISBT 128 54h Enable

Code 128 Decode Performance 48h Enable

Code 128 Decode Performance Level 49h Level 1

Code 39 

Code 39 00h Enable

Trioptic Code 39 0Dh Disable

Convert Code 39 to Code 32 56h Disable

Code 32 Prefix E7h Disable

Set Length(s) for Code 39 12h
13h

Length within Range: 0-55

Code 39 Check Digit Verification 30h Disable

Transmit Code 39 Check Digit 2Bh Disable

Code 39 Full ASCII Conversion 11h Disable

Code 39 Decode Performance 46h Enable

Code 39 Decode Performance Level 47h Level 1

Table H-1    Scanning Default Table (Continued)

Parameter Parameter Number Default
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Code 93

Code 93 09h Disable

Set Length(s) for Code 93 1Ah
1Bh

Length within Range: 0-55

Interleaved 2 of 5

Interleaved 2 of 5 06h Disable

Set Length(s) for I 2 of 5 16h
17h

1 Discrete Length: 14

I 2 of 5 Check Digit Verification 31h Disable

Transmit I 2 of 5 Check Digit 2Ch Disable

Convert I 2 of 5 to EAN 13 52h Disable

Discrete 2 of 5

Discrete 2 of 5 05h Disable

Set Length(s) for D 2 of 5 14h
15h

1 Discrete Length: 14

Codabar

Codabar 07h Enable

Set Lengths for Codabar 18h
19h

Length within Range: 06-55

CLSI Editing 36h Disable

NOTIS Editing 37h Disable

MSI Plessey

MSI Plessey 0Bh Enable

Set Length(s) for MSI Plessey 1Eh
1Fh

Length Within Range: 04 - 55

MSI Plessey Check Digits 32h One

Transmit MSI Plessey Check Digit 2Eh Disable

MSI Plessey Check Digit Algorithm 33h Mod 11/Mod 10

PDF417/MicroPDF417

PDF417 0fh Enable

MicroPDF417 E3h Enable

Table H-1    Scanning Default Table (Continued)

Parameter Parameter Number Default
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Code 128 Emulation 7Bh Disable

GS1 DataBar (Formerly RSS, Reduced Space Symbology)

GS1 DataBar-14 FOh 52h Enabled

GS1 DataBar Limited FOh 52h Enabled

GS1 DataBar Expanded FOh 52h Enabled

Data Options

Transmit Code ID Character 2Dh None

Prefix/Suffix Values
Prefix 
 Suffix 1
 Suffix 2

69h
68h
6Ah

NULL
CR
LF

Scan Data Transmission Format EBh Data as is

Simple Serial Interface (SSI) Options

Baud Rate 9Ch 38400

Parity 9Eh None

Check Parity 97h Enable

Software Handshaking 9Fh ACK/NAK

Decode Data Packet Format EEh Packeted

Stop Bit Select 9Dh 1

Intercharacter Delay 6Eh 0

Host Serial Response Time-out 9Bh 2 sec

Host Character Time-out EFh 200 msec

Event Reporting 

Decode Event F0h 00h Enable

Boot Up Event F0h 02h Enable

Parameter Event F0h 03h Enable

Macro PDF

Transmit Each Symbol in
Codeword Format

Afh Disable

Transmit Unknown Codewords BAh Disable

Escape Character E9h None

Table H-1    Scanning Default Table (Continued)

Parameter Parameter Number Default
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Set Default Parameters
Scanning the below bar code sets the scan engine to the default settings listed in Table H-1. After scanning this 
bar code, reboot the MK1200 to apply the settings.

ECI

Delete Character Set ECIs E6h Enable

ECI Decoder E8h Enable

Transmit Macro PDF User-Selected Field

Transmit File Name B0h Disable

Transmit Block Count B1h Disable

Transmit Time Stamp B2h Disable

Transmit Sender B3h Disable

Transmit Addressee B4h Disable

Transmit Checksum B6h Disable

Transmit File Size B5h Disable

Transmit Macro PDF Control 
Header

B7h Disable

Last Block Marker B9h Disable

Table H-1    Scanning Default Table (Continued)

Parameter Parameter Number Default



Glossary
ACK/NAK. ACK/NAK is the default software handshaking.

AirBeam Manager. AirBeam Manager is a comprehensive wireless network management system that provides 
essential functions that are required to configure, monitor, upgrade and troubleshoot the 
Spectrum24® wireless network and its components (including networked terminals). Some 
features include event notification, access point configuration, diagnostics, statistical reports, 
auto-discovery, wireless proxy agents and monitoring of access points and mobile devices. 

Aperture. The opening in an optical system defined by a lens or baffle that establishes the field of view.

ANSI Terminal. A display terminal that follows commands in the ANSI standard terminal language. For 
example, it uses escape sequences to control the cursor, clear the screen and set colors. 
Communications programs support the ANSI terminal mode and often default to this terminal 
emulation for dial-up connections to online services.

 ASCII. American Standard Code for Information Interchange. A 7 bit-plus-parity code representing 
128 letters, numerals, punctuation marks and control characters. It is a standard data 
transmission code in the U.S.

Autodiscrimination. The ability of an interface controller to determine the code type of a scanned bar code. After 
this determination is made, the information content is decoded.

Bar. The dark element in a printed bar code symbol.

Bar Code Density. The number of characters represented per unit of measurement 
(e.g., characters per inch).

Bar Height. The dimension of a bar measured perpendicular to the bar width.

Bar Width. Thickness of a bar measured from the edge closest to the symbol start character to the trailing 
edge of the same bar.

Baud Rate. A measure of the data flow or number of signaling events occurring per second. When one bit 
is the standard "event," this is a measure of bits per second (bps). For example, a baud rate 
of 50 means transmission of 50 bits of data per second.

Bit. Binary digit. One bit is the basic unit of binary information. Generally, eight consecutive bits 
compose one byte of data. The pattern of 0 and 1 values within the byte determines its 
meaning.
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Byte. On an addressable boundary, eight adjacent binary digits (0 and 1) combined in a pattern to 
represent a specific character or numeric value. Bits are numbered from the right, 0 through 
7, with bit 0 the low-order bit. One byte in memory is used to store one ASCII character.

BOOTP. A protocol for remote booting of diskless devices. Assigns an IP address to a machine and 
may specify a boot file. The client sends a bootp request as a broadcast to the bootp server 
port (67) and the bootp server responds using the bootp client port (68). The bootp server 
must have a table of all devices, associated MAC addresses and IP addresses. 

CDRH. Center for Devices and Radiological Health. A federal agency responsible for regulating laser 
product safety. This agency specifies various laser operation classes based on power output 
during operation.

CDRH Class 1. This is the lowest power CDRH laser classification. This class is considered intrinsically safe, 
even if all laser output were directed into the eye's pupil. There are no special operating 
procedures for this class.

CDRH Class 2. No additional software mechanisms are needed to conform to this limit. Laser operation in this 
class poses no danger for unintentional direct human exposure.

Character. A pattern of bars and spaces which either directly represents data or indicates a control 
function, such as a number, letter, punctuation mark, or communications control contained in 
a message.

Character Set. Those characters available for encoding in a particular bar code symbology.

Check Digit. A digit used to verify a correct symbol decode. The scanner inserts the decoded data into an 
arithmetic formula and checks that the resulting number matches the encoded check digit. 
Check digits are required for UPC but are optional for other symbologies. Using check digits 
decreases the chance of substitution errors when a symbol is decoded.

Codabar. A discrete self-checking code with a character set consisting of digits 0 to 9 and six additional 
characters: ( - $ : / , +).

Code 128. A high density symbology which allows the controller to encode all 128 ASCII characters 
without adding extra symbol elements.

Code 3 of 9 (Code 39). A versatile and widely used alphanumeric bar code symbology with a set of 43 character 
types, including all uppercase letters, numerals from 0 to 9 and 7 special characters (- . / + % 
$ and space). The code name is derived from the fact that 3 of 9 elements representing a 
character are wide, while the remaining 6 are narrow.

Code 93. An industrial symbology compatible with Code 39 but offering a full character ASCII set and 
a higher coding density than Code 39.

Code Length. Number of data characters in a bar code between the start and stop characters, not including 
those characters.

Continuous Code. A bar code or symbol in which all spaces within the symbol are parts of characters. There are 
no intercharacter gaps in a continuous code. The absence of gaps allows for greater 
information density.

Dead Zone. An area within a scanner's field of view, in which specular reflection may prevent a successful 
decode.

Decode. To recognize a bar code symbology (e.g., UPC/EAN) and then analyze the content of the 
specific bar code scanned.
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Decode Algorithm. A decoding scheme that converts pulse widths into data representation of the letters or 
numbers encoded within a bar code symbol.

Decryption. Decryption is the decoding and unscrambling of received encrypted data. Also see, 
Encryption and Key.

Depth of Field. The range between minimum and maximum distances at which a scanner can read a symbol 
with a certain minimum element width.

DHCP. (Dynamic Host Configuration Protocol) Software that automatically assigns IP addresses to 
client stations logging onto a TCP/IP network. Similar to BOOTP, but also permits the leasing 
of an IP address. It eliminates having to manually assign permanent IP addresses. DHCP 
software typically runs in servers and is also found in network devices such as routers that 
allow multiple users access to the Internet.

DHCP Server. A server in the network or a service within a server that assigns IP addresses.

Discrete Code. A bar code or symbol in which the spaces between characters (intercharacter gaps) are not 
part of the code.

Discrete 2 of 5. A binary bar code symbology representing each character by a group of five bars, two of 
which are wide. The location of wide bars in the group determines which character is 
encoded; spaces are insignificant. Only numeric characters (0 to 9) and START/STOP 
characters may be encoded.

EAN. European Article Number. This European/International version of the UPC provides its own 
coding format and symbology standards. Element dimensions are specified metrically. EAN 
is used primarily in retail.

Element. Generic term for a bar or space.

Encoded Area. Total linear dimension occupied by all characters of a code pattern, including start/stop 
characters and data.

ENQ (RS-232). ENQ software handshaking is also supported for the data sent to the host.

Encryption. Encryption is the scrambling and coding of data, typically using mathematical formulas called 
algorithms, before information is transmitted over any communications link or network. A key 
is the specific code used by the algorithm to encrypt or decrypt the data. Also see, Decryption 
and Key.

ESD. Electro-Static Discharge

ESS_ID. Extended Service Set Identifier, defines the coverage area. Prior to the release of the 802.11 
specification the ESS_ID was called the Net_ID or Network Identifier.

ESS_ID: 32 Alphanumeric characters, (case sensitive).

Flash Memory. Flash memory is responsible for storing the system firmware and is non-volatile. If the system 
power is interrupted the data will not be lost.

Host Computer. A computer that serves other terminals in a network, providing such services as computation, 
database access, supervisory programs and network control.

IEC. International Electrotechnical Commission. This international agency regulates laser safety 
by specifying various laser operation classes based on power output during operation.
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IEC (825) Class 1. This is the lowest power IEC laser classification. Conformity is ensured through a software 
restriction of 120 seconds of laser operation within any 1000 second window and an 
automatic laser shutdown if the scanner's oscillating mirror fails. 

IEEE Address. See MAC Address.

Intercharacter Gap.  The space between two adjacent bar code characters in a discrete code.

Interleaved Bar Code. A bar code in which characters are paired together, using bars to represent the first character 
and the intervening spaces to represent the second.

Interleaved 2 of 5. A binary bar code symbology representing character pairs in groups of five bars and five 
interleaved spaces. Interleaving provides for greater information density. The location of wide 
elements (bar/spaces) within each group determines which characters are encoded. This 
continuous code type uses no intercharacter spaces. Only numeric (0 to 9) and START/STOP 
characters may be encoded.

IP. (Internet Protocol) The IP part of the TCP/IP communications protocol. IP implements the 
network layer (layer 3) of the protocol, which contains a network address and is used to route 
a message to a different network or subnetwork. IP accepts “packets” from the layer 4 
transport protocol (TCP or UDP), adds its own header to it and delivers a “datagram” to the 
layer 2 data link protocol. It may also break the packet into fragments to support the maximum 
transmission unit (MTU) of the network.

IP Address. (Internet Protocol address) The address of a computer attached to an IP network. Every client 
and server station must have a unique IP address. A 32-bit address used by a computer on 
a IP network. Client workstations have either a permanent address or one that is dynamically 
assigned to them each session. IP addresses are written as four sets of numbers separated 
by periods; for example, 204.171.64.2.

Kerberos. Kerberos is a network authentication protocol. It is designed to provide strong authentication 
for client/server applications by using secret-key cryptography. A free implementation of this 
protocol is available from the Massachusetts Institute of Technology. Kerberos is available in 
many commercial products as well.

Key. A key is the specific code used by the algorithm to encrypt or decrypt the data. Also see, 
Encryption and Decrypting.

LASER - Light 
Amplification by 
Stimulated Emission 
of Radiation. 

The laser is an intense light source. Light from a laser is all the same frequency, unlike the 
output of an incandescent bulb. Laser light is typically coherent and has a high energy density.

Laser Diode. A gallium-arsenide semiconductor type of laser connected to a power source to generate a 
laser beam. This laser type is a compact source of coherent light.

LED Indicator. A semiconductor diode (LED - Light Emitting Diode) used as an indicator, often in digital 
displays.  The semiconductor uses applied voltage to produce light of a certain frequency 
determined by the semiconductor's particular chemical composition.

MAC Address 
(also called 
IEEE Address). 

Spectrum24® devices, like other Ethernet devices, have unique, hardware-encoded MAC 
(also called IEEE addresses). MAC addresses determine the device sending or receiving 
data. The MAC address is a 48-bit number written as six hexadecimal bytes separated by 
colons.

MIL. 1 mil = 1 thousandth of an inch.
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Misread (Misdecode). A condition which occurs when the data output of a reader or interface controller does not 
agree with the data encoded within a bar code symbol.

MU. The MU (Mobile Unit) searches for APs with the same ESS_ID and associates with an AP to 
establish communications.

Null Modem Cable. An RS-232 cable used to connect two personal computers together in close proximity for file 
transfer. It attaches to the serial ports of both machines and simulates what would occur 
naturally if modems and the phone system were used. It crosses the sending wire with the 
receiving wire.

Nominal. The exact (or ideal) intended value for a specified parameter. Tolerances are specified as 
positive and negative deviations from this value.

Nominal Size. Standard size for a bar code symbol.  Most UPC/EAN codes are used over a range of 
magnifications (e.g., from 0.80 to 2.00 of nominal).

Open System 
Authentication. 

Open System authentication is a null authentication algorithm.

Parameter. A variable that can have different values assigned to it.

Percent Decode. The average probability that a single scan of a bar code would result in a successful decode.  
In a well-designed bar code scanning system, that probability should approach near 100%.

PING. (Packet Internet Groper) An Internet utility used to determine whether a particular IP address 
is online. It is used to test and debug a network by sending out a packet and waiting for a 
response.

Print Contrast Signal 
(PCS). 

Measurement of the contrast (brightness difference) between the bars and spaces of a 
symbol.  A minimum PCS value is needed for a bar code symbol to be scannable.  PCS = (RL 
- RD) / RL, where RL is the reflectance factor of the background and RD the reflectance factor 
of the dark bars.

Programming Mode. The state in which a scanner is configured for parameter values. See SCANNING MODE.

Protected Mode. An application can be assigned password protection so that it can only run when a password 
is entered. The password can be assigned for a specific application using the RDM, System 
Menu or the Control Panel.

Quiet Zone. A clear space, containing no dark marks, which precedes the start character of a bar code 
symbol and follows the stop character.

Reflectance. Amount of light returned from an illuminated surface.

Resolution. The narrowest element dimension which is distinguished by a particular reading device or 
printed with a particular device or method.

Scan Area. Area intended to contain a symbol.
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Scanner. An electronic device used to scan bar code symbols and produce a digitized pattern that 
corresponds to the bars and spaces of the symbol. Its three main components are:

1. Light source (laser or photoelectric cell) - illuminates a bar code.

2. Photodetector - registers the difference in reflected light (more light reflected from spaces).

3. Signal conditioning circuit - transforms optical detector output into a digitized bar pattern.

Scanning Mode. The scanner is energized, programmed and ready to read a bar code.

Scanning Sequence. A method of programming or configuring parameters for a bar code reading system by 
scanning bar code menus.

SMDK. Symbol Mobility Developer Kit

Self-Checking Code. A symbology that uses a checking algorithm to detect encoding errors within the characters 
of a bar code symbol.

Shared Key. Shared Key authentication is an algorithm where both the AP and the MU share an 
authentication key.

Space. The lighter element of a bar code formed by the background between bars.

Specular Reflection. The mirror-like direct reflection of light from a surface, which can cause difficulty decoding a 
bar code.

Start/Stop Character. A pattern of bars and spaces that provides the scanner with start and stop reading instructions 
and scanning direction. The start and stop characters are normally to the left and right 
margins of a horizontal code.

Subnet Mask. A 32-bit number used to separate the network and host sections of an IP address. A custom 
subnet mask subdivides an IP network into smaller subsections. The mask is a binary pattern 
that is matched up with the IP address to turn part of the host ID address field into a field for 
subnets. Default is often 255.255.255.0.

Substrate. A foundation material on which a substance or image is placed.

Symbol. A scannable unit that encodes data within the conventions of a certain symbology, usually 
including start/stop characters, quiet zones, data characters and check characters.

Symbol Aspect Ratio. The ratio of symbol height to symbol width.

Symbol Height. The distance between the outside edges of the quiet zones of the first row and the last row.

Symbol Length.  Length of symbol measured from the beginning of the quiet zone (margin) adjacent to the 
start  character to the end of the quiet  zone (margin) adjacent to a stop character.

Symbology. The structural rules and conventions for representing data within a particular bar code type 
(e.g. UPC/EAN, Code 39).
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TCP/IP. (Transmission Control Protocol/Internet Protocol) A communications protocol used to 
internetwork dissimilar systems. This standard is the protocol of the Internet and has become 
the global standard for communications.

TCP provides transport functions, which ensures that the total amount of bytes sent is 
received correctly at the other end. UDP is an alternate transport that does not guarantee 
delivery. It is widely used for real-time voice and video transmissions where erroneous 
packets are not retransmitted.

IP provides the routing mechanism. TCP/IP is a routable protocol, which means that all 
messages contain not only the address of the destination station, but the address of a 
destination network. This allows TCP/IP messages to be sent to multiple networks within an 
organization or around the world, hence its use in the worldwide Internet. Every client and 
server in a TCP/IP network requires an IP address, which is either permanently assigned or 
dynamically assigned at startup.

Telnet. A terminal emulation protocol commonly used on the Internet and TCP/IP-based networks. It 
allows a user at a terminal or computer to log onto a remote device and run a program.

TFTP. (Trivial File Transfer Protocol) A version of the TCP/IP FTP (File Transfer Protocol) protocol 
that has no directory or password capability. It is the protocol used for upgrading firmware, 
downloading software and remote booting of diskless devices.

Tolerance. Allowable deviation from the nominal bar or space width.

UDP. (User Datagram Protocol) A protocol within the IP protocol suite that is used in place of TCP 
when a reliable delivery is not required. For example, UDP is used for real-time audio and 
video traffic where lost packets are simply ignored, because there is no time to retransmit. If 
UDP is used and a reliable delivery is required, packet sequence checking and error 
notification must be written into the applications.

UPC. Universal Product Code. A relatively complex numeric symbology. Each character consists of 
two bars and two spaces, each of which is any of four widths. The standard symbology for 
retail food packages in the United States.

Visible Laser Diode 
(VLD). 

A solid state device which produces visible laser light.

WEP Encryption. (Wired Equivalent Privacy encryption) The conversion of data into a secret code for 
transmission over a public network. The original text, or plaintext, is converted into a coded 
equivalent called ciphertext using an encryption algorithm. The ciphertext is decoded 
(decrypted) at the receiving end and turned back into plaintext.

The encryption algorithm uses a key, which is a binary number that is typically from 40 to 128 
bits in length. The greater the number of bits in the key (cipher strength), the more possible 
key combinations and the longer it would take to break the code. The data is encrypted, or 
“locked,” by combining the bits in the key mathematically with the data bits. At the receiving 
end, the key is used to “unlock” the code and restore the original data.
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WEP. Wired Equivalent Privacy, is specified by IEEE for encryption and decryption of RF (wireless) 
communications.

WNMP. (Wireless Network Management Protocol) This is Symbol proprietary MAC layer protocol 
used for inter access point communication and other MAC layer communication.

WNMS 
(has been renamed to 
AirBeam 
Manager). 

See AirBeam Manager
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______________________________________________________________________________________

Very familiar Slightly familiar  Not at all familiar
Thank you for your input—We value your comments.
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