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1
Installing and Accessing Image Kiosk Power Tools

Image Kiosk Power Tools

Image Kiosk Power Tools are installed in every IK8560 and IK8570. Power Tools simplify system tasks such as retrieving device 
information, customizing user interfaces, and working with the registry.

Image Kiosk Power Tools consist of a CAB file and network utilities in the system kernel.

Software Requirements 

IK8560/8570 Kiosks

The CE-based Power Tools are designed to work with the following operating systems:

• Microsoft® Windows® CE 5.0

Desktop

The PC-based Power Tools are designed to work with the following operating systems:

• Microsoft® Windows® XP

• Microsoft® Windows® 2000

• Microsoft® Windows® NT

Note: For communication between a PC and an IK8560/8570, you must have Microsoft® ActiveSync® version 4.2 or later 
installed on the PC.

CAB File Power Tools
(in the .cab file)

• AutoInstall

• Autorun

• DeviceConfig

• EasyMenu

• EZConfig Editor CE

• EZConfigWinCE

• FrameworkLoaderApp

• IKWedge

• InstallerCE

• Reboot

• RegBackup

• RegEdit

• RegRestore

• SetDeviceInfo

• SysInfo

• EXM configuration files
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Upgrading Power Tools

Image Kiosk Power Tools come loaded in every IK8560/8570 and are included in system upgrades.

CAB File Power Tools The Power Tools .cab file is part of a Demos and Power Tools upgrade.

Acquiring Upgrades
Upgrades are available from Customer Support (see page 9-1) or www.handheld.com.

Installing an Upgrade to the PC
Image Kiosk Power Tools upgrades install to the PC via an upgrade executable. The upgrade files are then transferred to the 
IK8560/8570.

Requirements An active Microsoft® ActiveSync® connection between a host PC and the IK8560/8570.

1. Download the new Hand Held Products Image Kiosk Power Tools and Demos.exe to the Program Files folder on the 
PC.

2. Click the Hand Held Products Image Kiosk Power Tools and Demos.exe to install. 
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3. Click Next.

4. If you agree to the terms of the license agreement, click “I accept the terms of the license agreement.” and Next.
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5. Enter Your Name and Company Name.

6. Read the description on the screen and click Next.

7. Choose a Complete install and click Next.
Custom enables you to choose between Power Tools and Demos.
Complete installs both Power Tools and Demos.
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8. Verify the information and select Next to start copying files.

9. On the next screen, click Install and program begins installing. During the installation process, you are offered the 
opportunity to have the device cab files copied to the unit.
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When the installation is complete, click Finish.

Image Kiosk Power Tools and Demos Folder on the PC
After installation is complete, an Image Kiosk Power Tools and Demos folder is installed in the Program Files > Hand Held 
Products > Image Kiosk Power Tools and Demos folder. (If a Hand Held Products folder does not already exist in the Program 
Files folder, the installation creates one.) 

The Image Kiosk Demos and Power Tools has five folders:

Documentation User guides for the Image Kiosk Power Tools (including this guide).

EZConfig Editor EZConfig Editor program.

Power Tools and Demos CE Image Kiosk Power Tools cab file and the utility (CopyPowerToolsCab.exe) to copy the 
cab file to the IK8560/8570.

Desktop Driver Contains the IK8560/8570 USB Driver.

Device Image Default IPSM image.

Installing an Upgrade on the IK8560/8570
1. Connect the Image Kiosk to the PC and ensure that the ActiveSync connection is running. 

2. On the PC, open Windows Explorer and navigate to the Installing an Upgrade on the Terminal

3. Connect the Image Kiosk to the PC and ensure that the ActiveSync connection is running. 
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4. On the PC, open Windows Explorer and navigate to the \IPSM folder on the Dolphin terminal.

5. Back up your current \IPSM folder to the PC.

6. Delete the entire contents of the \IPSM folder. 

7. Navigate to C:\Program Files\Hand Held Products\Image Kiosk Power Tools and Demos\Device Image. 

8. Copy all items (including the Autoinstall folder). 

9. Navigate to the \IPSM folder on the Dolphin terminal and paste.

10. Copy and paste radio CABs, application CAB files, and programs to the \IPSM and \IPSM\Autoinstall folders. 

11. When all the files are pasted, cold boot the terminal. 

12. The Power Tools upgrade installs during startup.



1 - 8 Image Kiosk™/WinCE 5.0 Power Tools User’s Guide

Power Tools Main Window

Tap Start > Programs > Power Tools folder. 

Exiting the Power Tools Main Window

• Tap the Exit icon .
• Tap File > Exit (ESC).

View Options
The View menu in the command bar at the top of the screen changes the organization of the Power Tools main window. A 
checkmark appears next to the selected view. 

Icon Name Description See Page

EZConfig 
Utilities

Opens a window that displays the EZConfig utilities on the IK8560/
8570.

2-22

Reboot Performs a warm or cold boot from the touch screen. 6-2

RegBackup Backs up the registry. 7-2

RegEdit Allows you to edit the registry. 7-3

RegRestore Restores a backup of the registry. 7-8

SysInfo Displays system information. 6-5
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This menu enables you to choose between:

• Small Icon View
• Large Icon View (Default view)
• List View
• Detail View (This view displays a description of the Power Tool in a column to the right of the name.)

Additional Power Tools

These Power Tools are not accessed from the main window. 

Name Function Storage Location Access Location Page

AutoInstall Installs CAB files after a hard 
reset.

\IPSM \IPSM\AutoInstall 4-5

AutoRun Programs that applications  
launch at startup.

\IPSM \IPSM 4-1

EasyMenu Programs custom application 
windows.

\Program Files\Power 
Tools

\IPSM\*.exm files 8-1

InstallerCE Stores CAB files after they 
install instead of deleting 
them.

\Program Files\Power 
Tools

You do not launch 
InstallerCE.

4-1

SetDeviceInfo Sets a unique name and 
device for each IK8560/8570.

\Program Files\Power 
Tools

Start > Settings > Control 
Panel > System > Device 
Name tab.

6-3
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2
EZConfig Utilities

Overview

EZConfig is a suite of products that configures IK8560/8570s quickly and efficiently. With the tools in the EZConfig suite, you can 
package data on the PC, then deploy and unpackage that data on the IK8560/8570.

Components
There are two main components: EZConfig Editor and EZConfig Client.

EZConfig Editor
Edits and creates configuration files in the .exm file format for the IK8560/8570. There are two versions of EZConfig Editor: one 
for the PC and one for the IK8560/8570.

Both editors:

• Create and modify configuration files–Working with Open Configuration Files (see page 2-6)

In addition, EZConfig Editor on the PC 

• Generates bar codes from configuration files–Creating Bar Codes (see page 2-16)

For details about the PC editor, see EZConfig Editor on page 2-2.
For details about the IK8560/8570 editor, see EZConfig Editor on the IK8560/8570 on page 2-22.

EZConfig Client
Decodes the bar codes generated by EZConfig Editor on the PC. For details, see EZConfig Client on page 2-26.
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EZConfig Editor

EZConfig Editor creates, edits, and manages configuration files for IK8560/8570 devices. There is an EZConfig Editor on the PC 
and an EZConfig Editor on the terminal. In the PC editor, configuration files are edited, saved, then transferred to the terminal. 
In the terminal editor, configuration files are edited and saved right on the terminal; see EZConfig Editor on the IK8560/8570 
(page 2-22).

EXM Files 

Configuration files are in the EXM file format, which is an XML format customized for IK8560/8570 devices. EXM files are 
comprised of sections that contain child sections and keys. Keys contain the values that configure the terminal. 

The .exm file format supports a multi-level, hierarchical, tree structure. The terminal reads the highest level section first and then 
reads the key values in each section.

EXM files replace .ini files for Power Tools and terminal configuration settings. If both an .ini file and an .exm file are present for 
the same application, the terminal defaults to the .exm file and a warning message appears at startup. Remove the .ini file from 
the terminal to avoid this warning message.

Configuration Documents

There are two kinds of documents in the .exm file format: configuration documents and registry documents. Configuration 
documents program and configure the terminal. Registration documents update and modify the registry; see Registry Documents 
(page 2-14).

Sample EXM Files
After you install the new build on the PC, default configuration files are stored in the \Program Files\Hand Held Products\Image 
KioskPower Tools and Demos\EZConfig Editor folder. 

Use these configuration files as templates to create new configuration files.
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Opening EZConfig Editor on the PC
After you complete installation, EZConfig Editor is available on the PC from the Start menu. 
Click Start > Programs > Hand Held Products > Image Kiosk Power Tools > EZConfig Editor. 

Menu and Toolbar Options

File Menu

Menu Item Description

New 
Creates a new document. There are two options:

• Configuration Document - Creates a configuration file; 
Creating New Configuration Files (page 2-12).

• Registry Document - Creates a registry file in the .exm file format;
Registry Documents (page 2-14).

Open 
Opens a configuration file located on the PC.

Open from Device Opens a configuration file located on the terminal. The location of the file appears in the title bar 
with the word “[Remote]” to identify that the open file is located on the terminal. 
Note: Requires an ActiveSync connection between the PC and the terminal.

Save 
Saves the open file to the location you select on the PC.
This option is disabled for new and imported files; use Save As instead. 

Save As Saves the open file with a new name to the location you select on the PC.

Save to Device As Saves an open file to the terminal; see Saving to the Device on page 2-12.
Note: Requires an ActiveSync connection between the PC and the terminal.

Properties 
Associates the configuration file with an application on the terminal; see Associating Applications 
on page 2-13.

Create EZConfig 

Bar Code  

Embeds the open configuration file in an Aztec bar code; see Generating Bar Codes on page 2-17.

Exit Closes EZConfig Editor.

Menus

Toolbar
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Edit Menu
For Section Edit menu options, see Working with Sections on page 2-6.
For Key Edit menu options, see Working with Keys on page 2-10.

View Menu

Tools Menu

Menu Item Description

View Locks  
Displays an icon over locked sections. For example,

Information about locks on subsections and keys also appears in the Status Bar (see page 2-6).

Menu Item Description

Simplify Document
Note: You cannot 

undo this action!

Simplifies the configuration file, which makes it smaller. 
Simplifying permanently removes 

• Disabled sections and keys, 
• Descriptions 
• Bar code settings. 

When you create a bar code, you can simplify the file embedded in the bar code without affecting 
the open configuration file. This reduces the size of the bar code package yet keeps the disabled 
sections, descriptions, and bar code settings in the open configuration file for future reference. 
For more information, see Simplified (page 2-18) on the Advanced Tab (see page 2-19).

Because the following menu items execute commands on the terminal, there must be an ActiveSync connection between 
the PC and the terminal. 

Launch Associated 
Application

If the open configuration file is associated with an application on the terminal, this item is active 
and launches the associated application on the terminal.
Note: You would use this option after saving the configuration file to the terminal; Save to Device 

As, page 2-3.

Warm Boot *Warm boots the terminal.

Cold Boot *Cold boots the terminal.

*Some settings affect the boot process and these items can help you run a test without switching to the terminal.

The lock icon means the section’s 
subsections are locked.

The key icon means that the 
section’s keys are locked.
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Opening Configuration Files
EZConfig Editor opens configuration files located on either the PC or the remote terminal. 

Opening Configuration Files on the PC

Click File > Open or the Open toolbar button  and select the .exm file.

Opening Remote Configuration Files

Requirements The PC and the terminal must be connected via ActiveSync!

EZConfig Editor can open configuration files located on the remote terminal. 

Click File > Open From Device and the remote open window opens. 

To open, double-tap on a file or select it and click OK. 

Note: You can also open configuration files in the editor on the terminal; see EZConfig Editor on the IK8560/8570 (page 2-22).

Upgrade Remote INI 
Files

Not applicable

Menu Item Description
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Working with Open Configuration Files
Whether you open an .exm file or .ini file, EZConfig Editor displays the content in four different sections of the window. 

Status Bar
The Status Bar appears at the bottom of the window and displays information about selected sections and keys.

Selected Section

See Section Locks on page 2-8.

Selected Key

See Key Types on page 2-11.

Working with Sections
The .exm file format supports a multi-level tree structure. The section tree appears in the top left quadrant of the window. The 
root node identifies the configuration file and “Root” appears in the description.

Sections have a Name and Description and contain keys that appear in the upper right quadrant when you select the section 
name. Select a section by clicking on it. You can select only one section at a time.

Displays the root node 
and sections. 

Select a section and the 
details appear in the 
other portions of the 
window.

The folders appear in 
different colors to 
indicate their status.

Displays the section 
name and description. 

Displays the keys in the 
selected section.

Text that appears in blue 
can be edited.

Displays the selected 
key’s name and 
description.

Displays the file name.

If the file is on the 
terminal, the title bar 
displays the remote 
path.

Status Bar

Section Name Merge Mode Locks on subsections and keys

Key Name Enabled or 
Disabled

Read Only Encrypted Key locked by 
section 
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Edit Menu Options

Select a section click Edit to see the available options.

Rename Activates the section name so that you can rename the section.

Note: You cannot modify the name if the section is locked; see Section Locks (page 2-8).

Cut Cuts a selected section.

Copy Copies a selected section.

Paste Pastes the section that was just cut or copied at the same level as the selected section.

Paste as Child Pastes the section that was just cut or copied as a child of the selected section.

Note: You can cut, copy and paste sections within a configuration file or across configuration files.

Delete Deletes a selected section. 

Note: Because you cannot undo a delete, consider disabling rather than deleting.

Enable Sections are enabled by default. This menu item enables sections that were disabled. To enable a 
section, its parent section must be enabled.

To enable all the keys inside a section you are enabling, SHIFT + right-click and select Enable All.

Disable All Sections are enabled by default. This menu item disables sections and all of its keys. 
Disabled sections remain in the file with a gray folder .

If you disable a section that has child sections, all of its child sections (and the child section keys) are 
disabled automatically. The child section folders are also in gray.

When reading the configuration file, the terminal behaves as though disabled sections are not there 
and moves on to read the next enabled section.

Disabled sections can be removed from the configuration file permanently using the Simplify 
Document (see page 2-4) option. If you want to keep disabled sections in the configuration file on the 
PC but not the file deployed to the terminal, select the Simplified radio button (page 2-18) when 
creating the bar code.

Insert Section This menu item inserts a new section.

Note: You can also press the Insert key (INS).

Append Child Section This menu item adds a new child section to a selected section. The new child section is inserted 
below the previous child section.
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Modifying Section Names

To change a section name, double-click on the folder and type in the new name or select Rename on the Edit menu. Type in the 
new name and press ENTER.

Note: You cannot modify the name if the section is locked; see Section Locks (page 2-8).

Modifying Section Descriptions

Descriptions are not required to process key values but document the configuration file. If you want to modify a section 
description, select the section, click inside the section description, and begin typing. You cannot modify descriptions of locked 
sections.

Moving Sections

To move sections within a configuration file, use the drag and drop method. By default, sections are dropped at the same level 
in the tree.

For additional functionality when dragging and dropping, press and hold: 

• ALT to drop a section as a child section. 
• CTRL to copy a section and drop the copy at the same level in the tree. 
• CTRL + ALT to copy a section and drop the copy as a child section.
Note: You can select only one section at a time; you cannot use SHIFT+Click or CTRL+Click to select more than one section.

To move sections between configuration files, open two instances of EZConfig Editor and drag and drop sections between 
them. When dragging, a copy of the section is dragged to the new file. When dropping, drop the section directly on top of the 
section you want it to be a child section of.

Note: To drop the first section into a new file, press and hold the ALT key and drop the section on the root node. (All sections 
must be child sections of the root node.)

Section Locks

There are different types of locks on sections. The status bar indicates what type of lock is applied to a selected section.

Note: All locks are applied to each individual section and are not recursive. Only text that appears in blue can be modified.

Type of Locks Status Bar 
Indicator

Description Effect

Name Lock The section name is locked. • Section Name and Description cannot be 
modified. 

Key Lock All keys are locked. • Key Names and Descriptions cannot be modified.
• Keys cannot be added, moved, or deleted within 

the section. 

Subsection 
Lock

All immediate subsections are 
locked.

• Immediate subsection Names and Descriptions 
cannot be modified.

• Immediate subsections cannot be added, moved, 
or deleted.
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Section-Level Merge Modes

Configuration files ship with section-level merge modes already defined according to section content. Merge modes determine 
how section information is handled when an updated configuration file is deployed to the terminal where an existing version of 
that configuration file is stored.

Merge modes are indicated by folder icons and in the Status bar.

To change section-level merge modes, select a section and right click.

The folder colors change immediately after selection.

Mode Description Merge Effect

Delete + Add Deletes non-common children elements (i.e., subsections, and keys) in the 
target file, then adds the new information from the bar code. Basically, the new 
section replaces the old section.
This is the default merge mode for new sections. 

Exclusive

Disable + Add Disables non-common children elements (i.e., subsections, and keys) in the 
target file, then adds the new information from the bar code. 
Note: Disabled sections and keys removed from the simplified bar code end up 

as disabled in the target file.

Add Only Adds new information (sections and keys) to the existing section. If this is a 
brand new section, the new section is added to the existing configuration file.
Note: Disabled sections removed from the simplified bar code are not modified 

in the target file.

Inclusive
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Working with Keys
Keys have a Name, a Description, and a Value and reside inside sections. For specific key values, consult the chapters of this 
user’s guide that describe the configuration file you’re attempting to edit. 

Edit Menu Options

Select a key and right-click or click Edit to see the available options.

Rename Activates the key name so that you can rename the key. 

Note: Rename is disabled if the key is locked; see Key Types (page 2-11).

Cut Cuts a selected key.

Copy Copies a selected key.

Paste Disabled; keys can be pasted only as children of a section.

Paste as Child Pastes the key just cut or copied in the selected section. Keys are not multi-level; all keys paste at 
the same level within a section. 

Note: You can cut, copy and paste keys within a configuration file or across configuration files.

Delete Deletes a selected key. 

Note: You cannot undo a delete; you might want to consider disabling rather than deleting.

Enable Enables keys that were disabled. When a key is enabled, the client application can read and apply 
its value. When you enable a key, make sure to specify a value for that key; do not leave it blank.

Note: To enable a key, its parent section must be enabled.

Disable Disables keys. Enabled keys have key values in blue. Disabled keys have key values in black. 

The terminal does not read disabled keys and disabled keys are removed if the file is simplified;  see 
Simplify Document (page 2-4). 

Because many key values are 1 for enable and 0 for disable, remember that disabling a key 
means that the terminal behaves as if the key is not there when reading the file, NOT that the 
key’s value is set to disabled. The terminal simply moves on to read the next enabled key. 

Insert New Key This menu item inserts a new key above the selected key.

Note: You can also press the Insert key (INS).

Modifying Key Names

To modify key names, double-click on the key name or select Rename on the Edit menu. Type in the new name and press 
ENTER or TAB.

Note: You cannot modify the description if the key is locked; see Key Types (page 2-11). Only text that appears in blue can be 
modified.

The same options  
appear on both 
menus.
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Modifying Key Values

You can modify a key value only if its text appears in blue. In that case, double-click on the value or select the key and press 
ENTER. Type in the new value and press ENTER or TAB to save.

Modifying Key Descriptions

Descriptions are not required to process key values but document the configuration file for future reference. To modify a key’s 
description, click on the key, then click in the key description area. When the cursor is active, you can type in the text. 

Note: You cannot modify the description if the key is locked; see Key Types (page 2-11).

Moving Keys

To move keys within a configuration file, use the drag and drop method. Press and hold the CTRL key to drag and drop a copy 
of the key to the new location.

Note: You cannot move a key if it is locked by its section.

To move keys between configuration files, open two instances of EZConfig Editor and drag and drop keys between them. When 
you select the key and drag, a copy of the key is dragged to the new file. In the new file, drop the key in the key area of a selected 
section; keys are always dropped at the same level within a section.

Key Types

When a key is selected, its properties display in the Status bar.

Note: Locked and Read Only properties are not recursive. Properties are applied to each individual key. Only text that appears 
in blue can be modified.

Type Status Bar 
Indicator

Description Effect

Name Lock Keys are locked by the section. • Name and Description cannot be modified. 
• Keys cannot be added, moved, or deleted 

within the section.

The key name is locked 
individually.

• Name and Description cannot be modified. 
• These keys can be moved.

Read Only Read-only keys cannot be 
modified in any way. They 
appear in red.

• Name, Description, and Value cannot be 
modified.

• Keys cannot be added, moved, or deleted 
within the section.

Encrypted Key’s value appears as asterisks 
(*) for added security. 

Note: Encrypted keys are also stored encrypted 
in the EXM file. If you open the EXM file in 
a text editor, you won't see the data as 
clear text.
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Saving to the Device
You can save configuration files directly to the terminal when there is an ActiveSync connection between the terminal and the 
PC. Select File > Save to the Device As and the Save Remote File window opens. 

Select the location on the terminal where you want to store the configuration file and click OK. The configuration file is 
downloaded directly to the terminal via ActiveSync. 

Note: Configuration files for Image Kiosk Power Tools must be stored in the \IPSM folder. 

Creating New Configuration Files
To create new configuration files that are configuration documents, you can open an existing configuration file and save it with a 
new name or create a configuration file from scratch.

1. Click File > New > Configuration Document. The root node is created and appears as the top level section. All sections 
must be at least one level down from the root node. The name of the root node is always the same as the filename. 

Note: You can also create registry documents in the configuration file format. For details, see 
Registry Documents on page 2-14.

2. To create the first subsection, select the root node, right-click, and select Append Child Section. 
Insert Section is disabled because you cannot insert sections at the same level as the root node.

3. Enter a Name and a Description and click OK.
The name is required, the description is optional.

The terminal reads 
root node first.

The Description 
says “Root” to 
indicate that this is 
the root section. 
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4. To add a new section at the same level, right-click and select Insert Section.
To add a new section one level down, right-click and select Append Child Section.

5. To add keys, select a section, right-click in the key value section, and select Append Key. 

6. Enter the Name, Value, and Description and click OK.

7. Continue adding sections and keys.

8. If necessary, associate this configuration file with an application; see Associating Applications (page 2-13).

9. Click File > Save As to save the file. 
Save is disabled so that you save the document with a name other than “NewDocument.exm.”

Associating Applications
The Properties function associates a configuration file with an application on the terminal. The associated application launches 
after EZConfig Client decodes the bar code containing the configuration file. For more information, see Creating Bar Codes on 
page 2-16.

While the configuration file is open, click File > Properties or the Document Properties toolbar button .  

Field Description

Path Enter the location of the .exe on the terminal.

Arguments Enter the command line argument you want applied when the application launches.
When an application is entered in the Path field, the following command line appears as the 
argument: /exm %filename.

Enter additional command line arguments (see Command Line Arguments on page 2-28) next to /
exm %filename in this field.

“%filename” means that the value immediately after the “%” is variable and the file name will be 
replaced with the remote path entered on the Bar Codes tab; for more information, see Remote 
Path on page 2-18.

Execute Tells EZConfig Client to launch the application after decoding the bar code. Execute selects 
automatically when an application is entered in the Path field.  You cannot de-select Execute for 
configuration documents. 

You can de-select Execute for registry documents; however, EZConfig Client cannot update the 
registry unless Execute is selected. For more information, see Default Application Association 
(page 2-14).

Wait Until Finished Tells EZConfig Client to wait until the associated application is finished processing before finalizing.
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Registry Documents

EZConfig Editor creates registry documents in the .exm file format and also opens existing .reg files and converts them to the 
EXM file format.  EZConfig Editor cannot save registry documents in the .reg file format. 

Updating the Registry on the Terminal
To update the terminal’s registry, you must 

• Create a configuration file that is a registry document–Creating Registry Documents (page 2-14),
• Create a bar code package from that configuration file–Creating Bar Codes (page 2-16), and
• Scan the bar code with the terminal

By default, EZConfig Client on the terminal updates the Windows registry immediately after decoding the bar code. 

Default Application Association
By default, registry documents are associated with EZConfig Client. While a registry document is open, click File > Properties.

Execute must remain selected for EZConfig Client to update the registry after decoding the bar code. If Execute is not selected, 
the registry document is deployed after decoding but the registry is not updated.

Creating Registry Documents
1. In EZConfig Editor, click File > New > Registry Document. 

The new document contains the three top-level sections in a registry. These sections are locked and cannot be changed. You 
can add subsections to each section and then add keys to those subsections.

2. Click File > Save As. 

3. Choose the name and location and click Save. 
You cannot save the document as a .reg file; you must save it as an .exm file. 
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4. To add sections, select one of the registry levels, right-click, and select Append Child Section. 
Enter the section information, and click OK.

For more information about adding sections, see Working with Sections on page 2-6.

5. To add keys to the new section, select the section, and right-click in the key value area.
For details, see Adding Registry Keys on page 2-15.

6. Continue adding sections and keys.

7. Save the file.

Adding Registry Keys
To add a key, select a section, and right-click in the key area of the EZConfig Editor window. A list box with Append Key displays. 
Select the Append Key, and a key will be created with the key name = New Key, key type = REG_SZ, and Value field blank.  The 
key name field will be open for edit.  The other fields can be opened into edit mode by double clicking in the field area.  
Descriptions can be entered into the lower half of the EZConfig window.

When you click OK to save the key, the data appears in columns in the key area of the EZConfig Editor window.

Field Description

Name Enter the key’s name.

Registry Value Type Select the registry type from the drop down list. This value appears in the Type column.

Value Enter the key’s value.

Desc Enter a description for the key; descriptions appear in the lower half of the EZConfig Editor 
window when the key is selected.
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Processing Registry Documents on the Terminal
After EZConfig Client updates the registry, the configuration file itself is deployed to the location entered in the Remote Path 
(page 2-18) field on the Bar Codes Tab (page 2-18).

Note: EXM files appear with an  icon on terminal windows.

If you do not want to store the registry document on the terminal after updating the registry, select the Temporary (page 2-20) 
option on the Bar Codes Tab (page 2-18).

Creating Bar Codes 

EZConfig Editor embeds configuration files in bar codes. The EZConfig Client on the terminal decodes the bar code and deploys 
the data in the terminal.

Using bar codes quickly and easily configures IK8560/8570 devices without a direct connection to a PC.

Configuration File Types
EZConfig Editor produces two kinds of configuration files: configuration documents and registry documents. Both can be 
embedded in bar codes and processed by EZConfig Client on the terminal.

Configuration Documents
EZConfig Client deploys the configuration file in the terminal. If a configuration file is associated with 
an application, EZConfig Client deploys the data to that application for processing; see Associating 
Applications on page 2-13.

Note: The DeviceConfig.exm file must be associated with DeviceConfig.exe to be processed 
appropriately on the terminal.

Registry Documents EZConfig Client updates the registry immediately without launching another application. 

Bar Code Type

EZConfig Editor creates an Aztec bar code; for example, .

Time and Date Stamp
Configuration files are stamped with the time and date the moment EZConfig Editor creates the barcode.
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Bar Code Size and Number
The amount of data in the configuration file determines how many bar codes are generated and the physical size of each bar 
code. More data means more bar codes and larger bar codes. 

EZConfig Editor offers four ways to control how many bar codes are produced and adjust the size of each bar code: 

1. Set byte size limits on how much data each bar code can contain—see Max Barcode Size on page 2-19. 

2. Split the data across a specified number of bar codes—see # Bar codes to generate on page 2-18.

3. Simplify the configuration file in the bar code—see Simplified on page 2-18.

4. Scale the bar codes on the bar code sheet—see Bar Code Scaling Factor on page 2-21.

Bar Code Sheet
EZConfig Editor produces a bar code sheet that contains the generated bar codes. Bar code sheets can be printed from a laser 
printer, copied to the clipboard, and saved as an HTML file; see Printing and Saving Options on page 2-21. 

In addition, individual bar codes can be saved as .tiff or .png graphic files that can then be emailed and printed; see Bar Codes 
Tab on page 2-18.

Generating Bar Codes
When creating a bar code, EZConfig Editor automatically encrypts and compresses the data in the configuration file. To generate 

a bar code, click File > Create EZConfig Bar Code OR the Create Bar Code toolbar button  while the configuration file is 
open. EZConfig Editor generates a bar code or codes. The Bar Codes tab window opens displaying the details of the bar code 
package generated. 

The Bar Codes and Advanced tabs offers several processing options. 

Note: The number of bar codes produced depends on the amount of data present in the configuration file. The more data 
present, the more bar codes generated. You must scan all bar codes to deploy the package!
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Bar Codes Tab
The Bar Codes tab previews and customizes generated bar code(s). 

Field/Option Description

Display Indicates which bar code is displayed in the preview area; the default is “1,” the first bar code 
in the package. If more than one bar code was generated, you can use the up and down 
arrows to scroll through the bar codes.

(___ bytes) Displays the exact byte size of the bar code displayed in the preview area.
Total Package Size (page 2-21) is displayed at the bottom of the window.
Note: The sum of bar code size is typically larger than the package size. 

Remote Path Type in the location and filename where the configuration file should be deployed on the 
terminal. For instance, 
\ipsm\deviceconfig.exm

Tap the browse button  to navigate to the location on the terminal. Your ActiveSync 
connection must be active.

Full Contents Includes the full contents of the configuration file in the bar code, without simplifying.

Simplified Simplifies the configuration file in the bar code, which removes disabled sections, description 
information, and bar code settings (if any), which decreases the size of the bar code. The 
open configuration file is not simplified.
Simplified is selected by default.
The differences in total package size are displayed in the Package Size (page 2-21) field. 
Individual bar code size can be seen in the Display (page 2-18) field.

# Bar codes to generate This is active only if the Always use minimum # bar codes (see page 2-19) is not selected. 
When this slider is active, you can move the slider toward minimum or maximum to change 
the number of bar codes generated. As you move the slider, you’ll see the number of bar 

codes in the counter at the bottom of the window  and you’ll notice the graphic of the 
bar code in the preview area change.
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Advanced Tab
The Advanced tab contains settings that tell EZConfig Client how to process the configuration file on the terminal. 

Copy to Clipboard Copies the bar code displayed in the preview area to the clipboard.
Use this option to paste the bar code into another application.

Save Saves the bar code displayed in the preview area as a .png or .tiff image file. 
By default, the name of the graphic file is the same as the name of the open configuration file. 
You can enter a different name when saving.

Save All Saves all bar codes in the package as individual graphic files.
By default, the graphic files are saved with the same name as the open configuration file with 
a number at the end to distinguish the individual graphic files from each other.

Print Opens the printing window where you can select print options and print the bar code package. 
For details, see Printing and Saving Options on page 2-21.

Field Description

Bar Code Options

Max Barcode Size Set the maximum amount of data (in bytes) one bar code can contain. The lower the number of 
bytes, the smaller the bar code. Bar code size is displayed to the right of the Display (page 2-18) 
field. The total number of bar codes created is displayed at the bottom of the window; see Bar Codes 
(page 2-21).

Always use 
minimum # bar 
codes

This option is selected by default. It calibrates the data so that the minimum number of bar codes are 
used. When this option is selected, the number of bar codes slider on the Bar Codes tab is disabled.

Full screen 
progress dialog

This option runs the deployment progress dialog box on the terminal in full screen mode so that the 
user cannot open another application while the bar codes is being deployed on the terminal. 

Field/Option Description
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Warm boot after 
finished

This option automatically launches a warm boot on the terminal after the bar code is deployed. Use 
this option with configuration files that contain application information requiring a warm boot to take 
effect, such as registry settings.

Deployment Options–These options determine how to deploy the configuration file embedded in the bar code. For each 
deployment option selected, there are corresponding overwrite options under If already exists, deploy:.

Replace remote 
file

Replaces the existing file; no section-level merge modes are applied.
If already exists, deploy:

• Always–Select to always replace the existing file.

• Only if newer–Select to replace the existing file only if the file in the bar code is newer than the 
existing.

• Never—Do not deploy the new file; this preserves the existing file.

• Prompt—EZConfig Client asks the user if they want to overwrite the existing file during 
deployment.

Merge each 
section…
(Default selection)

Deploys information according to the section-level merge mode settings; see Section-Level Merge 
Modes on page 2-9.
If already exists, deploy:
• Always–Select to always use the section-level merge mode settings.
• Only if newer–Select to use the section-level merge mode settings only if the sections are newer 

than the existing file.

Temporary Deploys the configuration file temporarily. The configuration file is deployed and its settings applied, 
but the file does not remain in the system after EZConfig Client is done. 
If the terminal contains a previous configuration file with the same name, the previous configuration 
file is preserved.

Persist Bar Code 
Settings

Stores the settings from the Options, Bar Codes, and Web Page tabs within the configuration file so 
that the same bar code settings are applied the next time a bar code is created from the  
configuration file. This increases the size of both the configuration file and the bar code(s).  

If the Simplify option is selected, bar code setting information is not included in the bar code but 
remains in the open configuration file.

Field Description
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Information at the Bottom of Tab Windows 

Printing and Saving Options

On the Bar Codes tab, when you click Print, a bar code printing window opens offering you a number of printing options.   

Field Description

Package Size Displays the total size of the bar code package. This number changes with simplifying. 

Compression On Notifies you that compression and encryption are both on.
Compression and encryption are always on by default. EZConfig Editor uses 128-bit 
encryption automatically.Encryption On

Bar Codes Displays the total number of bar codes generated. This number changes as you move the 
slider on the Bar Codes tab.

Field/Option Description

Preview Area This is the largest section of the tab window and displays a preview of the bar code sheet. 
Use the scroll bars to see all the bar codes.

Header Type in a custom header for the page. “EZConfig Bar Code Sheet” is the default header.

Footer Type in a custom footer for the page. “Hand Held Products” is the default footer.

Bar Code Scaling Factor Adjusts the size of each bar code by scaling all of them up or down, which determines how 
many bar codes can fit on each page. This does not change the amount of data in each bar 
code, just the size of the bar code on the page.
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EZConfig Editor on the IK8560/8570

EZConfig Editor on the IK8560/8570 edits and creates configuration files in the IK8560/8570 and contains the same basic 
functionality as the editor on the PC. 

Accessing EZConfig Editor

Tap Start > Programs >  Power Tools > EZConfig Utilities . 

The EZConfig Utilities window provides access to both the EZConfig Editor and the EZConfig Client (see EZConfig Client on 
page 2-26) as well as the configuration files on the IK8560/8570. 

• To open EZConfig Editor without opening a configuration file, tap the EZConfig Editor icon . (You would then tap File 
> Open to open a configuration file.)

• Tap directly on a configuration file to open it in EZConfig Editor. 

Save Saves the bar code sheet as an HTML file.

Preview Click to see a print preview. 

Click Print on this window to print your bar codes.

Field/Option Description
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The EZConfig Editor window opens displaying the contents of the selected configuration file.  

Note: EXM files have an .exm file extension on IK8560/8570 windows.

Available Menus
The menus in the Command bar contain the same items as the menus in the EZConfig Editor on the PC.

File Menu For details about each menu item, see File Menu on page 2-3.

Note: You cannot generate bar codes from configuration files on the IK8560/8570.

Edit Menu For details about each menu item, see Edit Menu on page 2-4. 

Tools Menu For details about each menu item, see Tools Menu on page 2-4.

Editing Sections

Modifying Text

To edit a section name or description, you have two options: 

1. Select the section and tap Edit > Modify, OR

2. Select the section and press the ENTER key.
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Both options open the Edit Section window. 

Tap inside the Name or Description fields and edit the text.

Tap OK to save changes. (You can also press the ENTER key.)
Tap Cancel to close the window without changes.

Moving Sections

You cannot drag and drop to move sections in the tree. Use the Cut, Copy, Paste, and Paste as Child items on the Edit menu 
to move sections.

Note: The Paste function pastes sections at the same level they were cut by default.

Editing Keys

Modifying Text

To edit a key’s name, value, or description, you have three options:

1. Select the key and tap Edit > Modify, OR

2. Select the key and press the ENTER key. 

Both edit options open the Edit Key window. 
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Tap inside the Name, Value or Description fields and edit the text.

Tap OK to save changes. (You can also press the ENTER key.)
Tap Cancel to close the window without changes.

Moving Keys

You cannot drag and drop to move keys. Use the Cut, Copy, and Paste as Child items on the Edit menu to move keys.

Launching Associated Applications
The Tools menu contains an item named Launch Associated App.

Selecting this item automatically saves the open configuration file and launches the associated application while the configuration 
file remains open.

To see the associated application, tap File > Properties. 

The Path field contains the launch location of the application.
The Args field contains any command line arguments to execute when the application launches. 

For more information about associating applications, see Associating Applications on page 2-13.

Example 1 - You’ve saved changes to an open DeviceConfig.exm file. 

To apply those changes immediately, tap Tools > Launch Associated App. Because the DeviceConfig.exm file is associated 
with DeviceConfig.exe by default, DeviceConfig launches and applies the settings in the DeviceConfig.exm file.

Example 2 - You’ve saved changes to an open registry document. 

Because registry documents are always associated with EZConfig Client, tapping Tools > Launch Associated App updates 
the registry. EZConfig Client always updates the registry when launched from a configuration file that is a registry document.

Example 3 - You’ve saved changes to an open IKWedge.exm file.

And that IKWedge.exm file has the following parameters as the associated application:

Path: \program files\power tools\IKWedge.exe

Args: /restart
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Tapping Tools > Launch Associated App refreshes IKWedge with the new settings.

EZConfig Client

EZConfig Client decodes bar codes created in EZConfig Editor and deploys the data in the IK8560/8570. In addition, if the 
configuration file in the bar code is associated with an application, EZConfig Client launches that application, which then 
processes the decoded data. 

Storage Location
The EZConfig Client executable is stored in the \IPSM folder.

For upgrades, EZConfig Client is located in the IPSM image installed on the PC. This .exe must be copied and pasted into the 
\IPSM folder on the IK8560/8570. For more information, see Installing an Upgrade on the IK8560/8570 on page 1-6.

Using EZConfig Client
1. On the IK8560/8570, tap Start > Programs >  Power Tools. The Power Tools Main Window (see page 1-8) opens.

You can scan the first bar code from the Power Tools main window by pressing the SCAN key; see page 2-28 for details.
EZConfig Client can also be launched with a HotKey from any window; see page 2-28 for details.

2. Tap EZConfig Utilities  > EZConfig Client . The EZConfig Client window opens.

3. Point the IK8560/8570 at the first EZConfig Editor bar code and press the SCAN key.

4. EZConfig Client decodes the bar code. 
If there is only one bar code in the package, EZConfig Client deploys the package.
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If there is more than one bar code in the package, EZConfig Client decodes the bar code, records that one bar code has 
been read, and waits for the next scan. 

5. Scan all the bar codes in the package. Bar codes can be scanned in any order.

6. When all bar codes in the package have been scanned, the EZConfig Client deploys the data.  

Configuration File Processing
After decoding, EZConfig Client saves all configuration files to the location on the IK8560/8570 selected in the Remote Path 
(page 2-18) field on the Bar Codes Tab (page 2-18). (If the Temporary, page 2-20, option is selected in the bar code, EZConfig 
Client does not save the configuration file.)

There are two types of configuration files: configuration documents and registry documents. EZConfig Client processes each type 
of configuration file differently.

Configuration Documents
If the configuration file was associated with an application, EZConfig Client launches and deploys the 
data to that application for processing.

Note: DeviceConfig.exm file is a configuration document that must be associated with 
DeviceConfig.exe to be processed appropriately. After decoding the bar code, EZConfig 
Client deploys the data to DeviceConfig.exe, which applies the settings to the IK8560/8570. 

Registry Documents Registry documents are always associated with EZConfig Client. The Execute option (Execute, page 
2-13) determines whether the registry is updated or not. If Execute is selected, EZConfig Client 
updates the registry immediately after decoding the bar code.

Multiple Bar Codes
Some configuration files generate more than one bar code. If multiple bar codes were generated, EZConfig Client recognizes 
that there is more than one bar code in the package and tracks each bar code scanned and decoded. Bar codes can be scanned 
in any order, but EZConfig Client does not deploy the data until all the bar codes in the package have been scanned.
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EZConfig Client Window

Command Line Arguments
/%filename Executes the configuration file; this is the default entry.

/q Quiet mode

/s Full screen

/o No menu

/e Exit if first scan fails to deliver a valid bar code

/u Accept (decode) unsecure bar codes

Field Description

Package ID This is the ID of the entire package. 
EZConfig Editor assigns an ID to bar code packages when creating the bar code. 

Status This field displays the decode status of the bar codes scanned so far. 
If there is more than one bar code in the package, this field acts as a decode counter. 
The Status field displays:

• How many bar codes have been scanned and 
• How many bar codes are in the package

Read # box This box displays the list of bar codes scanned and decoded.

Accept Unsecure This option allows EZConfig Client to scan bar codes that are not encrypted.
Note: By default, all bar codes created in EZConfig Editor are encrypted.
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3
DeviceConfig

Overview

DeviceConfig consists of 

• The DeviceConfig executable file located in the \Program Files\Power Tools folder, and the 
• The DeviceConfig.exm file located in the \IPSM folder.  

DeviceConfig.exe looks for and applies the settings in the DeviceConfig.exm file.

DeviceConfig.exm 

The DeviceConfig.exm file contains terminal configuration settings and is stored in the \IPSM folder.  As such, the configuration 
settings in this file persist through cold boots and should be considered system defaults. For example, if you use the 
DeviceConfig.exm file to set up a radio, those settings remain in the IK8560/8570 after the next cold boot.

Autorun
The Autorun Configuration File (see page 4-1) launches DeviceConfig.exe during startup, which means that DeviceConfig.exe 
applies the (enabled) settings in the \IPSM\DeviceConfig.exm file after each cold boot.

Control Panel Applets
Many settings in the DeviceConfig.exm file, such as Connection settings, have Control Panel applets with GUIs on which the 
user can enter and save new values. If a user changes a setting in the Control Panel applet, that setting is applied but stored in 
RAM memory and erased during the next cold boot. Then, as part of startup after the next cold boot, Autorun launches 
DeviceConfig.exe, which then re-applies the settings in the DeviceConfig.exm file.

Bar Code Delivery
When the DeviceConfig.exm file is delivered to the IK8560/8570 via bar code, EZConfig Client launches DeviceConfig.exe 
automatically after decoding. DeviceConfig.exe then applies the settings in theDeviceConfig.exm file in the IK8560/8570. For 
more information, see Creating Bar Codes (page 2-16) and EZConfig Client (page 2-26).

Requirements

The DeviceConfig.exm file must be associated with DeviceConfig.exe for EZConfig Client to launch DeviceConfig.exe after 
decoding the bar code. In EZConfig Editor, the associated application path must be

\Program files\Power Tools\deviceconfig.exe

For more information, see Associating Applications, page 2-13. 

DeviceConfig.exe

DeviceConfig.exm
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DeviceConfig Sections and Keys

The sections and keys in the DeviceConfig.exm file are locked, which means that you can change the value but not the name or 
description. The description of locked keys contains “[Locked]” next to the name.  

Connections Section

The Connections section contains child sections that set communication parameters on the IK8560/8570.

System Section

The System section contains child sections that configure various system settings. For specifics on each section and its keys, 
refer to the Description sections in the DeviceConfig.exm file itself.

Applications Section

The Applications section configures specific software applications installed on the IK8560/8570.

Internet Explorer Section
The Internet Explorer section defines the home page for Internet Explorer 6.0 for Microsoft Windows CE.

Command Line Arguments

/q Quits the program; this command line in the Args field of the Associated Application window stops the 
confirmation message from appearing after DeviceConfig.exe finishes processing.

Launching DeviceConfig.exe Manually

DeviceConfig.exe does launch automatically after each cold boot. However, if you make changes to the DeviceConfig.exm file 
that you want applied in the IK8560/8570 immediately, manually launch DeviceConfig.exe.

1. Tap Start > Run, browse to \Program Files\Power Tools\ and double tap DeviceConfig.exe, then tap OK. Device Config 
executes and any changes the user might have made to DeviceConfig.exm are applied.

Section Name Description See Page

Connections Configures ActiveSync settings. 3-2

System Configures basic system settings. 3-2

Applications Configures software applications. 3-2

Key Description Default 
Value

Available Values

ActiveSync Enable/Disable automatic connection when 
the device is connected via USB to a PC.  If 
set to 1, a connection will automatically be 
established. 

1 0=Disabled
1=Enabled
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2. Tap Tools > Launch Associated App.

3. The settings in the DeviceConfig.exm file are saved and applied to the IK8560/8570 configuration by DeviceConfig.exe.

Temporary Option for Bar Code Deployment

The Bar Codes Tab (see page 2-18) in EZConfig Editor contains a Temporary option (see page 2-20) that, when selected during 
bar code creation, applies the settings in the DeviceConfig.exm file temporarily, which means until the next cold boot.

In the IK8560/8570, EZConfig Client deploys the DeviceConfig.exm file and launches DeviceConfig.exe, which applies the 
settings in the DeviceConfig.exm file as usual. However, when the Temporary option is selected, the DeviceConfig.exm file is 
not saved after processing is finished. The original file is preserved instead, and its settings will be restored during/upon the next 
cold boot.

Select this option when you want a temporary configuration in the IK8560/8570 (such as access to a specific network in a 
facility) without changing the default configuration. 
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4
Startup Power Tools

Overview

Startup is the launch sequence when an IK8560/8570 is booted. 
There are two startup Power Tools:

1. Autorun, page 4-1

2. AutoInstall, page 4-5

Autorun

Autorun specifies the software applications to launch after each hard reset. Autorun is located in the \IPSM folder and consists 

of an Autorun.exe  that is programmed by the Autorun Configuration File (page 4-1) .   

During startup, after a soft or hard reset, the IK8560/8570 operating system looks for and launches \IPSM\Autorun.exe. If the 
Autorun.exe is configured (by Autorun.exm) to launch an application, that application launches when Autorun.exe launches. 
Autorun can launch up to 32 applications or utility programs after each hard reset.

Note: The Autorun.exm file allows applications to be launched based on conditional situations, including the return code of 
another application launched previously and specific characteristics of the IK8560/8570 itself.

Autorun Configuration File
The Autorun.exm file has a multi-level tree structure. There are two top levels: 

Section Name Description See Page

Settings Stores general Autorun settings 4-2

Programs Determines which programs to launch; this section has multiple child sections 4-3
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Settings Section 

Note: This section and most of its keys are locked, which means that you can change the value but not the name or description. 

Key Function Default Available Values

Version Stores the .exm file version. 22 You cannot modify this 
value!

StartMenu Enables and Disables the StartMenu during the Autorun 
execution.

1 0=Disables
1=Enable 

Debug Controls the debug function at AutoInstall. 0 0=Disable
1=Enable, an autorun.log 

file is created in the 
\IPSM folder.

TestMode Runs the IK8560/8570 in test mode and tests the 
functionality of AutoInstall. This is a diagnostic tool.
When enabled, applications stored in the AutoInstall 
folder, including the radio drivers, are not loaded during 
startup. 

0 0=Disable
1=Enable
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Programs Section

The Programs section determines which programs launch at startup. 

Program Sections and Launch Sequence

Each section is a program to launch at startup. The sequence of sections determines the launch sequence on the IK8560/8570; 
the IK8560/8570 reads this file consecutively. To change the launch sequence, move the section up or down in the list; see 
Working with Sections (page 2-6).

Enabling and Disabling Sections

If you don’t want to the application to launch at startup, you can delete the section. However, program sections contain settings 
you’ll want to keep when adding that same application back to startup. To keep the program section in the file for future reference, 
disable the program section instead of deleting it. Disabled sections appear in red.

When processing files, the IK8560/8570 behaves as though disabled sections are not there and moves on to the next enabled 
section.

Program Child Sections

The following section is required and must be enabled.

The other sections launch the executable entered in the Program key.

Program Section Keys

Each program section should contain the following keys:   

Section Description

Reset Initiates a warm boot after the cold boot during startup. Do NOT disable the Reset section!

Key Function

Program Specifies the command line to execute. This is the location of the program’s executable. If you 
want a Power Tool to launch at startup, enter the location of that tool’s .exe here.

Args Specifies the command line arguments to execute at startup.

Wait Determines if Autorun should wait for the program to complete and close before continuing to 
the next program in the sequence. 
0=Continue to the next program immediately
1=Wait enabled 
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Editing the Autorun Configuration File
Edit Autorun.exm in EZConfig Editor. For details, see Working with Open Configuration Files on page 2-6.

Adding a Program Section 
1. In EZConfig Editor, right click on the Programs section and select Append Child Section.

A new program must be a child section of the Programs section to launch at startup.

2. On the Add New Section window, enter the Name and Description and click OK.

3. The new section is added to the bottom of the list.

StartOption Specifies the startup options for the program. Autorun launches the program only if the 
startup options entered here are met.
Blank = Always run the program.
For a complete list of values, see Startup Options on page 4-5.

Optional Keys—These are keys you can add as necessary.

PNPID Specifies a card description. This option needs to be entered only when PNPID or 
NONPNPID values are specified in the StartOption key.

DependIndex Specifies the index (top to bottom) of a dependent program.

DependExitCode Specifies the required result of the dependent program. If the result of the dependent program 
does not equal the DependExitCode entered here, the current program will not be executed at 
startup.

Key Function
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4. Use the click and drag method to move the section to the desired launch sequence. 
Press and hold the ALT key to make sure that you move the section at the same level. Do not append the section to an 
existing section!

5. Right-click in the key area and select Append Key. You must add all the required Autorun keys; see Program Section Keys 
on page 4-3.

6. Save the file and transport it to the IK8560/8570.

Sample Autorun Configuration File
A sample Autorun.exm file installs on the PC to C:\Program Files\Hand Held Products\Image Kiosk Power Tools and 
Demos\EZConfig Editor. 
For more information, see Sample EXM Files on page 2-2.

Startup Options
Startup Options define the required system parameters for a software application to launch.  The following values can be entered 
for the StartOption key, wherever it appears:

Multiple options can be specified for each category. Separate multiple options with a comma.

To ignore a category, don’t specify any of its options.

Applying Startup Options to the Autorun Configuration File

For each category, Autorun validates each startup option specified in the StartupOption key. If no specified option is valid in a 
category, Autorun does not execute the program. If at least one of the specified options is valid in each category evaluated, the 
program is executed.

To always execute a program, specify no options in the StartOption key.

AutoInstall

AutoInstall allows you to install . cab files automatically whenever the IK8560/8570 initializes from a cold boot. Stored in the 
\IPSM directory, AutoInstall consists of an AutoInstall.exe that, when launched, installs the CAB files in the AutoInstall folder.

The Autorun Configuration File, page 4-1, launches the AutoInstall.exe during startup.

Option Name The program launches if … Category

DISABLED Never, regardless of other startup options specified. None

COLDBOOT The IK8560/8570 has performed a cold boot.
Boot type

WARMBOOT The IK8560/8570 has performed a warm boot.
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AutoInstall launches during a hard reset (also known as a cold boot) and installs the CAB files stored in the AutoInstall folder. 
Therefore, if you want to ensure that a software application persists through a hard reset, store its CAB file in the AutoInstall 
folder.

Program Install Locations
When triggered by a hard reset, the CAB file installs the applications to the directories established in the CAB file. For most 
applications, this means that an .exe for the software application is placed in the \Program Files folder.

AutoInstall.exm
The AutoInstall.exm file controls the behavior and appearance of the Autoinstall process.  

Note: Remember! It’s the Autorun.exm file that determines the programs and install sequence, not AutoInstall.exm.

Command Line Arguments
/copy Add /copy to the Autorun.exm file to automatically move a file from one location to another.

Usage  autoinstall  /copy sourcefilename destinationfilename

Example autoinstall /copy "\windows\data.mdf " "\IPSM\data.mdf"

Key Function Default 
Value

Available Values

Version This is the current version of the AutoInstall.exm file. 
This key is read-only and cannot be modified.

3 N/A

Debug Enable and disables logging of debug information to  
\IPSM\AUTOINSTALL.LOG. 

0 0=Disabled
1=Enabled

Cancel Enable and disables the Cancel button on the 
AutoInstall window.

0 0=Disabled
1=Enabled

ExitPrompt Enable and disables the AutoInstall exit confirmation 1 0=Disables
1=Enabled

FullScreen Determines if the AutoInstall window runs in full screen 
mode (barring access to other windows).

1 0=Disabled
1=Enabled

HaltOnError Sets the behavior of AutoInstall when an error is 
encountered. 

1 0=Log the error and 
continue AutoInstall

1=Halt AutoInstall and 
prompt the user to 
continue or cancel

MaskPassword If a password is entered in the Password key, this key 
determines if that password is masked when entered on 
the screen.

1 0=Disabled
1=Enabled

Password Establishes a password required to halt AutoInstall. Blank Blank=User can halt and 
exit AutoInstall without 
entering a password

X=Password
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5
IKWedge

Overview

IKWedge sends data from the IK8560/8570 decoder to the foreground application as keystrokes (as if the data were entered via 
the keyboard). The foreground application is the open software application whose window is currently active on the display. 

Enabling IKWedge

Tap the IKWedge icon once . IKWedge initializes and enables.

Command Bar Menu
When IKWedge is enabled, a smaller IKWedge icon appears in the command bar at the bottom of the screen. 

Tap this icon to open the command bar menu. 

Enabling IKWedge at Startup
To run IKWedge automatically when the IK8560/8570 boots up, 

Add a link to the IKWedge.exe in the \WINDOWS\STARTUP folder

OR 

Enable the IKWedge section of the Autorun Configuration File (see page 4-1).

Menu Item This item …

Settings Edit the IKWedge.exm settings using the EZConfig Editor.  The settings are reloaded 
when the editor is closed if the settings file has been modified.

Scanning Enabled Enables and disables scanning without exiting IKWedge.

Translate Unprintables Enables and disables whether unprintable ASCII characters are replaced by their termi-
nal descriptors (values less that 32) or by their decimal value (values greater than 127).

Beep On Decode Whether to sound the IK8560/8570 beeper on a successful decode.

Beep On Application Event Enable/Disable device sounds for events other than decode.

About… Opens the About screen for IKWedge

Exit Exits the IKWedge application. The icon no longer appears in the Command bar.
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Disabling IKWedge

Navigate to the Power Tools Main Window (see page 1-8) and tap the IKWedge icon again.

OR

Select Exit on the Command Bar Menu (page 5-1).

Modifying the IKWedge Configuration File

When IKWedge is installed, a IKWedge.exm file is inserted in the \IPSM folder. This configuration file specifies configuration 
parameters for IKWedge and must be located in the \IPSM directory. Do not move IKWedge.exm!

Use EZConfig Editor on the PC to modify the IKWedge configuration file. For more information, see Working with Open 
Configuration Files on page 2-6.

IKWedge Configuration File Sections

The IKWedge.exm file is divided into the following sections:  

Basic Values
In each section, the following values apply (unless otherwise specified in the tables below):

0 = Disable 

1 = Enable

Section Description See Page

Settings Programs general settings for IKWedge. 5-3

Decode Specifies how the decoder/scanner interfaces with IKWedge. 5-4

Centering Defines the centering window for scanning bar codes when IKWedge is 
interfacing with the decoder.

5-6

Symbologies Defines the symbologies that the scanner can decode and send to IKWedge. 5-7

VK Mapping Defines the virtual key sent to IKWedge for any decoded ASCII character. 5-9
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Settings Section
The Settings section determines how IKWedge interprets data from the decoder.

0 = Disable    1 = Enable

Settings Section Key Description Default 
Value

Available Values

Version This is the version of IKWedge 3 You cannot modify this value.

Aimers Enables and disables aimers while scanning. 0 0=Disable
1=Enable

SendMode Specifies the method to use when sending the 
decoded message to the foreground 
application. 
Note: This setting affects only the decoded 

message; the prefix and suffix are always 
sent using the virtual key method to allow 
navigational functionality.

0 0=Each character is sent as a 
virtual keystroke.  This method 
works well when scanning small 
bar codes (20 characters or less), 
but becomes very slow for larger 
bar codes on the IK8560/8570. 

1=IKWedge uses the direct text 
method where the decoded 
message is sent as text directly 
to the window that has the 
keyboard focus in the foreground 
application. This method is faster 
than the virtual key and supports 
bar codes with ASCII characters 
between 1 and 255 but works 
only if the foreground application 
uses standard Window’s Edit 
controls for user input.

2=Simulated Key method: each 
character is sent as an actual 
keystroke.  This method works 
well for all bar codes, but does 
not use the VKMapping table.

Sound Enables and disables the audio notification for 
decode/data reception. There is one sound for 
success and another sound for an error.

1 0=Disable; no sound on decoding.
1=Enable; sound on decoding.

SoundConnect Enables and disables 
• The sound that IKWedge makes when 

starting up, shutting down, or restarting.

1 0=Disabled 
1=Enabled

Note: Audio notifications for errors 
can’t be disabled.

MessageConnect Enables and disables the display of a 
notification message after a successful imager 
connect.

0 0=Disable
1=Enable

Append Keys Options for Key strokes to be appended to the 
decoded data when sent to the active window.

3 0 - None.
1 - Append a <tab>
2 - Append a <CR>
3 - Append <CR><LF>
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Translate 
Unprintable

Enables/ Disables the translation (replacement) 
of non-printable ASCII characters.

If < 32 (Space) - The character is replaced with 
its terminal character string. ex.  The character 
value 09 is replaced by "<tab>".

if > 127 - The character is replaced by its 
decimal value <ddd>.  ex.  The character value 
220 is replaced by "<220>"

1 0=Disable
1=Enable

Accept EZConfig
This key applies only to 
the decoder.

Enables and disables IKWedge’s compatibility 
with EZConfig Client when decoding bar codes. 

1 0=Disabled; IKWedge processes 
EZConfig bar codes as it would 
any other bar code.

1=Enabled; IKWedge recognizes 
EZConfig bar codes and passes 
them on to the EZConfig Client 
for further processing.

Decode Section
The Decode section specifies decoder settings when using the decoder with IKWedge.

IKWedge Entry Description Default 
Value

Available Values

Enable Enable and disable scanning for bar 
codes.

0 0=Disabled; Application still 
running but scanning is turned off.
1=Enabled; Scanning for bar codes 
is enabled.

ScanTimeout Specifies the decode time out. If a symbol 
is not decoded in the specified timeout the 
scan process is restarted.

30000 Timeout is specified in 
milliseconds.
0=No Timeout
300000=5 minutes

ScanMode Specifies the decode method used by the 
decoder.

0 0 - Full Omni decoder.
1 - Quick Omni decoder.
2 - Aggressive Linear decoder

LinearRange Specifies the linear search range to be 
used while in ALD mode.

3 The range is 1 to 6. A value of 1 
indicates a tight vertical range near 
the aimer. A value of 6 indicates a 
vertical range of the entire height of 
the imager.

Settings Section
The Settings section determines how IKWedge interprets data from the decoder.

0 = Disable    1 = Enable

Settings Section Key Description Default 
Value

Available Values
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Sound Enable/Disable successful beep on 
successful decode.

1 0=No Beep (Silent Decode)
1=Beep on decode.

ScanInterval The time to wait after a decode timeout 
before continuing to scan for more bar 
codes.

400 Time is specified in milliseconds.

0=Don't wait
300000= 5 minutes

PostDecodeInterval The time to wait after a successful decode 
before continuing to scan for more bar 
codes.

2500 Time is specified in milliseconds.

0=Don't wait
300000= 5 minutes

PrintWeight This is the relative contrast setting used by 
the decoder when scanning and decoding 
symbols.

4 The valid range is 1 (light) to 7 
(dark).

ReverseVideo Tells whether symbols being scanned are 
dark on light or light on dark.

0 0 = dark bar code on light 
background.
1=light bar code on dark 
background

SearchTimeLimitFull
Omni

Maximum time in milliseconds to search a 
single image for a decodeable symbol 
when the decoder is set to Full Omni 
Mode.

400 The valid range is 0 (None) to 
10000 (10 seconds).

DecodeAttemptLimitFull
Omni

Maximum time in milliseconds that the 
decoder should spend trying to decode a 
suspected symbol in Full Omni mode.

800 The valid range is 0 (None) to 
10000 (10 seconds).

SearchTimeLimitQuick
Omni

Maximum time in milliseconds to search a 
single image for a decodeable symbol 
when the decoder is set to Quick Omni 
Mode.

400 The valid range is 0 (None) to 
10000 (10 seconds).

DecodeAttemptLimit
QuickOmni

Maximum time in milliseconds that the 
decoder should spend trying to decode a 
suspected symbol in Quick Omni mode.

800 The valid range is 0 (None) to 
10000 (10 seconds).

SearchTimeLimitALD Maximum time in milliseconds to search a 
single image for a decodeable symbol 
when the decoder is set to Aggressive 
Linear Mode.

400 The valid range is 0 (None) to 
10000 (10 seconds).

DecodeAttemptLimitALD Maximum time in milliseconds that the 
decoder should spend trying to decode a 
suspected symbol in ALD mode.

800 The valid range is 0 (None) to 
10000 (10 seconds).

Decode Section
The Decode section specifies decoder settings when using the decoder with IKWedge.

IKWedge Entry Description Default 
Value

Available Values
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Centering Section
The Centering section determines the centering window for bar code scanning. 

IKWedge Entry Description Default 
Value

Available Values

CenteringEnable= Enable and disables the decode centering 
window for the decoder.    

0 0=Disabled; centering is disabled 
for IKWedge.

1=Enabled; bar codes are decoded 
only if they are within the 
centering window specified by 
the rest of the keys in this 
section. 

CenteringTop= Specifies the top coordinate of the 
centering window.  

215 Enter the coordinates in pixels.

CenteringBottom= Specifies the bottom coordinate of the 
centering window.

265

CenteringLeft= Specifies the left coordinate of the 
centering window. 

335

CenteringRight= Specifies the right coordinate of the 
centering window. 

385
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Symbologies Section
The Symbologies section specifies the settings for each of the symbologies supported by the decoder.

The settings are in the form: 

Symbology Name=Enable(1 or 0), Parm1, Parm2, Parm3, Parm4, Parm5, Parm6, Parm7, Parm8

Where 

• Enable specifies that the symbology is enabled or disabled.  
• Parms1–8 specify the settings for the symbology. 

For more information regarding the individual settings for each of the symbologies, refer to the Hand Held Products Decode API 
documentation in the IK8560/8570 SDK documentation.

Symbologies Settings

0=Disabled  1=Enabled

IKWedge Entry Default Enabled/
Disabled Value

Default Value

Aztec Code 1=Enabled 1,3750,0,0,0,0,0,0

Codabar 1=Enabled 0,0,0,2,60,0,0,0

Code 11 0=Disabled 1,4,80,0,0,0,0,0

Code 128/EAN 128 1=Enabled 0,80,0,0,0,0,0,0

Code 39 1=Enabled 0,0,0,0,0,2,48,0

Code 49 1=Enabled 1,81,0,0,0,0,0,0

Code 93 1=Enabled 0,80,0,0,0,0,0,0

EAN.UCC Composites 0=Disabled 0,1,300,0,0,0,0,0,

Data Matrix 1=Enabled 1,1500,0,0,0,0,0,0

EAN-8 1=Enabled 0,0,0,0,0,0,0,0

EAN-13 1=Enabled 0,0,0,0,0,0,0,0

Interleaved 2 of 5 1=Enabled 0,0,4,80,0,0,0,0

MaxiCode 0=Disabled 1,150,0,0,0,0,0,0

MicroPDF417 1=Enabled 1,366,0,0,0,0,0,0

OCR 0=Disabled 2,dddddddd,,,,0

PDF417 1=Enabled 1,2750,0,0,0,0,0,0

QR Code 0=Disabled 1,3500,0,0,0,0,0,0



5 - 8 Image Kiosk™/WinCE 5.0 Power Tools User’s Guide

Postnet 1=Enabled 0,0,0,0,0,0,0,0

Reduced Space 
Symbology (RSS)

1=Enabled 1,1,4,74,0,0,0

UPC-A 1=Enabled 0,0,0,0,0,0,0,0

UPC-E0 1=Enabled 0,0,0,0,0,0,1,0

UPC-E1 0=Disabled 0,0,0,0,0,0,1,0

ISBT 0=Disabled 0,0,0,0,0,0,0,0

British Post 0=Disabled 0,0,0,0,0,0,0,0

Canadian Post 0=Disabled 0,0,0,0,0,0,0,0

Australian Post 0=Disabled 0,0,0,0,0,0,0,0

Straight 2 of 5 IATA 0=Disabled 4,80,0,0,0,0,0,0

Codablock 0=Disabled 1,2048,0,0,0,0,0,0

Japanense Post 0=Disabled 0,0,0,0,0,0,0,0

Planet Code 0=Disabled 0,0,0,0,0,0,0,0

Dutch Post 0=Disabled 0,0,0,0,0,0,0,0

MSI 1=Enabled 4,48,0,0,0,0,0,0

TCIF Linked Code 39 
(TLC39)

0=Disabled 0,0,0,0,0,0,0,0

Trioptic Code 0=Disabled 0,0,0,0,0,0,0,0

Code 32 0=Disabled 0,0,0,0,0,0,0,0

Straight 2 of 5 Industrial 0=Disabled 4,48,0,0,0,0,0,0

Matrix 2 of 5 0=Disabled 4,80,0,0,0,0,0,0

Plessey 0=Disabled 4,48,0,0,0,0,0,0

China Post 0=Disabled 4,80,0,0,0,0,0,0

Korea Post 0=Disabled 4,48,0,0,0,0,0,0

Symbologies Settings

0=Disabled  1=Enabled

IKWedge Entry Default Enabled/
Disabled Value

Default Value
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VK (Virtual Key) Mapping Section
The virtual key map settings are located in the VKMapping section in the IKWedge configuration file. The virtual key map settings 
define the virtual key that will be sent to IKWedge for any decoded ASCII character. 

The settings are in the form:   ASCII Key = Virtual Key, ShiftMode

Where

• ASCII Key is an ASCII value between 0 an 255 (decimal)
• Virtual Key is the virtual key to be sent when the specified ASCII key is decoded
• ShiftMode can have the following values:

• 0=the virtual key is never shifted
• 1=the virtual key must be shifted
• 2=the virtual key needs to be shifted if Caps Lock is off
• 3=the virtual key needs to be shifted if Caps Lock is on

For detailed information about the values in this section,  see Virtual Key Codes Table on page 5-10.

Telepen 0=Disabled 1,60,0,0,0,0,0,0

Code 16K 0=Disabled 1,160,0,0,0,0,0,0

PosiCode 0=Disabled 4,48,0,0,0,0,0,0

Coupon Code 0=Disabled 0,0,0,0,0,0,0,0

4-CB (4-State Customer 
Barcode)

1=Enabled 0,0,0,0,0,0,0,0

ID-tag (UPU 4-State) 1=Enabled 0,0,0,0,0,0,0,0

Symbologies Settings

0=Disabled  1=Enabled

IKWedge Entry Default Enabled/
Disabled Value

Default Value
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Virtual Key Codes Table

The following table shows the symbolic constant names, hexadecimal values, and keyboard equivalents for the virtual-key codes 
used by the Microsoft Windows CE operating system. The codes are listed in numeric order. 

Note: To use these codes in the VKMapping section, the hexadecimal values need to be converted to decimals. 

Virtual Key Codes Table

Symbolic Constant Name Decimal Value Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 

VK_LBUTTON 1 01 Touch screen  

VK_CANCEL 3 03 Control-break processing 

—— 5-7 05-07 Undefined 

VK_BACK 8 08 BACKSPACE key 

VK_TAB 9 09 TAB key 

—— 10-11 0A-0B Undefined 

VK_CLEAR 12 0C CLEAR key

VK_RETURN 13 0D ENTER key 

—— 14-15 0E-0F Undefined 

VK_SHIFT 16 10 SHIFT key

VK_CONTROL 17 11 CTRL key

VK_MENU 18 12 ALT key 

VK_CAPITAL 20 14 CAPS LOCK key 

—— 21-25 15-19 Reserved for Kanji systems 

—— 26 1A Undefined 

VK_CLEAR 12 0C CLEAR key 

VK_RETURN 13 0D ENTER key 

—— 14-15 0E-0F Undefined

VK_SHIFT 16 10 SHIFT key 

VK_CONTROL 17 11 CTRL key 

VK_MENU 18 12 ALT key

VK_CAPITAL 20 14 CAPS LOCK key 
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—— 21-25 15-19 Reserved for Kanji systems 

—— 26 1A Undefined 

VK_ESCAPE 27 1B ESC key 

—— 28-31 1C-1F Reserved for Kanji systems 

VK_SPACE 32 20 SPACEBAR key

VK_PRIOR 33 21 PAGE UP key

VK_NEXT 34 22 PAGE DOWN key 

VK_END 35 23 END key

VK_HOME 36 24 HOME key 

VK_LEFT 37 25 LEFT ARROW key

VK_UP 38 26 UP ARROW key

VK_RIGHT 39 27 RIGHT ARROW key 

VK_DOWN 40 28 DOWN ARROW key

VK_SELECT 41 29 SELECT key 

—— 42 2A Original equipment manufacturer 
(OEM)– specific 

VK_EXECUTE 43 2B EXECUTE key

VK_SNAPSHOT 44 2C PRINT SCREEN key for Windows 3.0 and later 

VK_HELP 47 2F HELP key 

VK_0 48 30 0 key 

VK_1 49 31 1 key 

VK_2 50 32 2 key 

VK_3 51 33 3 key 

VK_4 52 34 4 key 

VK_5 53 35 5 key 

Virtual Key Codes Table

Symbolic Constant Name Decimal Value Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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VK_6 54 36 6 key 

VK_7 55 37 7 key 

VK_8 56 38 8 key 

VK_9 57 39 9 key 

—— 58-64 3A-40 Undefined 

VK_A 65 41 A key 

VK_B 66 42 B key 

VK_C 67 43 C key 

VK_D 68 44 D key 

VK_E 69 45 E key 

VK_F 70 46 F key 

VK_G 71 47 G key 

VK_H 72 48 H key 

VK_I 73 49 I key 

VK_J 74 4A J key 

VK_K 75 4B K key 

VK_L 76 4C L key 

VK_M 77 4D M key 

VK_N 78 4E N key 

VK_O 79 4F O key 

VK_P 80 50 P key 

VK_Q 81 51 Q key 

VK_R 82 52 R key 

VK_S 83 53 S key 

VK_T 84 54 T key 

Virtual Key Codes Table

Symbolic Constant Name Decimal Value Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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VK_U 85 55 U key 

VK_V 86 56 V key 

VK_W 87 57 W key 

VK_X 88 58 X key 

VK_Y 89 59 Y key 

VK_Z 90 5A Z key 

—— 91-95 5B-5F Undefined 

VK_NUMPAD0 96 60 Numeric keypad 0 key 

VK_NUMPAD1 97 61 Numeric keypad 1 key 

VK_NUMPAD2 98 62 Numeric keypad 2 key 

VK_NUMPAD3 99 63 Numeric keypad 3 key 

VK_NUMPAD4 100 64 Numeric keypad 4 key 

VK_NUMPAD5 101 65 Numeric keypad 5 key 

VK_NUMPAD6 102 66 Numeric keypad 6 key 

VK_NUMPAD7 103 67 Numeric keypad 7 key  

VK_NUMPAD8 104 68 Numeric keypad 8 key 

VK_NUMPAD9 105 69 Numeric keypad 9 key 

VK_MULTIPLY 106 6A Asterisk (*) key 

VK_ADD 107 6B Plus sign (+) key 

VK_SEPARATOR 108 6C Separator key 

VK_SUBTRACT 109 6D Minus sign (–) key 

VK_DECIMAL 110 6E Period (.) key 

VK_DIVIDE 111 6F Slash mark (/) key 

—— 88 88-8F Unassigned 

—— 146-185 92-B9 Unassigned 

Virtual Key Codes Table

Symbolic Constant Name Decimal Value Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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—— 186-192 BA-C0 OEM-specific 

—— 193-218 C1-DA Unassigned 

—— 219-228 DB-E4 OEM-specific 

—— 229 E5 Unassigned 

—— 230 E6 OEM-specific 

—— 231-232 E7-E8 Unassigned 

—— 233-245 E9-F5 OEM-specific 

VK_ATTN 246 F6

VK_CRSEL 247 F7

VK_EXSEL 248 F8

VK_EREOF 249 F9

VK_PLAY 250 FA

VK_ZOOM 251 FB

VK_NONAME 252 FC

VK_PA1 253 FD

VK_EM_CLEAR 254 FE

VK_LWIN 91 5B

VK_RWIN 92 5C

VK_APPS 93 5D

VK_LSHIFT 160 A0

VK_RSHIFT 161 A1

VK_LCONTROL 162 A2

VK_RCONTROL 163 A3

VK_LMENU 164 A4

VK_RMENU 165 A5

Virtual Key Codes Table

Symbolic Constant Name Decimal Value Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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Command Line Arguments

/restart Forces IKWedge to process its configuration file (IKWedge.exm) again, which applies changes 
immediately. If the SoundConnect (see page 5-3) is set to 1 (enabled), an ascending connect sound 
is played on restart.

/quit Shuts down IKWedge.
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6
Additional Power Tools

Overview

This chapter describes the following Power Tools:

InstallerCE (page 6-2)

Reboot (page 6-2)

SetDeviceInfo (page 6-3)

SysInfo (page 6-5)
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InstallerCE

InstallerCE is a utility that saves CAB files after a manual install initiated by double-tapping on the CAB. Normally, when you 
install a program by double-tapping on its CAB, the CAB file is deleted after installation is complete. InstallerCE preserves the 
original CAB file in its original location.

Location InstallerCE is located in the \Program Files\Power Tools folder.

To Manually Install a CAB File 
1. On the IK8560/8570, open File Explorer.

2. Navigate to the \IPSM\AutoInstall folder.

3. Double-tab on a CAB file. The program begins installing.

4. If the program is already installed, the system will ask you if you want to re-install it. Click Yes.

5. After installation is complete, notice that the CAB file remains in the AutoInstall folder.

Reboot

Reboot performs a warm or cold boot from the touch screen. Reboot offers you the option of using the touch screen instead of 
the hardware button to perform a cold boot.

Warm Boot
A warm boot is a soft reset. A soft reset re-boots the device without losing RAM data. 

You would perform a soft reset when

• the IK8560/8570 fails to respond.
• after installing software applications that require a re-boot.
• after making changes to certain system settings, such as network cards.

Cold Boot
A cold boot is a hard reset. A hard reset resets the operating system, restores the IK8560/8570 back to factory defaults, and 
resets the IK8560/8570. 

A hard reset erases all of the data stored in RAM memory and all RAM installed applications! Only data and applications stored 
in \IPSM memory persist.

Rebooting the IK8560/8570
1. Tap Start > Programs > Power Tools. The Power Tools Main Window (see page 1-8) appears. 

2. Tap the Reboot icon . The Reboot screen appears.  

To perform a warm boot, tap the Warm Boot button. 

To perform a cold boot, tap the Cold Boot button.

The IK8560/8570 begins booting immediately.
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Command Line Arguments
/r Warm Reset

/c Cold Reset

SetDeviceInfo

SetDeviceInfo sets a unique device name and description for the IK8560/8570. 

Location SetDeviceInfo is an executable in the \Program Files\Power Tools folder that creates a Device 
Name tab window in the “System” Control Panel applet. 

Startup SetDeviceInfo launches automatically after each hard reset. The SetDeviceInfo Program section of 
the Autorun Configuration File (page 4-1) is enabled by default.

Device Name Tab
1. Tap Start > Settings > ControlPanel.

2. Tap the System icon .

3. Tap the Device Name tab. The Device Name window appears displaying the default Device name and Description. 

4. You can enter a unique Device name and Description in both fields.
ActiveSync recognizes the Device name and Description entered here.

5. Tap OK to save.

Default Device Name
The Device name in the graphic above breaks down like this:

Prefix Data

IK 000008216

The SetDeviceID configuration file in the \IPSM folder contains these settings.
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Customizing the Device Name
You can make a custom device name for the IK8560/8570 by modifying the SetDeviceInfo.exm file in EZConfig Editor on the PC.

To change a value, click on the data in the Value column.

For more information, see Working with Open Configuration Files (page 2-6).

Device Name Restrictions
1. The device name must begin with a letter.

2. The entire device name (the combination of all three key values) cannot exceed 15 characters.

You can enter any values you like within these restrictions.

Key Values

Prefix This field must begin with a letter.

Data The default is “[SERIALNUMBER].” SetDeviceInfo dynamically obtains the IK8560/8570’s serial 
number.
If you want the serial number in a different location in the device name, type 

[SERIALNUMBER]

as the Value in either the Prefix or Suffix keys.

Suffix The default is “[MODELNUMBER].” SetDeviceID dynamically obtains the IK8560/8570’s model 
number. 
If you want the model number in a different location in the device name, type 

[MODELNUMBER]

as the Value in either the Data or Prefix keys. 
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SysInfo

SysInfo provides a read-out of important system information including firmware versions, .dll versions, system parameters, as 
well as network and radio information. 

To See System Information
1. Tap Start > Programs > Power Tools. The Power Tools Main Window (see page 1-8) appears. 

2. Tap the SysInfo icon once . 

3. SysInfo queries the system, compiles the data and displays it on the SysInfo screen.  

You cannot edit information in SysInfo. This information is gathered from the IK8560/8570 and changes only when the IK8560/
8570’s configuration has changed.

To refresh the system information, go to File > Refresh. The system re-compiles system information.

To Save the System Information to a Text File
Tap File > Save to File. A file named “Sysinfo.txt” is generated and saved to the IPSM folder.

To open the file, tap Start > Programs > File Explorer. Navigate to the IPSM folder. The Sysinfo.txt file appears in the list.  

Viewing Options
You must copy the file to the host computer to view the file. 
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Sample SysInfo Text

Field Sample Data This entry specifies the …

SYSTEM TIME:

Date 04/27/2005 Current date.

Time 16:21:29 Time the SysInfo icon was tapped.

SYSTEM INFO:

Hardware Revision 1 Hardware revision.

Kernel 8.08 (Oct 04, 2004) Kernel version.

Service Pack 03 Service pack level.

Boot Loader 8.08 (Oct 04, 2004) Bootloader version.

Manufacture Date 20040720 Manufacture date.

Model Number IK8560/8570 Model number.

Part Number IK8560-000-000 Main board part number.

Special Part Number Special part number, if any.

Terminal Serial Number 000008216 IK8560/8570 serial number.

CPLD Version 31205342-005 CPLD firmware version.

Scanner Type IT4300 Scanner type.

Touch Panel Type Installed Type of touch panel.

Display Type Sharp Color Type of display.

PROCESSOR INFO:

ProcessorName PXA255 Name of the CPU.

Architecture ARM Processor architecture.

ProcessorLevel 4 Architecture-dependent processor level.

ProcessorRevision Model A, Pass 6 Architecture-dependent processor revision.

DLL VERSION INFO:

Decoder.dll 2.16 Current DecodeCE.dll API build revision.

MagStripe.dll 1.4 Current MagStripe.dll API build revision.
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Matrix Engine 1.97.1.2 Current Matrix engine build revision.

HHPScanInterface.dll 1.15 Current HHPScanInterface.dll API build revision.

Scan Driver 1.100 Current scan driver build revision.

HHPICMediaHW.dll 1.00.01 Current HHPICMediaHW.dll API build revision.

HHPMT9V022HW.dll 1.00.01 Current HHPMT9V022HW.dll api build revision.

ImgApi.dll 2.04.05 Current ImgApi.dll API build revision.

DibCE.dll 2.04.00 Current DibCE.dll API build revision.

SYSTEM PARAMETERS:

OEMInfo Hand Held Products Name of the OEM. 

PlatformType Win CE 5.0 Type of platform (CE or PPC)

NETWORK INFO:

Hostname test The logical name assigned to the IK8560/8570.

NumberOfAdapters 2 Number of network adapters installed in the IK8560/
8570.

1: Mac Address 000000000000 IK8560/8570’s MAC address.

1: IP Address 192.168.55.101 IK8560/8570’s IP address.

RADIO INFO:

Current Mode: 802.11b Radio mode that is currently enabled.

Modes Supported: 802.11b

/IPSM Contents: AutoInstall
Autorun.exe
AutoRun.exm
DemosMenu.exm
DeviceConfig.exm
EZConfigWinCE.exe
SetDeviceInfo.exm
AutoInstall.exe
EZConfigMenu.exm
IKWedge.exm
PowerTools.exm
RegBackup.hhp
AutoInstall.exm
FrameworkLoaderApp.exe
NewDocument.exm

Displays the filenames of the files stored in the /IPSM 
folder.

Sample SysInfo Text

Field Sample Data This entry specifies the …
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/IPSM/AutoInstall/ 
Contents:

IK8560 Power Tools r1.02.cab
IK8560 .NET Install r1.02.CAB
ceremote.8560.CAB
IK8560 .NET Demos r1.02.CAB

Displays the filenames of the files stored in the /IPSM/
AutoInstall folder.

STORE INFO:

StoreSize 65773568 Size, in bytes, of the object store.

FreeSize 61070344 Amount of free space in the object store, in bytes.

SYSTEM VERSION:

MajorVersion 4

Microsoft’s version and build numbers for the operating 
system.

MinorVersion 21

BuildNumber 1088

PlatformId 3

CSDVersion Most current service pack installed on the system.

GLOBAL MEMORY STATUS:

MemoryLoad 38 Number between 0 and 100 that gives a general idea of 
current memory utilization. 0 indicates no memory use 
and 100 indicates full memory use.

TotalPhysical 65888256 Total number of bytes of physical memory.

TotalPageFile 0 Number of bytes of physical memory available.

AvailPageFile 0 Total number of bytes that can be stored in the paging 
file.

TotalVirtual 33554432 Total number of bytes that can be described in the user 
mode portion of the virtual address space of the calling 
process.

AvailVirtual 27721728 Number of bytes of unreserved and uncommitted 
memory in the user mode portion of the virtual address 
space of the calling process.

Sample SysInfo Text

Field Sample Data This entry specifies the …
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7
Registry Power Tools

Overview

The registry is the configuration database in all 32-bit versions of Windows that contains settings for the hardware and software, 
consisting of the SYSTEM.DAT and USER.DAT files. Many settings previously stored in the WIN.ini and SYSTEM.ini files in 16-
bit Windows (Windows 3.x) are in the registry.

The IK8560/8570 contains three Power Tools that enable you manage the registry on your device:

1. RegBackup (page 7-2)

2. RegEdit (page 7-3)

3. RegRestore (page 7-8)

Accessing Registry Power Tools
Registry Power Tools are accessed from the Power Tools Main Window (see page 1-8).
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RegBackup

RegBackup backs up the current registry to a RegBackup file stored in the \IPSM folder. 

To Backup the Registry 
To ensure that you are backing up the most current registry, you need to warm boot the IK8560/8570 prior to backing up the 
registry.

1. Warm boot the IK8560/8570; see Warm Boot on page 6-2.

2. On the Power Tools Main Window (see page 1-8), tap the RegBackup icon once . The registry starts backing up 
and the following screen appears. 

3. When the backup is complete, a RegBackup file is created and in the \IPSM folder.   

Note: By default, the RegBackup.hhp file loads after a cold boot. 

Command Line Arguments
/h Help
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RegEdit

RegEdit modifies the device’s registry settings. 

To Edit the Registry

1. On the Power Tools Main Window (see page 1-8), tap the RegEdit icon once . RegEdit opens to a split-pane window 
with a collapsible menu in top half.

This is the top level of the registry; it cannot be edited, copied, pasted, or renamed.

2. Click the + sign to expand the menu options.

3. Reg Edit offers the following registry categories:

4. Expand the appropriate menu by clicking on the + sign.

5. Drill-down to the appropriate registry entry. When you click on a registry entry in the top half of the screen, the data appears 
in the lower half of the screen.  

The two columns show the Value Name and the Value Data. 

Category

HKEY_CLASSES_ROOT

HKEY_CURRENT_USER

HKEY_LOCAL_MACHINE
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6. Double-click on the Value Data. The Edit Value window pops up.

In the Value Data field, type the new value.

7. Press the ENTER or OK key. The new data appears in the list.

8. After all your edits are complete, Warm Boot (see page 6-2) the IK8560/8570.

To Export the Registry
You can export the current registry.

1. Tap File > Export. The Save As window appears.

2. Enter a Name.

3. Select a Folder. Selecting None places the file in the My Documents folder.

4. You can save the exported file only as a .reg file Type.
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5. Tap OK. The file is saved in the selected location.

Note: Tapping on a .reg file in any folder immediately tries to add the information in that file to the registry. A message appears 
asking if you want to add the information to the registry. Tap Yes to add the information. Tap No to exit.

To Import Registry Files
The file must be loaded on the IK8560/8570 and have a .reg extension.

1. Tap File > Import.

By default, the open function searches for .reg files and displays the search results in the lower half of the window. 

2. To import a file into the registry, tap on it twice. The file loads automatically and the RegEdit window appears on the screen.
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File Menu

Edit Menu

Menu Item Description

New Creates a new Key, String, or DWORD Value. 

Import Imports a registry file; see To Import Registry Files on page 7-5.

Export Exports the current registry; see To Export the Registry on page 7-4.

Exit Closes RegEdit.

Menu Item Description

Copy Copies a selected item.

Paste Pastes a copied item within RegEdit.
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View Menu

These menu items shift focus between the Keys Panel and the Values Panel.

Registry Edit Options
You can also use EZConfig Editor to create registry documents on the PC, create a bar code, then use EZConfig Client to decode 
the bar code and update the registry on the IK8560/8570.

For more information, see

• Registry Documents on page 2-14
• Creating Bar Codes on page 2-16
• EZConfig Client on page 2-26

Rename Renames a registry entry. 

Enter the new name and press the ENTER or OK key.

Delete Deletes a selected registry entry.

Find Searches for registry entries within a selected section. (Select an item in the top half of the window 
before tapping Edit > Find.) 

Enter the search criteria and tap OK. RegEdit notifies you if the selected section contains data 
matching the entered criteria.

Find Next Launches another search for the criteria entered in Find.

Menu Item Description
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RegRestore

RegRestore restores the registry to the last backed up registry. When the registry is backed up (see RegBackup on page 7-2), 
RegBackup creates a RegBackup file in the \IPSM folder. 

RegRestore calls, then loads the RegBackup file into the current registry.

To Restore the Registry

On the Power Tools Main Window (see page 1-8), tap the RegRestore icon once . The system starts restoring the 
registry and the following screen appears.

When the restore is complete, this screen disappears.

Hard Reset (Cold Boot)
By default, the Autorun Configuration File (see page 4-1) launches RegRestore after a hard reset. Therefore, if you want changes 
made to the registry to persist through a cold boot, back up the registry after your edits are complete; see RegEdit on page 7-3. 

Command Line Arguments
/r Reboot after restore.

/q Quiet, No dialogs

/k Override kernel version

/s Override service pack version

/h Help
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8
EZMenu

Overview

EZMenu formats application windows such as the Power Tools main window (see Power Tools Main Window on page 1-8). 

EZMenu consists of menu configuration files (special *.exm files) in the \IPSM folder and EZMenu.exe in the \Program 
Files\Power Tools folder, which applies the menu settings they contain.  DemosMenu.exm is an EZMenu.exm file that is included 
with the Power Tools and demos. 

Running Easy Menu 
EZMenu runs when you access an application window that has a menu configuration file. EZMenu.exe calls that menu 
configuration file to format the window. 

Default EZMenu Configuration Files 

The IK8560/8570 ships with a number of menu configuration files in the \IPSM folder: 

PowerTools.exm Programs the Power Tools main window (Start > Programs > PowerTools). 

EZConfigMenu.exm Programs the EZConfig Utilities window; see EZConfig Editor on the IK8560/8570 on page 2-22.

DemosMenu.exm Programs the Demos main window (Start > Programs > Demos)

Default menu configuration files must be located in the \IPSM folder.

*.exm Files EasyMenu.exe
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Modifying Menu Configuration Files 

Menu configuration files can be modified in EZConfig Editor on the PC or the IK8560/8570 

For details:

See EZConfig Editor on page 2-2. If modified on the PC, the *Menu.exm file must be deployed to the IK8560/8570.

See EZConfig Editor on the IK8560/8570 on page 2-22.

Creating Menu Configuration Files 

Use the Default EZMenu Configuration Files (see page 8-1) to create new menu configuration files.

1. On the PC, navigate to the C:\Program Files\Hand Held Products\Image Kiosk Power Tools\EZConfig Editor folder.

2. Open a sample menu configuration file in EZConfig Editor.

3. Tap File > Save As and save the file with a new name.

4. Modify the file; to see the available values, see Menu Configuration File Sections on page 8-2.

5. Save or transfer the file to the \IPSM folder on the IK8560/8570. 

Menu Configuration File Sections 

Menu configuration files contain of two basic sections: Settings and MenuEntries. Both sections are locked, which means only 
their Values can be changed.

Settings Section 
The Settings section defines general EZMenu settings. The keys in this section are locked, which means that only their Values 
can be changed. 

Key Description Default 
Value

Available Values 

Sig Identifies this file as a menu file. EZMenu These keys are read-only and cannot be 
changed.

Version This is the EZMenu version number. 1

EnableDebug Enables system debugging. 0 0=Disable
1=Enable; an Easymenu.log file is 

created in the \IPSM folder. 

ListViewMode Determines the default view mode for the 
window. For details, see View Options on 
page 1-8.

3 0=Detail 
1=List 
2=Small Icon 
3=Large Icon 

Caption Defines the caption or title displayed in the 
title bar of the application window.

Variable User-defined  

StartMenu Enables and disables access to the Start 
menu from the application window.

Variable 0=Disable Start Menu 
1=Enable Start Menu 

OK Toggles the presence of an “X” in the upper, 
right corner of the application window.

Variable 0=Disable
1=Enable 
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MenuEntries Section 
The MenuEntries section determines which programs appear on the application window. 

The MenuEntries section is locked, which means that you cannot change its Name or Description; however, its child sections are 
not locked and can have any name and description.

Each child section is a program that launches from the application window and must be at the same level underneath the 
MenuEntries section. The order of child sections from top to bottom determines the order that the programs appear on the 
application window. 

Child Section Keys 

The keys in the child sections are locked, which means only their Values can be changed.

Menu Determines which menus appear in the 
Command bar at the bottom of the window. 
There are three menus: File, View, and Help.
Exit=File menu
View=View menu
Default=File, View, and Help menus

3 0=No Menus 
1=Default Menu + No Exit + No View
2=Default Menu + No Exit
3=Default Menu

The following three parameters determine the icon spacing in all view modes: 

ListViewIconSpacingY Determines vertical icon spacing. 65 Spacing is measured in pixels. 

ListViewIconSpacingX Determines horizontal icon spacing. 75 Spacing is measured in pixels.

MaskPassword Determines whether to mask the optional 
passwords for the menu entries

1 0=Disable
1=Enable 

Key Description Required Available Values 

Name Name to display on the window. The name appears under 
the icon (if there is an icon).

Required User-defined

Description Description to display on the window in Detail view. Required User-defined

Key Description Default 
Value

Available Values 
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*Optional keys are not present by default, and must be created manually if desired.

Exit Icon

Default EZMenu Configuration Files (see page 8-1) contain a section named Exit as a child section of the MenuEntries section. 

The Exit section places this icon  on the application window, which allows users to exit. If you want users to be able to exit 
the application window, make sure the Exit section is a child of the MenuEntries section. If you want users to be unable to exit 
the application window, disable or delete the Exit section.

CommandLine Command line to execute when the item is selected on 
the window. This is the location of the EXE file for the 
location to launch.

Required Location of the .EXE. file.
Also available:
[ADMIN]=Toggles into 
Administrative mode 
[EXIT]=Exit menu 

CommandArgs Command line arguments used with the CommandLine 
parameter.

*Optional Program-specific

Password Use this key to password-protect access to the window. If 
no value is entered, the window is not password-
protected. 

Optional Enter a password. 

HotKey Hotkey that can be used to launch the menu entry.  Optional HotKey number

HotKeyModifier Modifier for the hotkey. Optional Global: 
16=No Modifier 
17=ALT 
18=CONTROL 
20=SHIFT 

EZMenu only: 
0=No Modifier 
1=ALT 
2=CONTROL 
4=SHIFT 

IconFile  The filename of the icon resource file. Optional The filename must be an 
.exe or .dll, NOT an .ico 
file. 

Icon ID The icon resource identifier contained in the file specified 
in the IconFile key.

Optional X=Icon resource identifier

StartupOption Specifies startup options that must be met for the menu 
entry to appear on the window.

Optional See Startup Options on 
page 8-5.

Key Description Required Available Values 
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Multiple options can be specified for each category. Separate multiple options with a comma.

To ignore a category, don’t specify any of its options.

Locking Down the Application Window

You can program a menu configuration file to block access to the Start menu, OK button, and Command bar menus on the 
application window. When all of these items are blocked, the user must navigate the IK8560/8570 from the application window. 

EZMenu carries these settings forward to all windows opened from the application window. This way, access to the Start menu, 
OK button, and Command bar menus can be blocked globally.

1. Open the menu configuration file in EZConfig Editor.
For more information, see Working with Open Configuration Files on page 2-6.

2. In the Settings Section (page 8-2), modify the following keys:

Menu=0 (No menus appear in the Command bar.)

3. If you are modifying the file in EZConfig Editor on the IK8560/8570, tap Tools > Launch Associated App. The application 
window opens displaying your changes. 

If you are modifying the file in EZConfig Editor on the PC, save, then transfer the file to the IK8560/8570. On the IK8560/
8570, navigate to the application window to verify your changes.

Note: To remove the Exit icon as well, delete the Exit section; see Exit Icon on page 8-4.

Booting the IK8560/8570 to the Application Window
You can program the IK8560/8570 to boot to the application window by modifying the Autorun Configuration File (see page 4-1).

1. In EZConfig Editor, open Autorun.exm.

2. Open the Programs section and enable the EasyMenu section.

Startup Options
Startup Options define the required system parameters for a software application to launch. The following values can be 
entered for the StartupOption key, wherever it appears:

Option Name The program launches if … Category

DISABLED Never, regardless of other startup options specified. None

COLDBOOT The IK8560/8570 has performed a cold boot.
Boot type

WARMBOOT The IK8560/8570 has performed a warm boot.



8 - 6 Image Kiosk™/WinCE 5.0 Power Tools User’s Guide

3. In the EasyMenu section, modify the Args key to call the .exm file of the application window. This is the path to the menu 
configuration file; i.e., “\ipsm\***menu.exm.”
By default, the Args key calls \ipsm\demosmenu.exm. 

4. Warm boot the IK8560/8570 and verify that startup finishes on the application window.
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9
Customer Support

Technical Assistance

If you need assistance installing or troubleshooting, please call your Distributor or the nearest Hand Held Products technical 
support office:

North America/Canada

Telephone:  (800) 782-4263
Fax number:  (315) 554-6705
E-mail:  natechsupport@handheld.com

Latin America

Telephone: (803) 835-8000
Telephone: (800) 782-4263
E-mail:  latechsupport@handheld.com

Brazil

Telephone: +55 (21) 2178-0500
Fax:  +55 (21) 2178-0505
E-mail:  brsuporte@handheld.com

Mexico

Telephone: (803) 835-8000
E-mail:  latechsupport@handheld.com

Europe, Middle East, and Africa

Telephone:  +31 (0) 40 7999 393
Fax:  +31 (0) 40 2425 672
E-mail:  eurosupport@handheld.com

Asia Pacific

Telephone - Hong Kong:  +852-3188-3485 or  2511-3050
Telephone - China:  +86 21 6361 3818    
E-mail:  aptechsupport@handheld.com

Japan

Telephone:  +813 5770-6312
E-mail:  aptechsupport@handheld.com

Online Technical Assistance
You can also access technical assistance online at www.handheld.com.

For Further Information
To download the full User’s Guide for these products, visit our website at www.handheld.com.

http://www.handheld.com/Site.aspx/na/en/home/
http://www.handheld.com
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