Purpose of this Document

Summary of Update

Changes that Effect the
Entire Document

Document Update

AdaptaScan™ Bar Code
Readers Application Guide

(Catalog Numbers 2755-SN3, -SN5, -and -SN8)

This document update revises the following publication. Keep this
document update for reference.

Publication Description
2755-6.8 AdaptaScan Bar Code Readers Application Guide

The following sections summarize the information contained in this
Document Update. Changes are presented as those that effect the
entire document or for a specific chapter in the document.

The following provides an update for changes that effect the entire
document.

Application Guide Database File

There is now an Application Guide Database File containing all of
the applications found in thedaptaScan Bar Code Readers
Application GuidgPublication No. 2755-6.8). The file is included
as part of the AdaptaScan Installation Files.

File Function

APPGUIDE.DBF Database containing example projects from the
AdaptaScan Application Guide.
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Project Database Dialog Box

Starting with version 11.x is a new project database dialog box that
allows you to select or create a database file. You can use this to
help organize your project. From the WinddWwStart menu, select
Programs>AdaptaScanOLP>AdaptaScan OLR The database

dialog opens.

ﬁhdaptaﬁcan Off-Line Programmer - Adaptasn. dbf

File Edit “iew Progect ‘window Help

aE e el e 2 emin] s e |

i Adaptasn_dbf

Frojects:
.............. T Open e
Ready S

You can create multiple database (.DBF) files with different projects.
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Project Dialog Box

There is a new Project dialog box that offers Upload/Download

functionality.
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The buttons on the Project window are defined below.

Select:

To:

Mew

Create a new Bar Code Reader configuration (Bar Code Reader 1, Bar
Code Reader 2, Bar Code Reader 3, ...) in the Project window.

Delete

Delete the selected Bar Code Reader configuration from the Project win-
dow.

Labels...

Define label setups and symbologies for Reader operation.

Device...

Define a unique name and enter a description for the Reader. Also de-
fines a DeviceNet™ address for the Reader.

Scanner...

Specify linear or raster scanning, how scanning is triggered, and access
the focus function.

Decoder...

Define when the Reader decodes data and what label is decoded. Also
defines the inter-symbol timer and performance indicator parameters.

InputAOutput....

Define the operation for package detector, discrete inputs, discrete out-
puts, timer and ASCII trigger commands.

Serial Port...

Define communication parameters (RS-232, RS-485/RS422) and proto-
cols (ASCII, DH-485, DF1) for the Reader’s communication ports.

Match T able...

Define match table, package and counter functions for decoded
bar code data.

Meszage...

Define the format and content of messages sent to the host after bar
codes are decoded.

Upload

Transfer the configuration stored in a Reader to the currently opened
project in the AdaptaScan Software.

Download

Downloads the highlighted configurations to the reader or network.

tonitor

View the operation of a single Reader or another Reader on the same
network.

Compare

Compare the Reader configuration within the project with the on-line
device.

PHRERERARNRNER

Firmware. ..

Download new firmware to a selected Reader.

Publication 2755-6.8.1
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Toolbar

Version 11.x offers a new toolbar. Turn the tool bar view on or off
from the View menu. The tool icons provide shortcuts to the
following menu items:
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Move the toolbar to any side of the window or detach the toolbar and
place anywhere on your screen by clicking on and holding down the
mouse key while dragging the toolbar.
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The following provides a brief summary of the AdaptaScan tools.

Tool

or Select
from menu:

Description

Create New Database

File >New

Creates a database file that will contain project configuration
files.

Open Existing Database

File >Open

Opens window allowing you to select an existing database file
(.dbf) containing project configuration files.

Open Selected Project

Project >Open

Opens the project currently selected in the AdaptaScan
database file window.

Create New Project

Project >New

Creates a new project within the currently open database file

(.dbf).

Go On-Line - | On-Line Tools >Go On-Line Connects the programming computer to the network.

Go Off-Line L On-Line Tools >Go Off-Line Disconnects the programming computer from the network.
ggl;zduizlgst;?o Prec IEI On-Line Tools >Upload gﬂ;i(:sp:r;jeezznﬁguration stored in the selected reader to the
e o | | | Ortoe T Do | DOl Rt o) o

Open Monitor Window

(=]

On-Line Tools >Monitor

Opens on-line monitor window.

Compare Project
Configuration with
On-Line Device

On-Line Tools >Compare

Compares the configuration database of the currently selected
Reader to the actual configuration stored within the Reader.

|

Removes the currently selected item from the dialog or

Cut Selection to Clipboard Edit>Cut window and places the item on the clipboard.

Copy Selection to Clipboard Edit >Copy gr?gis; 222 fﬁ;riggi ziliﬁ;eg”gz;naxm the dialog or window
Paste Clipboard Contents Edit >Paste z’;zt;: ;hliclz.;to irt]t.am placed on the clipboard to the currently
Print File >Print Opens the print dialog that allows you to print out an

application report.

About AdaptaScan Software

o | M | B

Help >About Off-Line Programmer

Opens a dialog showing the software revision and serial
numbers along with other software information.

On-Line Context Help

Help >Contents

When selected, displays a pointer. this pointer may be moved
to an area on a dialog or menu and clicked for help about the
item.

Publication 2755-6.8.1
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Online Tools

There are new online tools — project window icons. The project
window status icons display the status of the Reader connections and
configurations.

—
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Connection Device Icon # peeeetemrrrd TS ey
Indicates device is on-line . Database . Graphic representing
Indicates Configuration the type of device R | | B |
is stored in the database
Connection

When displayed, indicates a connection was made to the device:

* Yellow (default) indicates that the AdaptaScan software does not
have the information required to determine whether the device’s
configuration matches the configuration in the software database.

* Green appears after a Compare operation (see page 11) was
performed and the configuration of the on-line reader matches the
database configuration.

* Red appears after a Compare operation (see page 11) was
performed and the configuration of the on-line reader does not
match the database configuration.

Database

When displayed, indicates that a database configuration exists for the
Reader. The color indications are the same as for the Connection
icon (see descriptions above).

Device Icon

Displays the icon associated with the device. Here are some
common device icons:

m = AdaptaScan Reader g = PhotoEye photo-electric detector

= SDN Scanner Card % =KFD DeviceNet Personal
Computer Interface

Publication 2755-6.8.1
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Cut, Copy, and Paste

You can now cut, copy, and paste some items within and between
database files:

* projects

* Reader configurations
* match fields

* message fields

* labels

* label fields

The cut, copy, and paste icons and menu selections will only be
available where they can be used. Otherwise the icons will appear
grayed out.

Important: Cutting or copying and then pasting a Reader
configuration is different from importing/exporting Reader
configurations.

When an individual Reader configuration is pasted into a project,
only the original Reader’s configuration dialog boxes are copied and
recreated in the new project. Connections to and from the original
configuration are not recreated using Paste. If you use
import/export, the connections to the original module are maintained.
Paste is useful when you need to make a configuration similar to an
existing configuration in the currently open project or another
project.

When you need to make an exact copy of a configuration, copy and
paste the entire project in the AdaptaScan database dialog or use the
import/export functions (see next page).

Publication 2755-6.8.1
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Import/Export Configurations

You can now import/export configurations. Using the import/export
functions you can transfer exact copies of Reader configurations
between projects. The imported/exported configurations maintain
the internal and external connections.

1. Open the project you want to import the configuration file into.

2. From therile menu, seledmport. The Import Configuration
dialog is displayed.

Lk [ s =] QQF!‘
Fanse (B Do Feads 1ok I| Lpar |
Fleelime  ||CcongFies " el = Consel |

3. Enter the path>filename of the Reader configuration you want to
import (.cfg file).

4. Click Opento import the Reader configuration into the project.
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Go On-Line

i

Online Functionality

There is now an online function. The Go On-Line command
establishes communications between the AdaptaScan software and
the reader or DeviceNet network using the communication channel
specified on the Preferences dialog. To go on-line with AdaptaScan

software:

1. Click the Go On-Line icon or seleGb On-Line from the

Communicationsmenu.

The project window will display the devices on the network along
with their catalog no. and address.

Note: The Query dialog may be displayed when you go on-line
(depending on your preference settings).

Note: If you are connected to the DeviceNet network using the
Reader configuration cable, only AdaptaScan Readers on the
network are identified and displayed. When connecting using a
DeviceNet communications card and driver software on your
computer, all DeviceNet nodes on the network are identified and
displayed.

2. Highlight individual readers in the list to display the currently

loaded firmware revision and their configuration status.
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When going on-line:

You can only be on-line with one project at a time. Uséahe
Off-Line command (Communications menu) when you want to
switch to another project.

Upload, Download, Monitor andCompare functions are only
available for AdaptaScan Readers having the same major version
number as the AdaptaScan software (firmware version 11.x or
greater)

TheFirmware button, for downloading firmware to a Reader, is
only available when the communications channel is set for
Configuration Port (direct connection using configuration cable).

UseRefresh (Communications menu) to query the network and
update the display.

UseQuery (View menu) to display the Query dialog. The Query
dialog allows you to specify the network addresses read when
on-line functions are used. By only checking the addresses that
are required, you can increase the speed at which network
operations occur.
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Go On-Line E

Compare @t@

Compare Tool

The Compare Tool compares the calculated Cyclic Redundancy
Check (CRC) of the configuration stored in the project database with
the CRC of the configuration stored in the Reader. Compare is
useful when checking if a Reader’s configuration has been changed
to determine if an upload or download is necessary.

Note: Compare is not available if you are using peer-to-peer
connections (data, triggers, or I/0 shared between Readers). In
addition, cut and copied Reader configurations between projects may
not match when compared due to differences in the label
configurations between projects.

To use compare:

1. Make sure the software is on-line by clicking the Go On-Line
icon or by selectingso On-Line from theCommunications
menu.

Note: The Query dialog may be displayed when you go on-line
(depending on your preference settings).

2. Select the Reader configuration you want to compare with the
actual configuration stored within the Reader.

3. Click the Compare tool icon or selgebmpare from the
Communications menu.

/ \

Connection Icon Database Icon

If the Reader configuration has been compared and does not match
the configuration stored in the Reader, the connection icon appears
red.

If the Reader configuration has been compared and matches the
configuration stored in the Reader, the database and connection icons
appear green.

If a Reader configuration has not been compared to the configuration
stored in a Reader, the database and connection icons appear yellow.

Publication 2755-6.8.1
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Message Format

The Message Format dialog box has changed. You now have Swap
and Pad check box and Handshaking enabled or disabled

=] Project 1 - e Code Aesder 1 - Messange |
ootz G ]
Bew.. :—I
[ o | [ romn | )
Header: Source D:
\h I
I Cancel |
1 B Trailer:
e Hy
S " Swap and Pad
I E il I ﬂl
F"ﬂ— — Field Defiriter ~ Include
Nai Codls Flaomdai 1 .
|44 (0255, 44] V¥ Field Data [™ Scan Count
|I-[lm-u-Jr-|' ¥ Disable Courter
5 ol i [ of | — I Incjude
= Bad . —Meszage Destination————— Biawfiaes
 Dereate ——— ]
[¥ | Handshaking —
& Serial Part St J
IEar Code Reader 1 j I
Current beszage Size: 2

Swap and Pad

When selected, high and low data bytes swap positions. Select swap
bytes when data is sent in the wrong order (high byte first). For
example, data to a PIEOs sent with the first character of a string in

the second byte. By swapping the bytes, the first character
corresponds to the first byte. When selected, uneven numbered data
is padded with a zero so that messages always contain an even
number of bits.

Handshaking

When selected, allows the PLC or SLGo use bits in the
DeviceNet assembly objects to control the transfer of message data.
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Chapter 9 -
Communicating with an
SLC 5/03™ Processor on a
DeviceNet™ Network

The AdaptaScan operates in either polled mode or change of state
modes for version 11.x and higher. UnderConfigure the
1747-SDN DeviceNet Scanngthe sequence is:

6. Click the Edit /O Parameters button.

Edit Device 1/0 Parameters

r— Strobed
" Enablg

Strobed Size:

Rz Tx

ID— lu— Buytes

— Polled
[~ Enable

— Change of State/Cyclic

Palled Size:
Fall Bate:

R= T=
IU—IU— Bytes

Ewvem Scan

™ Enable

140 Size:

% Charge of State

) Cuclic:

ID— ID— Bytes

MSEc

[-]

Heartheat Fate: 250

Setto EDS Defaul |

o]

For the AdaptaScan to operate in Polled mode:

Cancel |
Help |

* Under Polled, check the enable box. Change of State/Cyclic
Enable box should not be checked.

* Change the Poll Size Rx box&dBytes).

* Change the Poll Size Tx box 1dBytes).

* In the Poll Rate List box, seleEvery Scan

For the AdaptaScan to operate in Change of State mode:

* Under Change of State/Cyclic, check the enable box. Polled
Enabled should not be checked.

* Select Change of State

* Change the Poll Size Rx box8dBytes).
* Change the Poll Size Tx box 1qBytes).

7. Click the OK button to return to the Scan List Editor button.

Continue with the remaining steps of the section to configure the

1747-SDN DeviceNet scanner.

Publication 2755-6.8.1
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Chapter 10 - Explicit messaging for AdaptaScan using firmware version 11.x has
Communicating with an changed. The data packet from the SLC (or PLC) has an additional
SLC 5/03 Processor on a word which must be included.

DeviceNet Network using
Explicit Messaging

Address
N20:0

UnderOverview, the AdaptaScan bar code reader is on node 10, not
node 3.

UnderDefine the DeviceNet Addresshe address is 10, not 3.

Refer toExplicit Message Program Control Limitations to find
the explanation of the Service Name, Service Code, and Example.

UnderExample Data Tables response file should be:

Address  Response File (good response)
N25:0 0101 000C 900C

Also, the explicit message is written in the N20:0 integer address.

Data = Hex Code (matchcode download of 0300 data)
0101 0012 100A 000F 0001 0001 1008 01CE 0300 0004 3330 3030

(0300 = Byte swap only for the data 33303030.)

Publication 2755-6.8.1
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The table below provides the data packets and their descriptions.

Packet | Description

TXID. The reader uses this value to track the transaction to completion and
01 returns the value to with the response that matches the request downloaded
by the processor.

CMD/Status. For each download, you assign a command code to instruct the

01 reader how to administer the request.
00 Port. The DeviceNet port where the transaction is routed.
Size. The size of the transaction body in bytes (0CH=12 bytes). The
12 transaction body can be as many as 29 words (58 bytes) in length. If the size

exceeds 29 words, an error code will be returned.

Service. For each explicit message request and response, the service
10 attribute contains the service request and response codes that match the
corresponding request for the TXID.

Mac ID (node address). The DeviceNet network allows a node range of

0A 0-63.

00 Parameter Class

OF Parameter Class

00 Instance Number (MSB)

01 Instance Number (LSB)

00 Attribute (MSB)

01 Attribute (LSB)

10 Set Attribute Single Request (MSB)

OB Length [The byte size count begins the Set Attributes Single request (MSB)]
10 Set Attribute Single Request (MSB)

CE (206) | Class (MSB)

03 Attribute Number — Rule (MSB)

00 Instance Number (LSB)

00 Length of String (MSB)

04 Length of String (LSB) being downloaded.
33 ASCII 33

30 ASCII 30

30 ASCII 30

30 ASCII 30

The response of the 0101 900C response code is 90 for successful
and 94 for fail.

A response code will not be sent out. Once the download is
complete the LEDs on the AdaptaScan will turn off and on,
indicating a reset was performed. After the Execute this Transaction
Block CMD Status (01) is sent, use a Reset all Client/Server
Transaction Command Code (03) to perform the next download
transaction.

UnderNotes on using Explicit Messaginggxplicit messaging must
always start at word 224 (i.e., M0:1.224) if using an SLC processor
(PLC on word 64).

Publication 2755-6.8.1
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UnderDownloading Other Host Commandsthe tables are:

Read Performance Indicator Command Read Performance Indicator Response
Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF Data (LSB) 01
Instance 01 Data (MSB) 00
Attribute 01
Length 04
Get Performance Request 4C
Class C8
Instance Number (LSB) 01
Instance Number (MSB) 00

*3F = Address 63, modify as required

Reset Package Counter Command Reset Package Counter Response
Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF
Instance 01
Attribute 01
Length 06
Class D2
Set Attribute Single Request 10
Instance Number (LSB) 00
Instance Number (MSB) 00
Attribute Number— 09
Reset Counters
Data 01

*3F = Address 63, modify as required

Publication 2755-6.8.1
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Read Match Counters Command

Read Match Counters Response

Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF Data (LSB) 00
Instance 01 Data 00
Attribute 01 Data 00
Length 05 Data (MSB) 00
Get Attribute Single Request 0E
Class CE
Instance Number (LSB) 01
Instance Number (MSB) 00
Attribute Number 08

*3F = Address 63, modify as required

Read Package Counters Command

Read Package Counters Response

Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF Data (LSB) 00
Instance 01 Data 00
Attribute 01 Data 00
Length 05 Data (MSB) 00
Get Attribute Single Request 0E
Class D2
Instance Number (LSB) 01
Instance Number (MSB) 00
Attribute Number— 08

Match Count

*3F = Address 63, modify as required

Reset Match Counters Command

Reset Match Counters Response

Packet Contents Response
DeviceNet Address 3F
Set Attribute Single Response 20

Packet Contents Data Sent
Response Codes 3F*
Set Attribute Single Request 10
Parameter Class OF
Instance 01
Attribute 01
Length 06
Get Attribute Single Request 10
Class CE
Instance Number (LSB) 00
Instance Number (MSB) 00
Attribute Number- 0B

Reset Counters

Data 01

*3F = Address 63, modify as required

Publication 2755-6.8.1
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Read Message Command

Read Message Response

Packet Contents Response
DeviceNet Address 3R
Set Attribute Single Response 90
String Length (LSB) 04
String Length (MSB) 00
ASCII Message Data 30%*
ASCII Message Data 32
ASCII Message Data 30
ASCII Message Data 30

Packet Contents Data Sent
DeviceNet Address 3
Set Attribute Single Request 10
Parameter Class OF
Instance 01
Attribute 01
Length 05
Get Attribute Single Request 0E
Class cC
Instance Number (LSB) 00
Instance Number (MSB) 00
Attribute Number - Message 14

*3F = Address 63, modify as required

Read LED Status Command

*3F = Address 63, modify as required

** Example data = 0200

Read LED Status Response

Packet Contents Data Sent
DeviceNet Address 3F*
Set Attribute Single Request 10
Parameter Class OF
Instance 01
Attribute 01
Length 04
Read LEDS Request 43
Class CB
Instance Number (LSB) 01
Instance Number (MSB) 00

Packet Contents Response
DeviceNet Address 3F
Set Attribute Single Response 90
101 See Table Next Page
1102 See Table Next Page
Trigger / Read See Table Next Page
On Symbol See Table Next Page
Laser On See Table Next Page
Module See Table Next Page
Network See Table Next Page

*3F = Address 63, modify as required

Set Output Timer Command

Set Output Timer Response

Packet Contents Response
DeviceNet Address 3F
Set Attribute Response 90

Packet Contents Data Sent
DeviceNet Address 3
Set Attribute Single Request 10
Parameter Class OF
Instance 01
Attribute 01
Length 07
Set Attribute Single Request 10
Class DO
Instance Number (LSB) 02
Instance Number (MSB) 00
Attribute Number - Max Time 09
Data (LSB) FA
Data (MSB) 00

*3F = Address 63, modify as required

** Time in milliseconds

Publication 2755-6.8.1
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Set Match Code Command Set Match Code Response
Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Response 90
Parameter Class OF
Instance 01
Attribute 01
Length 0B
Set Attribute Single Request 10
Class CE
Instance Number (LSB) 01
Instance Number (MSB) 00
Attribute Number 03
String Length (LSB) 04
String Length (MSB) 00
ASCII Character 0 30*
ASCII Character 3 33
ASCII Character 0 30
ASCII Character 0 30
*3F = Address 63, modify as required
** Example data = 0300
LED Status Response
Data at Indicated Bit Address = LED State
4=Not | 5=Flash | 6=Flash | 7=Flash
. . 0=0ff |1=VYellow | 2=Green | 3=Red
Byte Bits LED Indicator W Used Yellow Green Red
0-2 1101 OFF ON
0
35 1102 OFF ON
No . Valid
0-2 TRIGGER / READ Trigger Triggered Read
1
Not Read- . Read
35 ON SYMBOL ing Reading <100%
0-2 LASER ON OFF ON
2 Device | Hardware Minor
35 MODULE No Power oK Fault Power Up Fault
DeviceNet | DeviceNet Estab- No
3 0-2 NETWORK OK Fault lished | Response
35

Publication 2755-6.8.1
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Chapter 11- _ The AdaptaScan operates in either Polled or Change of State modes
Communicating with a for version 11.x or higher. Und&o Configure the 1771-SDN
PLC-5" Processor on a DeviceNet Scannegrthe sequence is:

DeviceNet Network 8. For the AdaptaScan to operate in Polled mode, edit the following

parameters in the Edit Device I/O Parameters dialog:

* Under Polled, check the enable box. Change of State/Cyclic
Enable box should not be checked.

* In the Poll Rx Size box, typ&(Bytes).
* Inthe Poll Tx Size box, typé (Bytes).
* From the Poll Rate list box, seldevery Scan

The dialog should look like this:

=ryabed P
I Erasbin Ax
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Change ol Stare poic E Eosiy -
FEnge -~ Peall . I Ewamp S I
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=
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For the AdaptaScan to operate in Change of State mode:

* UnderChange of State/Cycli¢check the enable box. Polled
Enabled should not be checked.

* SelectChange of State
* Change the Poll Size Rx box&dBytes).
* Change the Poll Size Tx box 1qBytes).

Continue with the remaining steps of the section to configure the
1771-SDN DeviceNet scanner.

Publication 2755-6.8.1
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Chapter 12 -
Communicating with a
PLC-5 Processor on a
DeviceNet Network using
Explicit Messaging

Explicit messaging for AdaptaScan using firmware version 11.x has
changed. The data packet from the PLC (or SLC) has an additional
word which must be included.

UnderOverview, the AdaptaScan bar code reader is on node 10, not
node 3.

UnderDefine the DeviceNet Addresshe address is 10, not 3.

Refer toExplicit Message Program Control Limitations to find
the explanation of the Service Name, Service Code, and Example.

UnderExample Data Tables response file should be:

Address  Response File (good response)
N25:0 0101 000C 900C

Also, the explicit message is written in the N20:0 integer address.

Address Data = Hex Code (matchcode download of 0300 data)

N20:0 0101 0012 100A

000F 0001 0001 100B 01CE 0300 0004 3330 3030

(0300 = Byte swap only for the data 33303030.)

UnderNotes on using Explicit Messagingexplicit messaging must
always start at word 64 if using an PLC processor (SLC on word
224).

Publication 2755-6.8.1
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The table below provides the data packets and their descriptions.

Packet | Description

TXID. The reader uses this value to track the transaction to completion and

01 returns the value to with the response that matches the request downloaded
by the processor.

01 CMD/Status. For gagh download, you assign a command code to instruct the
reader how to administer the request.

00 Port. The DeviceNet port where the transaction is routed.
Size. The size of the transaction body in bytes (0CH=12 bytes). The

12 transaction body can be as many as 29 words (58 bytes) in length. If the size
exceeds 29 words, an error code will be returned.
Service. For each explicit message request and response, the service

10 attribute contains the service request and response codes that match the
corresponding request for the TXID.

0A Mac ID (node address). The DeviceNet network allows a node range of
0-63.

00 Parameter Class

OF Parameter Class

00 Instance Number (MSB)

01 Instance Number (LSB)

00 Attribute (MSB)

01 Attribute (LSB)

10 Set Attribute Single Request (MSB)

OB Length [The byte size count begins the Set Attributes Single request (MSB)]

10 Set Attribute Single Request (MSB)

CE (206) | Class (MSB)

03 Attribute Number — Rule (MSB)

00 Instance Number (LSB)

00 Length of String (MSB)

04 Length of String (LSB) being downloaded.

33 ASCII 33

30 ASCII 30

30 ASCII 30

30 ASCII 30

The response of the 0101 900C response code is 90 for successful

and 94 for fail.

A response code will not be sent out. Once the download is
complete the LEDs on the AdaptaScan will turn off and on,

indicating a reset was performed. After the Execute this Transaction

Block CMD Status (01) is sent, use a Reset all Client/Server
Transaction Command Code (03) to perform the next download
transaction.
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UnderDownloading Other Host Commandsthe tables are:

Read Performance Indicator Command Read Performance Indicator Response
Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF Data (LSB) 01
Instance 01 Data (MSB) 00
Attribute 01
Length 04
Get Performance Request 4C
Class C8
Instance Number (LSB) 01
Instance Number (MSB) 00

*3F = Address 63, modify as required

Reset Package Counter Command Reset Package Counter Response
Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF
Instance 01
Attribute 01
Length 06
Class D2
Set Attribute Single Request 10
Instance Number (LSB) 00
Instance Number (MSB) 00
Attribute Number— 09
Reset Counters
Data 01

*3F = Address 63, modify as required

Publication 2755-6.8.1



24 AdaptaScan™ Bar Code Readers Application Guide

Read Match Counters Command Read Match Counters Response
Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF Data (LSB) 00
Instance 01 Data 00
Attribute 01 Data 00
Length 05 Data (MSB) 00
Get Attribute Single Request 0E
Class CE
Instance Number (LSB) 01
Instance Number (MSB) 00
Attribute Number 08

*3F = Address 63, modify as required

Read Package Counters Command Read Package Counters Response
Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF Data (LSB) 00
Instance 01 Data 00
Attribute 01 Data 00
Length 05 Data (MSB) 00
Get Attribute Single Request 0E
Class D2
Instance Number (LSB) 01
Instance Number (MSB) 00
Attribute Number— 08
Match Count

*3F = Address 63, modify as required

Reset Match Counters Command Reset Match Counters Response
Packet Contents Data Sent Packet Contents Response
Response Codes 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF
Instance 01
Attribute 01
Length 06
Get Attribute Single Request 10
Class CE
Instance Number (LSB) 00
Instance Number (MSB) 00
Attribute Number- 0B
Reset Counters
Data 01

*3F = Address 63, modify as required
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Read Message Command

Read Message Response

Packet Contents Response
DeviceNet Address 3F
Set Attribute Single Response 90
String Length (LSB) 04
String Length (MSB) 00
ASCII Message Data 30*
ASCII Message Data 32
ASCII Message Data 30
ASCII Message Data 30

* Example data = 0200

Packet Contents Data Sent
DeviceNet Address 3
Set Attribute Single Request 10
Parameter Class OF
Instance 01
Attribute 01
Length 05
Get Attribute Single Request 0E
Class cC
Instance Number (LSB) 00
Instance Number (MSB) 00
Attribute Number - Message 14

*3F = Address 63, modify as required

Read LED Status Command

Read LED Status Response

Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Single Response 90
Parameter Class OF 101 See Table Next Page
Instance 01 110 2 See Table Next Page
Attribute 01 Trigger / Read See Table Next Page
Length 04 On Symbol See Table Next Page
Read LEDS Request 43 Laser On See Table Next Page
Class CB Module See Table Next Page
Instance Number (LSB) 01 Network See Table Next Page
Instance Number (MSB) 00

*3F = Address 63, modify as required

Set Output Timer Command

Set Output Timer Response

Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Response 90
Parameter Class OF
Instance 01
Attribute 01
Length 07
Set Attribute Single Request 10
Class DO
Instance Number (LSB) 02
Instance Number (MSB) 00
Attribute Number - Max Time 09
Data (LSB) FA
Data (MSB) 00

*3F = Address 63, modify as required
** Time in milliseconds
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Set Match Code Command Set Match Code Response
Packet Contents Data Sent Packet Contents Response
DeviceNet Address 3F* DeviceNet Address 3F
Set Attribute Single Request 10 Set Attribute Response 90
Parameter Class OF
Instance 01
Attribute 01
Length 0B
Set Attribute Single Request 10
Class CE
Instance Number (LSB) 01
Instance Number (MSB) 00
Attribute Number 03
String Length (LSB) 04
String Length (MSB) 00
ASCII Character 0 30**
ASCII Character 3 33
ASCII Character 0 30
ASCII Character 0 30
*3F = Address 63, modify as required
** Example data = 0300
LED Status Response
Data at Indicated Bit Address = LED State
4=Not | 5=Flash | 6=Flash | 7="Flash
. . 0=0ff |1=Yellow | 2=Creen | 3=Red
Byte Bits LED Indicator W Used Yellow Green Red
0-2 101 OFF ON
0
35 I/0 2 OFF ON
No . Valid
0-2 TRIGGER / READ Trigger Triggered Read
1
Not Read- . Read
3-5 ON SYMBOL ing Reading <100%
0-2 LASER ON OFF ON
2 Device | Hardware Minor
3-5 MODULE No Power oK Fault Power Up Fault
DeviceNet | DeviceNet Estab- No
3 02 NETWORK oK Fault lished | Response
35
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Chapter 17 -
Communicating with
PanelView 900 ™

Terminals on a DeviceNet

Network

PanelView 900

UnderAdaptaScan Application, the sections are:

This application provides an example of using explicit-client
messages to monitor decoded bar code data and change attributes of
an AdaptaScan Bar Code Reader. The AdaptaScan is connected
directly to the PanelView.

Power Supply
(Catalog No. 2755-PW46)

=

AdaptaScan Reader

The DeviceNet network must be supplied with power. In this
application, you can use the AdaptaScan power supply (Catalog No.
2755-PW46). The power supplies used with DeviceNet are sized to
the number of devices and DeviceNet cable lengths. Review your
DeviceNet literature for DeviceNet network configuration data.

Note: AdaptaScan software version 11.x or later with reader
firmware 11.x or later is required to run this application.

Connections

The PanelView connects directly to the DeviceNet terminal block in
the AdaptaScan wiring base. Refer to Publication No. 2755-837 for
DeviceNet and power supply connections.
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PanelView Screen

The following shows how the PanelView screen appears in
PanelBuildef’ (Catalog No. 2711-ND3). You will need to create
this screen for your application.

In this application, the PanelView terminal:

displays decoded bar code data and package count from the
AdaptaScan Reader

resets the package count



AdaptaScan™ Bar Code Readers Application Guide 29

Read Bar Code Data and Package Count Tag Configuration

The dialog box for the bar code display object is shown below. The
display is configured as a8ClI string with an embedded variable

(bar code data) and package count. The Field Width is set to 24
characters and is based on the expected maximum bar code data
length in characters plus 10 character package count. The tag name
is Bar_Code_ Data.

A i
Fraadmr |

T e b i
e 3
i il et

et 3

Ml 1 e
[Ra_Cada_Diats 3

R

By selecting the Edit Tag option, you can edit the tag data as shown
below.

Tag Form - P¥_Adapt_Demo
Tag Name: Data Type:
IBal_Code_Dala Character Array j

Cancel |
M ing T ™ Swap Bytes
essaging Type Class:
Load from EDS... | I—
140 Slave Mode Address: Packet B 3 I4 :
@0 Tt ety Hode ress: 2:c_el yies: nstance;
= Explicit - Client | - 2
. Bit Dffset: Attribute:
[~ Write Tag 16
3
Description:
Peer tag that will read Bar Code data from an Adaptascan Bar Code reader. -
¥
Tag Initial ¥alue: Amay Size:
[ 2

The tag data type is “Character Array”. Itis an explicit-client read
message with the Class, Instance and Attribute values as shown. To
read bar code data and package count, the bit offset must be set to
16. The offset is necessary since the first two bytes represent the
length of the requested data.
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Publication 2755-6.8.1

AdaptaScan Configuration

The AdaptaScan Reader must be configured to make data available
for the PanelView terminal. You must configure the AdaptaScan
Reader for the bar code symbology being read, the number of bar
codes, scan pattern and triggering as you would for any other
application. Refer to Publication No. 2755-838 for information
regarding the basic set up of the AdaptaScan Bar Code Reader. The
following sections only provide the information necessary to make
the data available for the PanelView terminal.

Making Bar Code Data Available

To make the bar code data available on DeviceNet, the AdaptaScan
Bar Code Reader must be configured to make the data available.
The two dialog screens shown below set up a message field that
contains the bar code data. See Publication No. 2755-838. The
fields containing Symbol 1, Symbol 2, Symbol 3, define three bar
code types configured for the AdaptaScan Reader.
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Making Package Counter Data Available

Package counter data must be made available to the PanelView
terminal by setting up an unconditional match in the AdaptaScan Bar
Code Reader. The figure below shows the two dialog boxes that
need to be modified.

!

eszage Format

Header: Source D
I Cancel |
Trailer:
I [T Swap and Pad Help |
— Eield Delirmter — Include

|44 [0-255, 44] ¥ Field Data [ Scan Count

¥ Disable — Counter

V¥ Include

—Mezzage Destination D evice:

& DeviceNet Bar Code Readerl
[ Handshaking
: Counter:
" Serial Port

j IF'au:kage 1 j

I Bar Code Reader1l

Cument Meszage Size: 12
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Chapter 18 — Using DH485
in Slave Mode with an SLC
5/03 or SLC 5/04™
Controller

Hardware Requirements

Software Requirements

Related Publications

Publication 2755-6.8.1

This application describes how to set up the AdaptaScan bar code
reader from an SLC 5/03 or SLC 5/04 controller using DH485
protocol in slave mode.

DH485 Master is used for bar code data traveling at medium or slow
speeds. Data is sent to the SLC 5/03 or SLC 5/04 controller whether
it was requested or not by the SLC 5/03 or SLC 5/04 controller.

DHA485 Slave is used for bar code data traveling at high speeds. The
SLC 5/03 or SLC 5/04 controller initiates the request for bar code
data.

Refer to chapter 3 for a listing of additional host commands and
response codes.

The hardware items required for this application are:

e 2755-SN3, -SN5, or -SN8 AdaptaScan Bar Code Reader

e 2755-PW46 or -PW47 Power Supply

e 2755-NC43 or -NC48 Configuration Cable

e 2755-NB40 or -NB41 Wiring Base (Ser. A/Rev. B or higher)
e 1747-1.532, -L541, -1L.542, or -L543 SLC Processor

e 1746-A4, -A7, -10, or -A13 Chassis

e 1746-P3 Power Supply

e 1747-CP3 RS-232 Programming Cable

e 1747-AIC Isolated Link Coupler or 1761-NET-AIC Advanced
Interface Converter

e 1747-PIC RS-232/DH-485 Converter
e Computer running Windows 3.1 (or later) or Windows"95
* 9-t0-25 Pin Adapter (for computers with a 25-pin COM port)

The software requirements for this application are:
e 2755-ASN AdaptaScan Offline Programming Software

e 9323-PA2E Advanced Programming Software. (The original
ICOM SLC software is not compatible with this AdaptaScan
network.)

Related publications include:

Publication Description

2755-837 AdaptaScan Bar Code Readers User Manual

2755-838 AdaptaScan Software User Manual

1747-6.2 SLC 5QOW Modular Hardware Style Installation and
Operation Manual

9399-APSUM-11.15.95 Advanced Programming Software User Manual
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Connecting a Power
Supply to the Reader

Connecting to the DH-485
Network

The following illustration shows how to connect a 2755-PW46 or
-PW47 power supply to a single bar code reader.

Use a shielded cable (Belden 9316 recommended) to make the
connections. Connect the shield to the ground screw on the reader’s
wiring base.

2755-PW46
Power Supply Reader

V+

@ Ve

L .24+ N

C_H
ISHO
C_L|

o
CHONONCHY)

I

©
(&sH
©
©

7 —= Ground Screw
on Wiring Base

The wiring base of the AdaptaScan Reader has an RS-485/RS-422
terminal block for point-to-point or network connections.

This section shows three connection options:

* Connecting readers to SLC 5/03

* Connecting readers to SLC 5/04 using two 1747-AIC Modules
* Connecting readers to SLC 5/04 using one 1747-AlC Module

Note: You can use the 1761-NET-AIC Advanced Interface
Converter in place of the 1747-AIC Module.

Important. The DH485 network cable requires proper shielding,
grounding and termination. Refer to Data
Highway/Data Highway Plus/Data Highway DH485
Cable Installation Manual (Publication 1770-6.2.2).

Important:  When setting up a DH-485 network using an
AdaptaScan, make sure that the nodes on the network
are in sequential order. The SLC 5/03 or 5/04 should be
Node 1, and AdaptaScan should be Node 2, and each
node after that should be 3, 4, and so forth. If other
DH-485 nodes are needed (i.e. DTAM, etc...), the
AdaptaScan node number(s) must be first. Node gaps
must be avoided in order to prevent the AdaptaScan
from Soliciting of Successor (SOS). By preventing
SOS, bar code throughput is maximized as it is sent to
the SLC. In other words, when setting up the
AdaptaScan via DH-485 the first priority is to process
bar code data instead of finding node gaps.
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Connecting Readers to SLC 5/03 Controller

You must use a link coupler if the distance between the reader and
the SLC is greater than 15.2 meters (50 feet). The reader can
connect directly to another RS-485/RS-422 device. Point-to-point
and network connections are the same.

The end devices on the DH-485 network must be terminated. The
wiring base of the AdaptaScan Reader provides a termination switch.

AdaptaScan Wiring Base
RS-422/RS-485 Terminal

— —

RS-485/422 T e /@J : H@E@ @EFH / @\)

RS-485/422 ﬂ] 16/ @ Jd._ @ SLC 5/03 Processor
RS-422 el R N 0
RS-422 Y emem "B | e | |

|]:| RXB@ ﬁ% Power 0
[Dheel @ g
Ground ﬂj NS - @H {% Supply g
Shield == ) i
[ Jsoe u g |-
Termination Switch / |
1747-AIC Module ‘.
Term :
A 1
B
Com "
Shield ,
Chassis Gnd , Computer
f] )

1747-PIC ;
2755-ASN AdaptaScan Software

SLC 500 Advanced Programming Software
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Connecting Readers to SLC 5/04 Controller — 2 AIC Modules

The SLC 5/04 controller requires two 1747-PIC converters and a
power supply to connect to the second 1747-AlC module.

The end devices on a DH-485 network must be terminated. The
wiring base of the AdaptaScan Reader provides a termination switch.

SLC 5/04 Processor
[8)
power || o0 | B66R || B9 BERE
Supply [
Channel 0 A
| RS-232
. [] 1747-PIC
! AdaptaScan Wiring Base
| RS-422/RS-485 Terminal
' DH-485
| 1747-AIC Module
' _E TXA @ TN o n TN
' ‘O) q o (O
' s S ) o &
| O
\ Chassis G g e
. RxB|S)
\ : W\ [D
' D ﬂ] GNIED)
[sde )
1747-AIC Module
Term
5 1747-P4 The 1747-P4 Power Supply provides
C?_ml 24V dc Power Supply power to both 1747-AIC modules (1 AMP,
Shield 24V dc). Otherwise use 2 power supplies.
Chassis Gnd
f
|:| L ‘ Computer
1747-PIC
DH-485 ’—‘ RS-232 :gj
L]
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Connecting Readers to SLC 5/04 Controller — 1 AIC Module

The SLC 5/04 controller requires two 1747-PIC converters.
However, you can use an RJ48 Y adapter (8-wire LAN phone jack
plug) to connect the two 1747-PIC modules. The RJ48 Y adapter is
a modular adapter for 4-pair cable which parallels two 4-pair jacks
and one 4-pair modular plug. This adapter eliminates the second
1747-AIC module shown in the previous SLC 5/04 network diagram.

The end devices on a DH-485 network must be terminated. The
wiring base of the AdaptaScan Reader provides a termination switch.

SLC 5/04 Processor

8

B2 g | oot | P

Power |==°

8

Supply

e 0 |=

Channel 0
1

* RS-232

! 1747-PIC

DH-485 1747-AIC

AdaptaScan Wiring Base

3

RJ48 Y Adapter
(8-wire LAN Phone Jack Plug)
Available from Anixter Company
Part No: Hubbell BR851-B
Phone: 414-355-0222
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J
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Configuring Bar Code This section shows how to configure one the AdaptaScan Bar Code
Reader 1 Readers using the AdaptaScan Software (Catalog No. 2755-ASN).
The procedures in this section show how to:
* configure a bar code label and symbol
» define the DeviceNet node address of the AdaptaScan Reader
* configure the scanner
* configure the decoder trigger
* configure the serial port
» configure the format of messages and the message destination
The steps may vary for some procedures because of the different

requirements of applications. For example, the bar code labels may
vary from one application to the next.

Create a New Project

Create a new project named DH485 Setup for the AdaptaScan Bar
Code Readers.

1. Choose New from the Project menu to create a new project.

2. Click the New button to add a bar code reader (Bar Code Reader
1) to the project.

E® Project 3 ME E
Device Connections
=

MNew Monitor I ‘ Firmware___ I
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3. Choose Edit from the Project menu to rename the prbjdd85

Setup.
=
Rncripline —

Dg=cefai Dol Raa
o :_j_l. Amai

4. Click Save to save the project under the new name and then Close
to return to the Project dialog.

Define the Bar Code Label

1. Click the Label button to open the Bar Code Labels dialog.

DH485 Setup - Bar Code Labels E3

—Bar Code Labels

Close I
New... Save |
_lgdil"' Help |
1Enk
Easte |

2. Click the New button to add a label to open the Bar Code Label
dialog.

Bar Code Label E

Label Hame: Symbols Per Scan:
Label 1 | i =06 an. 1

Cancel |
RQuiet Zone R atio:
(1-10, 7] [ Meqative Image Used By... |
r Symbols Symbologies... |

New
Help |
Edit |

[Eat

Easte

3. Click the New button to add a symbol.
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4. Select a symbology and any other parameters (Identifier, Lengths)
required by your application.

Bar Code Label Symbol |
o
Symbol 1] |

Cancel |

Symbology:
|Code 39 = Help |
Identifier:
| | [ Include Identifier

Lengthsz

From: Through:

[ Length 1 (1-64)
[ Length 2 |:| [1-64)
Miength3 [1 | (1-64)

5. Click OK to return to the main Project dialog.

Define the DeviceNet Address

1. Click the Device button to open the Device dialog.

DH485 Setup - Bar Code Reader 1 - Device H= B

Hame:

Bar Code Reader 1 |

Descrnption:

DeviceMet Apply
Address: More. .

[E__Sos

The Baud Rate is 125 K Baud.

Close

Save

14

Help

2. Select a DeviceNet address.

Note: The DeviceNet address is not always the same as the
DH-485 node address. A DH-485 node address is assigned later.

3. Connect the 2755-NC43 or -NC48 cable to the reader.
4. Click the Apply button.

5. Click Save and Close to return to the Project dialog.
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Configure the Scanner

1. Click the Scanner button on the Project dialog to open the
Scanner dialog.

(A ot i G B | e G|
Lave L Farwn Narge Lirshy
1wy el = =8 ﬂ (L]
R

¥ L T Aares

S i [ h
[ |

I g i

T

A

*.en Faimn

2. Configure the scan pattern and use the Focus procedure for
optimum scanner focus. Use the Apply button to send the
scanner configuration to the AdaptaScan.

3. Click the Close button and return to the Project dialog.

Configure the Decoder Trigger

This application uses a Timer to trigger the reader’s decoder. The
Timer is typically used during application setup. Refer to
Publication 2755-837 for other input sources that trigger the decoder.

1. Click the Decoder button from the main Project dialog.

2. Under Triggered By, sele@imer from the Input list.

DHAES Sotep - B Code Resden | Docodn

I:.u-lur_. r.'\..-rl

z Hnamn [ Cee |
u__.- Code Labet Gaws |
Laslssd 1 - (.

[l p— _ M |
[awice

|B-a-| Giaske Aanidsl | ;1_

et — |
= B

3. Click Save and Close to return to the main Project dialog.
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Configure the Serial Port

1. Click the Serial Port button from the Project dialog.

DH485 Setup - Bar Code Reader 1 - Sernal Port M= B3
r Protocol —— Baud Rate:

Fominal o [T save_|
Edi Mazimum Length: —
b
;l D (0-1536.0) | UsedBy...

[ Scanner Protocol

— Parity Data Bits Stop Bits
Help |
% None (el @1
 0dd [OF:] c2 Connection:
© Eyen RS232 ||
—Message Buffer
Warning Al Buffer Size:
[ Enable Warning 56 | |B4 |
Device:
| =
Dutput:

" Enable Pass-Through to DeviceMet

2. Set the parameters as follows:
* From the Protocol list box, selddtH-485
* From the Baud Rate list box, selé&,200
* From the Connection list box, selét5485

The Serial Port must match the host configuration.

3. Click the Edit button to select DH485 Slave Mode.
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DH485 Slave Mode
1. Click the Protocol Edit button in the Serial Port dialog.

DH-485 E
Hode: Master/Slave 0K

O | G O e ;II
Maximum Mode: Cancel

3 7] (0-31) ¥ PCCC Enabled Help |
Destination

Mode: H3:0ffset:

oan [0 Jwszres. o0

2. Edit the parameters as follows:
* Click the PCCC Enabled box

* From the Master/Slave box, sel&tave
* From the Node box, sele2t
This is the DH485 node address.

3. Click OK to return to the main Serial Port dialog.

4. Click Save and Close to return to the main Project dialog.
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Configure for Match Codes

1. Click the Match Table button to open the Match Table dialog.

DH485 Setup - Bar Code Reader 1 - Match Table M= B3
—Match F
Close I
Hew.___
Save |
Eqoo| | (DPacEssen |
Autoload. . |
[Cut
Raste | Used By._. |
Help |
— Triggered By
Device:
|Bal Code Reader 1 j|
Input:
| [Decoder] j|

2. Click the New button to open the Match Function dialog and
create a Match Function.

Match Function
Function: Match Function Name:
atch Entry._ 12 L |

C |
Symbol Source ———— Bar Code Labels & Symbols Ll
Bar Code Reader 1 Label 1 Outputs. . |
LCounter. . |
Help |
Rule:
| | [ Disable
[¥ Match Exactly

3. Under Function, seledflatch Entry.
Match Entry specifies that a match occurs whenever decoded bar
code data matches the Rule: entry.

4. Under Symbol Source, seldsar Code Reader 1

5. Under Bar Code Labels and Symbols, sefehbol 1

6. Click the Match Exactly box.
Match Exactly specifies that ASCII characters are matched
instead of a metacharacter rule.

7. Click the Outputs button to specify which output activates when a
match occurs.
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Match Function Dutput

Available Dutputs: Output To:

Bar Code Reader 1
Discrete Input/Output 1
Dizcrete Input/Output 2
DeviceMet Dutput 1 Add 3>
DeviceMet Dutput 2 —
DeviceMet Dutput 3
DeviceNet Output 4 Bemoye
DeviceMet Dutput 5
DeviceMet Dutput B
DeviceMet Dutput 7
DeviceMet Dutput 8
DeviceMet Dutput 9

OK I Cancel Help

|»

|

8. Under Available Outputs, seleliscrete Input/Output 1.

9. Click the Add>> button to add this selection to
the Output To: area.

10. Click OK to return to the main Match Table dialog.

Configure for a Package

1. Click the Package button to open the Package dialog.

— Package Definitions

119

Cancel |
Edit
Used By... |
[ustput ot~ |
utput Tio Help

:

il

Eazte

— Triggered By

Device:

|Bar Code Reader 1 jl
Input:

| [Decoder] j|

2. Click the new button to create a Package.
3. Under Mode, seledlio-Read or No-Match

This mode is used to determine when a label is not read or does
not match the rule defined in the Match function.
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4. Highlight Match 1 to enable the Match function.

Package
e fne
|Package 1 |
Mode: Cancel |
|N0—Head or Ho-Match j| [ Disable Counter... |
r Dutput At
& End of Trigger & Match Complete Help |

— Match Functions

5. Click OK to return to the main Package dialog.

Configure for an Output

1. Click the Output To button to specify which output activates
when a No-Read or No-Match occurs.

Dulpsic
# wiwlilels (Dl pusl o [t T
FH Lacks Mpsadar 1 -
Doerste inp A0t 1
Dbicavte baguitied pim 7
DevcaM el Uuigul 1 k| I
Dievioticl Dufpd 7
Dpverml ol Numgad 3
Oevratel Quigul 4 ot |
Devmod el Dulged 5
Devcal el Nusgad
Deverntict Ouipul T
D vt el Diggead B
DovecaMel Uugul 9
Devaeslet Dt il k-

[k |  Comes | e |

2. Under available Outputs, seldgiscrete Input/Output 2.

3. Click the Add>> button to add this selection to the
Output To: area.

4. Click OK to return to the main Match Table dialog.
5. Click Save and Close to return to the Project dialog.
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Sending the Configuration From the main Project dialog, click the Download Device button to

to the Reader download the configuration to the bar code reader.

SLC Ladder Logic This section describes how to view match codes in Slave Mode via
ladder logic.

Use the following SLC ladder logic for DH485 Slave Mode if the
AdaptaScan I/0O LEDs cannot be used for viewing.

_ 53[ MSG [(EN) —
0 Read/Write
Type: PEER-TO-PEER —(DN )
Read/Write: READ
Target Device: 485CIF "( EH)
Local/Remote: LOCAL
Control Block: N7:50
Control Block Length: 14

Note: You can only initiate one read or one write at a time. Reads
and writes should never be initiated at the same time.

Message Instruction Configuration
For the Message Instruction, the configuration is listed in the table

below.
Parameter Configuration
Type Peer-to-Peer
Read/Write Read
Target Device 485CIF
Local/Remote Local
Control Block N7:50
Channel 0
Target Node 2
Destination File Access N7:80
255 (Change 255 to 256 or 100H in the third word of the
Taiget Ofse instolon hat the SLC contoter o aking 0 a bt code
device.)
Message Length in Elements | 2
Message Timeout (seconds) |0
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