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(Catalog Numbers 2755-SN3, -SN5, -and -SN8)

This document update revises the following publication.  Keep this
document update for reference.

Publication Description

2755-6.8 AdaptaScan Bar Code Readers Application Guide

The following sections summarize the information contained in this
Document Update.  Changes are presented as those that effect the
entire document or for a specific chapter in the document.

The following provides an update for changes that effect the entire
document.

Application Guide Database File

There is now an Application Guide Database File containing all of
the applications found in the AdaptaScan Bar Code Readers
Application Guide (Publication No. 2755-6.8).  The file is included
as part of the AdaptaScan Installation Files.

File Function

APPGUIDE.DBF Database containing example projects from the 
AdaptaScan Application Guide.

Document Update

Purpose of this Document

Summary of Update

Changes that Effect the
Entire Document
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Project Database Dialog Box

Starting with version 11.x is a new project database dialog box that
allows you to select or create a database file.  You can use this to
help organize your project.  From the Windows� Start menu, select
Programs>AdaptaScan OLP>AdaptaScan OLP.  The database
dialog opens.

You can create multiple database (.DBF) files with different projects.
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Project Dialog Box

There is a new Project dialog box that offers Upload/Download
functionality.

The buttons on the Project window are defined below.

Select: To:

Create a new Bar Code Reader configuration (Bar Code Reader 1, Bar
Code Reader 2, Bar Code Reader 3, ...) in the Project window.

Delete the selected Bar Code Reader configuration from the Project win-
dow.

Define label setups and symbologies for Reader operation.

Define a unique name and enter a description for the Reader.  Also de-
fines a DeviceNet� address for the Reader.

Specify linear or raster scanning, how scanning is triggered, and access
the focus function.

Define when the Reader decodes data and what label is decoded.  Also
defines the inter-symbol timer and performance indicator parameters.

Define the operation for package detector, discrete inputs, discrete out-
puts, timer and ASCII trigger commands.

Define communication parameters (RS-232, RS-485/RS422) and proto-
cols (ASCII, DH-485, DF1) for the Reader’s communication ports.

Define match table, package and counter functions for decoded 
bar code data.

Define the format and content of messages sent to the host after bar
codes are decoded.

Transfer the configuration stored in a Reader to the currently opened
project in the AdaptaScan Software.

Downloads the highlighted configurations to the reader or network.

View the operation of a single Reader or another Reader on the same
network.

Compare the Reader configuration within the project with the on–line
device.

Download new firmware to a selected Reader.
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Toolbar

Version 11.x offers a new toolbar.  Turn the tool bar view on or off
from the View menu.  The tool icons provide shortcuts to the
following menu items:

Move the toolbar to any side of the window or detach the toolbar and
place anywhere on your screen by clicking on and holding down the
mouse key while dragging the toolbar.

Bottom Position

Side WindowDetached

Default Position
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The following provides a brief summary of the AdaptaScan tools.

Tool Icon
or Select 

from menu:
Description

Create New Database File >New
Creates a database file that will contain project configuration
files.

Open Existing Database File >Open
Opens window allowing you to select an existing database file
(.dbf) containing project configuration files.

Open Selected Project Project >Open
Opens the project currently selected in the AdaptaScan
database file window.

Create New Project Project >New
Creates a new project within the currently open database file
(.dbf).

Go On-Line On-Line Tools >Go On-Line Connects the programming computer to the network.

Go Off-Line On-Line Tools >Go Off-Line Disconnects the programming computer from the network.

Upload Selected
Configuration into Project

On-Line Tools >Upload
Uploads the configuration stored in the selected reader to the
current project.

Download Selected
Configurations to Network

On-Line Tools >Download
Downloads the selected Reader configuration(s) to the
Readers on the network.

Open Monitor Window On-Line Tools >Monitor Opens on-line monitor window.

Compare Project
Configuration with 
On-Line Device

On-Line Tools >Compare
Compares the configuration database of the currently selected
Reader to the actual configuration stored within the Reader.

Cut Selection to Clipboard Edit >Cut
Removes the currently selected item from the dialog or
window and places the item on the clipboard.

Copy Selection to Clipboard Edit >Copy
Copies the currently selected item from the dialog or window
and places the copy on the clipboard.

Paste Clipboard Contents Edit >Paste
Pastes the last item placed on the clipboard to the currently
selected location.

Print File >Print
Opens the print dialog that allows you to print out an
application report.

About AdaptaScan Software Help >About Off-Line Programmer
Opens a dialog showing the software revision and serial
numbers along with other software information.

On-Line Context Help Help >Contents
When selected, displays a pointer.  this pointer may be moved
to an area on a dialog or menu and clicked for help about the
item.
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Online Tools

There are new online tools – project window icons.  The project
window status icons display the status of the Reader connections and
configurations.

Connection
Indicates device is on-line Database

Indicates Configuration
is stored in the database

Device Icon
Graphic representing 

the type of device

Connection

When displayed, indicates a connection was made to the device:

• Yellow (default) indicates that the AdaptaScan software does not
have the information required to determine whether the device’s
configuration matches the configuration in the software database.

• Green appears after a Compare operation (see page 11) was
performed and the configuration of the on-line reader matches the
database configuration.

• Red appears after a Compare operation (see page 11) was
performed and the configuration of the on-line reader does not
match the database configuration.

Database

When displayed, indicates that a database configuration exists for the
Reader.  The color indications are the same as for the Connection
icon (see descriptions above).

Device Icon

Displays the icon associated with the device.  Here are some
common device icons:

= AdaptaScan Reader

= SDN Scanner Card

= PhotoEye photo-electric detector

= KFD  DeviceNet Personal 
           Computer Interface
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Cut, Copy, and Paste

You can now cut, copy, and paste some items within and between
database files:

• projects

• Reader configurations

• match fields

• message fields

• labels

• label fields

The cut, copy, and paste icons and menu selections will only be
available where they can be used.  Otherwise the icons will appear
grayed out.

Important:   Cutting or copying and then pasting a Reader
configuration is different from importing/exporting Reader
configurations.

When an individual Reader configuration is pasted into a project,
only the original Reader’s configuration dialog boxes are copied and
recreated in the new project.  Connections to and from the original
configuration are not recreated using Paste.  If you use
import/export, the connections to the original module are maintained.
Paste is useful when you need to make a configuration similar to an
existing configuration in the currently open project or another
project.

When you need to make an exact copy of a configuration, copy and
paste the entire project in the AdaptaScan database dialog or use the
import/export functions (see next page).
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Import/Export Configurations

You can now import/export configurations.  Using the import/export
functions you can transfer exact copies of Reader configurations
between projects.  The imported/exported configurations maintain
the internal and external connections.

1.   Open the project you want to import the configuration file into.

2.   From the File menu, select Import .  The Import Configuration
      dialog is displayed.

3.   Enter the path>filename of the Reader configuration you want to
       import (.cfg file).

4.   Click Open to import the Reader configuration into the project.
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Online Functionality

There is now an online function.  The Go On-Line command
establishes communications between the AdaptaScan software and
the reader or DeviceNet network using the communication channel
specified on the Preferences dialog.  To go on-line with AdaptaScan
software:

1.   Click the Go On-Line icon or select Go On-Line from the 
      Communications menu.

The project window will display the devices on the network along
with their catalog no. and address.

Note:  The Query dialog may be displayed when you go on-line
(depending on your preference settings).

Note:  If you are connected to the DeviceNet network using the
Reader configuration cable, only AdaptaScan Readers on the
network are identified and displayed.  When connecting using a
DeviceNet communications card and driver software on your
computer, all DeviceNet nodes on the network are identified and
displayed.

2.   Highlight individual readers in the list to display the currently
      loaded firmware revision and their configuration status.

Go On-Line
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When going on-line:

• You can only be on-line with one project at a time.  Use the Go
Off-Line  command (Communications menu) when you want to
switch to another project.

• Upload, Download, Monitor  and Compare functions are only
available for AdaptaScan Readers having the same major version
number as the AdaptaScan software (firmware version 11.x or
greater)

• The Firmware  button, for downloading firmware to a Reader, is
only available when the communications channel is set for
Configuration Port (direct connection using configuration cable).

• Use Refresh (Communications menu) to query the network and
update the display.

• Use Query (View menu) to display the Query dialog.  The Query
dialog allows you to specify the network addresses read when
on-line functions are used.  By only checking the addresses that
are required, you can increase the speed at which network
operations occur.
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Compare Tool

The Compare Tool compares the calculated Cyclic Redundancy
Check (CRC) of the configuration stored in the project database with
the CRC of the configuration stored in the Reader.  Compare is
useful when checking if a Reader’s configuration has been changed
to determine if an upload or download is necessary.

Note:  Compare is not available if you are using peer-to-peer
connections (data, triggers, or I/O shared between Readers).  In
addition, cut and copied Reader configurations between projects may
not match when compared due to differences in the label
configurations between projects.

To use compare:

1. Make sure the software is on-line by clicking the Go On-Line
icon or by selecting Go On-Line from the Communications
menu.

Note:  The Query dialog may be displayed when you go on-line
(depending on your preference settings).

2. Select the Reader configuration you want to compare with the
actual configuration stored within the Reader.

3. Click the Compare tool icon or select Compare from the
Communications menu.

Connection Icon Database Icon

If the Reader configuration has been compared and does not match
the configuration stored in the Reader, the connection icon appears
red.

If the Reader configuration has been compared and  matches the
configuration stored in the Reader, the database and connection icons
appear green.

If a Reader configuration has not been compared to the configuration
stored in a Reader, the database and connection icons appear yellow.

Go On-Line

Compare
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Message Format

The Message Format dialog box has changed.  You now have Swap
and Pad check box and Handshaking enabled or disabled

Swap and Pad

When selected, high and low data bytes swap positions.  Select swap
bytes when data is sent in the wrong order (high byte first).  For
example, data to a PLC  is sent with the first character of a string in
the second byte.  By swapping the bytes, the first character
corresponds to the first byte.  When selected, uneven numbered data
is padded with a zero so that messages always contain an even
number of bits.

Handshaking

When selected, allows the PLC or SLC� to use bits in the
DeviceNet assembly objects to control the transfer of message data.
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The AdaptaScan operates in either polled mode or change of state
modes for version 11.x and higher.  Under To Configure the
1747-SDN DeviceNet Scanner, the sequence is:

6.   Click the Edit I/O Parameters button.

For the AdaptaScan to operate in Polled mode:

• Under Polled, check the enable box.  Change of State/Cyclic
Enable box should not be checked.

• Change the Poll Size Rx box to 8 (Bytes).
• Change the Poll Size Tx box to 1 (Bytes).
• In the Poll Rate List box, select Every Scan.

For the AdaptaScan to operate in Change of State mode:

• Under Change of State/Cyclic, check the enable box.  Polled
Enabled should not be checked.

• Select Change of State
• Change the Poll Size Rx box to 8 (Bytes).
• Change the Poll Size Tx box to 1 (Bytes).

7.   Click the OK button to return to the Scan List Editor button.

Continue with the remaining steps of the section to configure the
1747-SDN DeviceNet scanner.

Chapter 9 –
Communicating with an
SLC 5/03� Processor on a
DeviceNet� Network
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Explicit messaging for AdaptaScan using firmware version 11.x has
changed.  The data packet from the SLC (or PLC) has an additional
word which must be included.

Under Overview, the AdaptaScan bar code reader is on node 10, not
node 3.

Under Define the DeviceNet Address, the address is 10, not 3.

Refer to Explicit Message Program Control Limitations to find
the explanation of the Service Name, Service Code, and Example.

Under Example Data Tables, response file should be:

Address Response File (good response)

N25:0 0101 000C 900C

Also, the explicit message is written in the N20:0 integer address.

Address Data = Hex Code (matchcode download of 0300 data)

N20:0 0101 0012 100A 000F 0001 0001 100B 01CE 0300 0004 3330 3030

(0300 = Byte swap only for the data 33303030.)

Chapter 10 –
Communicating with an
SLC 5/03 Processor on a
DeviceNet Network using
Explicit Messaging



15AdaptaScan� Bar Code Readers Application Guide

Publication 2755-6.8.1

The table below provides the data packets and their descriptions.

Packet Description

01
TXID.  The reader uses this value to track the transaction to completion and
returns the value to with the response that matches the request downloaded
by the processor.

01
CMD/Status.  For each download, you assign a command code to instruct the
reader how to administer the request.

00 Port.  The DeviceNet port where the transaction is routed.

12
Size.  The size of the transaction body in bytes (0CH=12 bytes).  The
transaction body can be as many as 29 words (58 bytes) in length.  If the size
exceeds 29 words, an error code will be returned.

10
Service.  For each explicit message request and response, the service
attribute contains the service request and response codes that match the
corresponding request for the TXID.

0A
Mac ID (node address).  The DeviceNet network allows a node range of
0–63.

00 Parameter Class

0F Parameter Class

00 Instance Number (MSB)

01 Instance Number (LSB)

00 Attribute (MSB)

01 Attribute (LSB)

10 Set Attribute Single Request (MSB)

OB Length [The byte size count begins the Set Attributes Single request (MSB)]

10 Set Attribute Single Request (MSB)

CE (206) Class (MSB)

03 Attribute Number – Rule (MSB)

00 Instance Number (LSB)

00 Length of String (MSB)

04 Length of String (LSB) being downloaded.

33 ASCII 33

30 ASCII 30

30 ASCII 30

30 ASCII 30

The response of the 0101 900C response code  is 90 for successful
and 94 for fail.

A response code will not be sent out.  Once the download is
complete the LEDs on the AdaptaScan will turn off and on,
indicating a reset was performed.  After the Execute this Transaction
Block CMD Status (01) is sent, use a Reset all Client/Server
Transaction Command Code (03) to perform the next download
transaction.

Under Notes on using Explicit Messaging, explicit messaging must
always start at word 224 (i.e., M0:1.224) if using an SLC processor
(PLC on word 64).
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Under Downloading Other Host Commands, the tables are:

Read Performance Indicator Command Read Performance Indicator Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F Data (LSB) 01

Instance 01 Data (MSB) 00

Attribute 01

Length 04

Get Performance Request 4C

Class C8

Instance Number (LSB) 01

Instance Number (MSB) 00

*3F = Address 63, modify as required

Reset Package Counter Command Reset Package Counter Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F

Instance 01

Attribute 01

Length 06

Class D2

Set Attribute Single Request 10

Instance Number (LSB) 00

Instance Number (MSB) 00

Attribute Number–
Reset Counters

09

Data 01

*3F = Address 63, modify as required
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Read Match Counters Command Read Match Counters Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F Data (LSB) 00

Instance 01 Data 00

Attribute 01 Data 00

Length 05 Data (MSB) 00

Get Attribute Single Request 0E

Class CE

Instance Number (LSB) 01

Instance Number (MSB) 00

Attribute Number 08

*3F = Address 63, modify as required

Read Package Counters Command Read Package Counters Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F Data (LSB) 00

Instance 01 Data 00

Attribute 01 Data 00

Length 05 Data (MSB) 00

Get Attribute Single Request 0E

Class D2

Instance Number (LSB) 01

Instance Number (MSB) 00

Attribute Number–
Match Count

08

*3F = Address 63, modify as required

Reset Match Counters Command Reset Match Counters Response
Packet Contents Data Sent Packet Contents Response

Response Codes 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F

Instance 01

Attribute 01

Length 06

Get Attribute Single Request 10

Class CE

Instance Number (LSB) 00

Instance Number (MSB) 00

Attribute Number- 
Reset Counters

0B

Data 01

*3F = Address 63, modify as required
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Read Message Command Read Message Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F*

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F String Length (LSB) 04

Instance 01 String Length (MSB) 00

Attribute 01 ASCII Message Data 30**

Length 05 ASCII Message Data 32

Get Attribute Single Request 0E ASCII Message Data 30

Class CC ASCII Message Data 30

Instance Number (LSB) 00 *3F = Address 63, modify as required

Instance Number (MSB) 00 ** Example data = 0200

Attribute Number - Message 14

*3F = Address 63, modify as required

Read LED Status Command Read LED Status Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F I/O 1 See Table Next Page

Instance 01 I/O 2 See Table Next Page

Attribute 01 Trigger / Read See Table Next Page

Length 04 On Symbol See Table Next Page

Read LEDS Request 43 Laser On See Table Next Page

Class CB Module See Table Next Page

Instance Number (LSB) 01 Network See Table Next Page

Instance Number (MSB) 00

*3F = Address 63, modify as required

Set Output Timer Command Set Output Timer Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Response 90

Parameter Class 0F

Instance 01

Attribute 01

Length 07

Set Attribute Single Request 10

Class D0

Instance Number (LSB) 02

Instance Number (MSB) 00

Attribute Number - Max Time 09

Data (LSB) FA

Data (MSB) 00

*3F = Address 63, modify as required
** Time in milliseconds
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Set Match Code Command Set Match Code Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Response 90

Parameter Class 0F

Instance 01

Attribute 01

Length 0B

Set Attribute Single Request 10

Class CE

Instance Number (LSB) 01

Instance Number (MSB) 00

Attribute Number 03

String Length (LSB) 04

String Length (MSB) 00

ASCII Character 0 30**

ASCII Character 3 33

ASCII Character 0 30

ASCII Character 0 30

*3F = Address 63, modify as required
** Example data = 0300

LED Status Response
Data at Indicated Bit Address = LED State

Byte Bits LED Indicator
0 = Off 1 = Yellow 2 = Green 3 = Red 4 = Not

Used
5 = Flash

Yellow
6 = Flash

Green
7 = Flash

Red

0-2 I/O 1 OFF ON
0

3-5 I/O 2 OFF ON

0-2 TRIGGER / READ No 
Trigger

Triggered Valid
Read

1
3-5 ON SYMBOL Not Read-

ing
Reading Read

<100%

0-2 LASER ON OFF ON

2
3-5 MODULE No Power Device

OK
Hardware

Fault
Power Up Minor

Fault

3
0-2 NETWORK DeviceNet

OK
DeviceNet

Fault
Estab-
lished

No 
Response3

3-5
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The AdaptaScan operates in either Polled or Change of State modes
for version 11.x or higher.  Under To Configure the 1771-SDN
DeviceNet Scanner, the sequence is:

8.   For the AdaptaScan to operate in Polled mode, edit the following
     parameters in the Edit Device I/O Parameters dialog:

• Under Polled, check the enable box.  Change of State/Cyclic
Enable box should not be checked.

• In the Poll Rx Size box, type 8 (Bytes).
• In the Poll Tx Size box, type 1 (Bytes).
• From the Poll Rate list box, select Every Scan.

The dialog should look like this:

For the AdaptaScan to operate in Change of State mode:

• Under Change of State/Cyclic, check the enable box.  Polled
Enabled should not be checked.

• Select Change of State
• Change the Poll Size Rx box to 8 (Bytes).
• Change the Poll Size Tx box to 1 (Bytes).

Continue with the remaining steps of the section to configure the
1771-SDN DeviceNet scanner.

Chapter 11 –
Communicating with a
PLC-5  Processor on a
DeviceNet Network
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Explicit messaging for AdaptaScan using firmware version 11.x has
changed.  The data packet from the PLC (or SLC) has an additional
word which must be included.

Under Overview, the AdaptaScan bar code reader is on node 10, not
node 3.

Under Define the DeviceNet Address, the address is 10, not 3.

Refer to Explicit Message Program Control Limitations to find
the explanation of the Service Name, Service Code, and Example.

Under Example Data Tables, response file should be:

Address Response File (good response)

N25:0 0101 000C 900C

Also, the explicit message is written in the N20:0 integer address.

Address Data = Hex Code (matchcode download of 0300 data)

N20:0 0101 0012 100A 000F 0001 0001 100B 01CE 0300 0004 3330 3030

(0300 = Byte swap only for the data 33303030.)

Under Notes on using Explicit Messaging, explicit messaging must
always start at word 64 if using an PLC processor (SLC on word
224).

Chapter 12 –
Communicating with a
PLC-5 Processor on a
DeviceNet Network using
Explicit Messaging
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The table below provides the data packets and their descriptions.

Packet Description

01
TXID.  The reader uses this value to track the transaction to completion and
returns the value to with the response that matches the request downloaded
by the processor.

01
CMD/Status.  For each download, you assign a command code to instruct the
reader how to administer the request.

00 Port.  The DeviceNet port where the transaction is routed.

12
Size.  The size of the transaction body in bytes (0CH=12 bytes).  The
transaction body can be as many as 29 words (58 bytes) in length.  If the size
exceeds 29 words, an error code will be returned.

10
Service.  For each explicit message request and response, the service
attribute contains the service request and response codes that match the
corresponding request for the TXID.

0A
Mac ID (node address).  The DeviceNet network allows a node range of
0–63.

00 Parameter Class

0F Parameter Class

00 Instance Number (MSB)

01 Instance Number (LSB)

00 Attribute (MSB)

01 Attribute (LSB)

10 Set Attribute Single Request (MSB)

OB Length [The byte size count begins the Set Attributes Single request (MSB)]

10 Set Attribute Single Request (MSB)

CE (206) Class (MSB)

03 Attribute Number – Rule (MSB)

00 Instance Number (LSB)

00 Length of String (MSB)

04 Length of String (LSB) being downloaded.

33 ASCII 33

30 ASCII 30

30 ASCII 30

30 ASCII 30

The response of the 0101 900C response code  is 90 for successful
and 94 for fail.

A response code will not be sent out.  Once the download is
complete the LEDs on the AdaptaScan will turn off and on,
indicating a reset was performed.  After the Execute this Transaction
Block CMD Status (01) is sent, use a Reset all Client/Server
Transaction Command Code (03) to perform the next download
transaction.
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Under Downloading Other Host Commands, the tables are:

Read Performance Indicator Command Read Performance Indicator Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F Data (LSB) 01

Instance 01 Data (MSB) 00

Attribute 01

Length 04

Get Performance Request 4C

Class C8

Instance Number (LSB) 01

Instance Number (MSB) 00

*3F = Address 63, modify as required

Reset Package Counter Command Reset Package Counter Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F

Instance 01

Attribute 01

Length 06

Class D2

Set Attribute Single Request 10

Instance Number (LSB) 00

Instance Number (MSB) 00

Attribute Number–
Reset Counters

09

Data 01

*3F = Address 63, modify as required
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Read Match Counters Command Read Match Counters Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F Data (LSB) 00

Instance 01 Data 00

Attribute 01 Data 00

Length 05 Data (MSB) 00

Get Attribute Single Request 0E

Class CE

Instance Number (LSB) 01

Instance Number (MSB) 00

Attribute Number 08

*3F = Address 63, modify as required

Read Package Counters Command Read Package Counters Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F Data (LSB) 00

Instance 01 Data 00

Attribute 01 Data 00

Length 05 Data (MSB) 00

Get Attribute Single Request 0E

Class D2

Instance Number (LSB) 01

Instance Number (MSB) 00

Attribute Number–
Match Count

08

*3F = Address 63, modify as required

Reset Match Counters Command Reset Match Counters Response
Packet Contents Data Sent Packet Contents Response

Response Codes 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F

Instance 01

Attribute 01

Length 06

Get Attribute Single Request 10

Class CE

Instance Number (LSB) 00

Instance Number (MSB) 00

Attribute Number- 
Reset Counters

0B

Data 01

*3F = Address 63, modify as required
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Read Message Command Read Message Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F String Length (LSB) 04

Instance 01 String Length (MSB) 00

Attribute 01 ASCII Message Data 30*

Length 05 ASCII Message Data 32

Get Attribute Single Request 0E ASCII Message Data 30

Class CC ASCII Message Data 30

Instance Number (LSB) 00 * Example data = 0200

Instance Number (MSB) 00

Attribute Number - Message 14

*3F = Address 63, modify as required

Read LED Status Command Read LED Status Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Single Response 90

Parameter Class 0F I/O 1 See Table Next Page

Instance 01 I/O 2 See Table Next Page

Attribute 01 Trigger / Read See Table Next Page

Length 04 On Symbol See Table Next Page

Read LEDS Request 43 Laser On See Table Next Page

Class CB Module See Table Next Page

Instance Number (LSB) 01 Network See Table Next Page

Instance Number (MSB) 00

*3F = Address 63, modify as required

Set Output Timer Command Set Output Timer Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Response 90

Parameter Class 0F

Instance 01

Attribute 01

Length 07

Set Attribute Single Request 10

Class D0

Instance Number (LSB) 02

Instance Number (MSB) 00

Attribute Number - Max Time 09

Data (LSB) FA

Data (MSB) 00

*3F = Address 63, modify as required
** Time in milliseconds
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Set Match Code Command Set Match Code Response
Packet Contents Data Sent Packet Contents Response

DeviceNet Address 3F* DeviceNet Address 3F

Set Attribute Single Request 10 Set Attribute Response 90

Parameter Class 0F

Instance 01

Attribute 01

Length 0B

Set Attribute Single Request 10

Class CE

Instance Number (LSB) 01

Instance Number (MSB) 00

Attribute Number 03

String Length (LSB) 04

String Length (MSB) 00

ASCII Character 0 30**

ASCII Character 3 33

ASCII Character 0 30

ASCII Character 0 30

*3F = Address 63, modify as required
** Example data = 0300

LED Status Response
Data at Indicated Bit Address = LED State

Byte Bits LED Indicator
0 = Off 1 = Yellow 2 = Green 3 = Red 4 = Not

Used
5 = Flash

Yellow
6 = Flash

Green
7 = Flash

Red

0-2 I/O 1 OFF ON
0

3-5 I/O 2 OFF ON

0-2 TRIGGER / READ No 
Trigger

Triggered Valid
Read

1
3-5 ON SYMBOL Not Read-

ing
Reading Read

<100%

0-2 LASER ON OFF ON

2
3-5 MODULE No Power Device

OK
Hardware

Fault
Power Up Minor

Fault

3
0-2 NETWORK DeviceNet

OK
DeviceNet

Fault
Estab-
lished

No 
Response3

3-5
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Under AdaptaScan Application, the sections are:

This application provides an example of using explicit-client
messages to monitor decoded bar code data and change attributes of
an AdaptaScan Bar Code Reader.  The AdaptaScan is connected
directly to the PanelView�.

PanelView 900

AdaptaScan Reader

Power Supply
(Catalog No. 2755-PW46)

The DeviceNet network must be supplied with power.  In this
application, you can use the AdaptaScan power supply (Catalog No.
2755–PW46).  The power supplies used with DeviceNet are sized to
the number of devices and DeviceNet  cable lengths.  Review your
DeviceNet literature for DeviceNet network configuration data.

Note:  AdaptaScan software version 11.x or later with reader
firmware 11.x or later is required to run this application.

Connections

The PanelView connects directly to the DeviceNet terminal block in
the AdaptaScan wiring base.  Refer to Publication No. 2755-837 for
DeviceNet and power supply connections.

Chapter 17 –
Communicating with
PanelView 900�
Terminals on a DeviceNet
Network
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PanelView Screen

The following shows how the PanelView screen appears in
PanelBuilder� (Catalog No. 2711-ND3).  You will need to create
this screen for your application.

In this application, the PanelView terminal:

• displays decoded bar code data and package count from the
AdaptaScan Reader

• resets the package count
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Read Bar Code Data and Package Count Tag Configuration

The dialog box for the bar code display object is shown below.  The
display is configured as an ASCII string with an embedded variable
(bar code data) and package count.  The Field Width is set to 24
characters and is based on the expected maximum bar code data
length in characters plus 10 character package count.  The tag name
is  Bar_Code_Data.

By selecting the Edit Tag option, you can edit the tag data as shown
below.

4

2

3

The tag data type is “Character Array”.  It is an explicit-client read
message with the Class, Instance and Attribute values as shown.  To
read bar code data and package count, the bit offset must be set to
16.  The offset is necessary since the first two bytes represent the
length of the requested data.
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AdaptaScan Configuration

The AdaptaScan Reader must be configured to make data available
for the PanelView terminal.  You must configure the AdaptaScan
Reader for the bar code symbology being read, the number of bar
codes, scan pattern and triggering as you would for any other
application.  Refer to Publication No. 2755-838 for information
regarding the basic set up of the AdaptaScan Bar Code Reader.  The
following sections only provide the information necessary to make
the data available for the PanelView terminal.

Making Bar Code Data Available

To make the bar code data available on DeviceNet, the AdaptaScan
Bar Code Reader must be configured to make the data available.
The two dialog screens shown below set up a message field that
contains the bar code data.  See Publication No. 2755-838.  The
fields containing Symbol 1, Symbol 2, Symbol 3, define three bar
code types configured for the AdaptaScan Reader.
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Making Package Counter Data Available

Package counter data must be made available to the PanelView
terminal by setting up an unconditional match in the AdaptaScan Bar
Code Reader.  The figure below shows the two dialog boxes that
need to be modified.
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This application describes how to set up the AdaptaScan bar code
reader from an SLC 5/03 or SLC 5/04 controller using DH485
protocol in slave mode.

DH485 Master is used for bar code data traveling at medium or slow
speeds.  Data is sent to the SLC 5/03 or SLC 5/04 controller whether
it was requested or not by the SLC 5/03 or SLC 5/04 controller.

DH485 Slave is used for bar code data traveling at high speeds.  The
SLC 5/03 or SLC 5/04 controller initiates the request for bar code
data.

Refer to chapter 3 for a listing of additional host commands and
response codes.

The hardware items required for this application are:

• 2755-SN3, -SN5, or -SN8 AdaptaScan Bar Code Reader

• 2755-PW46 or -PW47 Power Supply

• 2755-NC43 or -NC48 Configuration Cable

• 2755-NB40 or -NB41 Wiring Base (Ser. A/Rev. B or higher)

• 1747-L532, -L541, -L542, or -L543 SLC Processor

• 1746-A4, -A7, -10, or -A13 Chassis

• 1746-P3 Power Supply

• 1747-CP3 RS-232 Programming Cable

• 1747-AIC Isolated Link Coupler or 1761-NET-AIC Advanced
Interface Converter

• 1747-PIC RS-232/DH-485 Converter

• Computer running Windows 3.1 (or later) or Windows 95�

• 9-to-25 Pin Adapter (for computers with a 25-pin COM port)

The software requirements for this application are:

• 2755-ASN AdaptaScan Offline Programming Software

• 9323-PA2E Advanced Programming Software.  (The original
ICOM SLC software is not compatible with this AdaptaScan
network.)

Related publications include:

Publication Description

2755-837 AdaptaScan Bar Code Readers User Manual

2755-838 AdaptaScan Software User Manual

1747-6.2
SLC 500� Modular Hardware Style Installation and
Operation Manual

9399-APSUM-11.15.95 Advanced Programming Software User Manual

Chapter 18 – Using DH485
in Slave Mode with an SLC
5/03 or SLC 5/04�
Controller

Hardware Requirements

Software Requirements

Related Publications
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The following illustration shows how to connect a 2755-PW46 or
-PW47 power supply to a single bar code reader.

Use a shielded cable (Belden 9316 recommended) to make the
connections.  Connect the shield to the ground screw on the reader’s
wiring base.

V-

24V+

Ground Screw
on Wiring Base

Reader
2755-PW46

Power Supply

The wiring base of the AdaptaScan Reader has an RS-485/RS-422
terminal block for point-to-point or network connections.

This section shows three connection options:

• Connecting readers to SLC 5/03

• Connecting readers to SLC 5/04 using two 1747-AIC Modules

• Connecting readers to SLC 5/04 using one 1747-AIC Module

Note:  You can use the 1761-NET-AIC Advanced Interface
Converter in place of the 1747-AIC Module.

Important: The DH485 network cable requires proper shielding,
grounding and termination.  Refer to Data
Highway/Data Highway Plus�/Data Highway DH485
Cable Installation Manual (Publication 1770-6.2.2).

Important: When setting up a DH-485 network using an
AdaptaScan, make sure that the nodes on the network
are in sequential order.  The SLC 5/03 or 5/04 should be
Node 1, and AdaptaScan should be Node 2, and each
node after that should be 3, 4, and so forth.  If other
DH-485 nodes are needed (i.e. DTAM, etc...), the
AdaptaScan node number(s) must be first.  Node gaps
must be avoided in order to prevent the AdaptaScan
from Soliciting of Successor (SOS).  By preventing
SOS, bar code throughput is maximized as it is sent to
the SLC.  In other words, when setting up the
AdaptaScan via DH-485 the first priority is to process
bar code data instead of finding node gaps.

Connecting a Power
Supply to the Reader

Connecting to the DH-485
Network
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Connecting Readers to SLC 5/03 Controller

You must use a link coupler if the distance between the reader and
the SLC is greater than 15.2 meters (50 feet).  The reader can
connect directly to another RS-485/RS-422 device.  Point-to-point
and network connections are the same.

The end devices on the DH-485 network must be terminated.  The
wiring base of the AdaptaScan Reader provides a termination switch.

Termination Switch

Ground

Shield

RS-485/422

RS-485/422

RS-422

RS-422

Term
A
B
Com
Shield
Chassis Gnd

SLC 5/03 Processor

Computer

1747-PIC

1747-AIC Module

2755-ASN AdaptaScan Software
SLC 500 Advanced Programming Software

AdaptaScan Wiring Base
RS-422/RS-485 Terminal

Power

Supply
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Connecting Readers to SLC 5/04 Controller – 2 AIC Modules

The SLC 5/04 controller requires two 1747-PIC converters and a
power supply to connect to the second 1747-AIC module.

The end devices on a DH-485 network must be terminated.  The
wiring base of the AdaptaScan Reader provides a termination switch.

SLC 5/04 Processor

Term
A
B
Com
Shield
Chassis Gnd

1747-PIC

1747-AIC Module

Term
A
B
Com
Shield
Chassis Gnd

1747-AIC Module

1747-P4 
24V dc Power Supply

1747-PIC

AdaptaScan Wiring Base
RS-422/RS-485 Terminal

Computer

The  1747-P4 Power Supply provides
power to both 1747-AIC modules (1 AMP,
24V dc). Otherwise use 2 power supplies.

DH-485 RS-232

RS-232

DH-485

Channel 0

Power

Supply
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Connecting Readers to SLC 5/04 Controller – 1 AIC Module

The SLC 5/04 controller requires two 1747-PIC converters.
However, you can use an RJ48 Y adapter (8-wire LAN phone jack
plug) to connect the two 1747-PIC modules.  The RJ48 Y adapter is
a modular adapter for 4-pair cable which parallels two 4-pair jacks
and one 4-pair modular plug.  This adapter eliminates the second
1747-AIC module shown in the previous SLC 5/04 network diagram.

The end devices on a DH-485 network must be terminated.  The
wiring base of the AdaptaScan Reader provides a termination switch.

SLC 5/04 Processor

Term
A
B
Com
Shield
Chassis Gnd

1747-PIC

1747-AIC Module

1747-PIC

AdaptaScan Wiring Base
RS-422/RS-485 Terminal

Computer

DH-485 RS-232

RS-232

DH-485

Channel 0

RJ48 Y Adapter
(8-wire LAN Phone Jack Plug)

Available from Anixter Company
Part No: Hubbell BR851-B

Phone: 414-355-0222

Power

Supply
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This section shows how to configure one the AdaptaScan Bar Code
Readers using the AdaptaScan Software (Catalog No. 2755-ASN).

The procedures in this section show how to:

• configure a bar code label and symbol

• define the DeviceNet node address of the AdaptaScan Reader

• configure the scanner

• configure the decoder trigger

• configure the serial port

• configure the format of messages and the message destination

The steps may vary for some procedures because of the different
requirements of applications.  For example, the bar code labels may
vary from one application to the next.

Create a New Project

Create a new project named DH485 Setup for the AdaptaScan Bar
Code Readers.

1. Choose New from the Project menu to create a new project.

2. Click the New button to add a bar code reader (Bar Code Reader
1) to the project.

Configuring Bar Code
Reader 1
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3. Choose Edit from the Project menu to rename the project DH485
Setup.

4. Click Save to save the project under the new name and then Close
to return to the Project dialog.

Define the Bar Code Label

1. Click the Label button to open the Bar Code Labels dialog.

2. Click the New button to add a label to open the Bar Code Label
dialog.

3. Click the New button to add a symbol.
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4. Select a symbology and any other parameters (Identifier, Lengths)
required by your application.

5. Click OK to return to the main Project dialog.

Define the DeviceNet Address

1. Click the Device button to open the Device dialog.

2. Select a DeviceNet address.

Note:  The DeviceNet address is not always the same as the
DH-485 node address.  A DH-485 node address is assigned later.

3. Connect the 2755-NC43 or -NC48 cable to the reader.

4. Click the Apply button.

5. Click Save and Close to return to the Project dialog.
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Configure the Scanner

1. Click the Scanner button on the Project dialog to open the
Scanner dialog.

2. Configure the scan pattern and use the Focus procedure for
optimum scanner focus.  Use the Apply button to send the
scanner configuration to the AdaptaScan.

3. Click the Close button and return to the Project dialog.

Configure the Decoder Trigger

This application uses a Timer to trigger the reader’s decoder.  The
Timer is typically used during application setup.  Refer to
Publication 2755-837 for other input sources that trigger the decoder.

1. Click the Decoder button from the main Project dialog.

2. Under Triggered By, select Timer  from the Input list.

3. Click Save and Close to return to the main Project dialog.
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Configure the Serial Port

1. Click the Serial Port button from the Project dialog.

2. Set the parameters as follows:

• From the Protocol list box, select DH-485
• From the Baud Rate list box, select 19,200
• From the Connection list box, select RS485

The Serial Port must match the host configuration.

3. Click the Edit button to select DH485 Slave Mode.
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DH485 Slave Mode

1. Click the Protocol Edit button in the Serial Port dialog.

2. Edit the parameters as follows:

• Click the PCCC Enabled box
• From the Master/Slave box, select Slave
• From the Node box, select 2

This is the DH485 node address.

3. Click OK to return to the main Serial Port dialog.

4. Click Save and Close to return to the main Project dialog.
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Configure for Match Codes

1. Click the Match Table button to open the Match Table dialog.

2. Click the New button to open the Match Function dialog and
create a Match Function.

3. Under Function, select Match Entry .

Match Entry specifies that a match occurs whenever decoded bar
code data matches the Rule:  entry.

4. Under Symbol Source, select Bar Code Reader 1.

5. Under Bar Code Labels and Symbols, select Symbol 1.

6. Click the Match Exactly box.

Match Exactly specifies that ASCII characters are matched
instead of a metacharacter rule.

7. Click the Outputs button to specify which output activates when a
match occurs.
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8. Under Available Outputs, select Discrete Input/Output 1.

9. Click the Add>> button to add this selection to
the Output To:  area.

10. Click OK to return to the main Match Table dialog.

Configure for a Package

1. Click the Package button to open the Package dialog.

2. Click the new button to create a Package.

3. Under Mode, select No-Read or No-Match.

This mode is used to determine when a label is not read or does
not match the rule defined in the Match function.
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4. Highlight Match 1 to enable the Match function.

5. Click OK to return to the main Package dialog.

Configure for an Output

1. Click the Output To button to specify which output activates
when a No-Read or No-Match occurs.

2. Under available Outputs, select Discrete Input/Output 2.

3. Click the Add>> button to add this selection to the
Output To:  area.

4. Click OK to return to the main Match Table dialog.

5. Click Save and Close to return to the Project dialog.
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From the main Project dialog, click the Download Device button to
download the configuration to the bar code reader.

This section describes how to view match codes in Slave Mode via
ladder logic.

Use the following SLC ladder logic for DH485 Slave Mode if the
AdaptaScan I/O LEDs cannot be used for viewing.

Read/Write

Read/Write:

Type:

Target Device:

Local/Remote:

Control Block:

Control Block Length:

MSG

READ

PEER-TO-PEER

485CIF

LOCAL

N7:50

14

B3

0
] [

Note:  You can only initiate one read or one write at a time.  Reads
and writes should never be initiated at the same time.

Message Instruction Configuration

For the Message Instruction, the configuration is listed in the table
below.

Parameter Configuration

Type Peer-to-Peer

Read/Write Read

Target Device 485CIF

Local/Remote Local

Control Block N7:50

Channel 0

Target Node 2

Destination File Access N7:80

Target Offset

255 (Change 255 to 256 or 100H in the third word of the
Control Block.  An offset greater than 255 tells the MSG
instruction that the SLC controller is talking to a bar code
device.)

Message Length in Elements 2

Message Timeout (seconds) 0

Sending the Configuration
to the Reader

SLC Ladder Logic
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Notes
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